Added extra/davfs2, fixed libwebkit

This commit is contained in:
Kevin Mihelich 2011-02-01 00:50:01 -05:00
parent 95292b18db
commit 1786831553
3 changed files with 98 additions and 6 deletions

37
extra/davfs2/PKGBUILD Normal file
View file

@ -0,0 +1,37 @@
# $Id: PKGBUILD 66598 2010-02-01 00:08:45Z giovanni $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# - we require a fix for glibc212, courtesy of gentoo (yuck), but only because people can't program right
plugrel=1
pkgname=davfs2
pkgver=1.4.5
pkgrel=1
pkgdesc="File system driver that allows you to mount a WebDAV server as a local disk drive."
arch=(i686 x86_64)
url="http://savannah.nongnu.org/projects/davfs2"
license=('GPL')
depends=('neon')
backup=(etc/davfs2/davfs2.conf etc/davfs2/secrets)
source=(http://mirrors.zerg.biz/nongnu/davfs2/${pkgname}-${pkgver}.tar.gz
davfs2-1.4.5-glibc212.patch)
sha256sums=('28f0ce00ddaf1ab93aa9f39db8d9f932d194c676bc21c3c8c3e2bea7f21274de'
'f8e8bcc99d36a661b5363fcd9ceae5eaf18010f165afcebd443eb36c75801a01')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p0 -i ${srcdir}/davfs2-1.4.5-glibc212.patch
dav_user=nobody dav_group=network ./configure --prefix=/usr --sysconfdir=/etc --disable-debug || return 1
make || return 1
# Create some dirs
install -d -m755 "${pkgdir}/sbin"
make DESTDIR="${pkgdir}" install || return 1
rm -f ${pkgdir}/sbin/{u,}mount.davfs
ln -sf /usr/sbin/mount.davfs "${pkgdir}/sbin/mount.davfs"
ln -sf /usr/sbin/umount.davfs "${pkgdir}/sbin/umount.davfs"
rm -f ${pkgdir}/usr/share/davfs2/{BUGS,COPYING,FAQ,NEWS,TODO,ChangeLog,GPL,README,THANKS}
}

View file

@ -0,0 +1,57 @@
--- src/dav_coda.c
+++ src/dav_coda.c
@@ -52,6 +52,9 @@
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif
+#ifdef HAVE_SYS_STAT_H
+#include <sys/stat.h>
+#endif
#include "defaults.h"
#include "mount_davfs.h"
--- src/dav_fuse.c
+++ src/dav_fuse.c
@@ -41,6 +41,12 @@
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_STAT_H
+#include <sys/stat.h>
+#endif
#include "defaults.h"
#include "mount_davfs.h"
--- src/kernel_interface.c
+++ src/kernel_interface.c
@@ -44,6 +44,12 @@
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_STAT_H
+#include <sys/stat.h>
+#endif
#ifdef HAVE_SYS_MOUNT_H
#include <sys/mount.h>
--- src/webdav.c
+++ src/webdav.c
@@ -47,6 +47,12 @@
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_STAT_H
+#include <sys/stat.h>
+#endif
#include <ne_alloc.h>
#include <ne_auth.h>

View file

@ -1,13 +1,11 @@
# $Id: PKGBUILD 104228 2010-12-30 22:22:42Z ibiru $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Plugbox changes: None, but this package has to be built by running:
# CPPFLAGS="-I/usr/include/cairo -I/usr/include/freetype2 \
# -I/usr/include/gtk-2.0 -I/usr/include/pango-1.0 -I/usr/lib/gtk-2.0/include \
# -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0 \
# -I/usr/include/gail-1.0" makepkg --asroot -Acs
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# - libtool is disabled for x86 because another tool takes its place for webkit.
# that tool doesn't run on arm, we have to use libtool.
plugrel=1
plugrel=2
pkgname=libwebkit
pkgver=1.2.6