mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
alarm/omxplayer-git to 515.7f3faf6-1
This commit is contained in:
parent
cba3451701
commit
1795acff44
3 changed files with 49 additions and 7 deletions
|
@ -1,7 +1,7 @@
|
|||
From 40bb25f8a0d66fad462d3f12f50873652adf54b9 Mon Sep 17 00:00:00 2001
|
||||
From 26db8c18b7eb27db94a664eb5875748dcead262e Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 24 Sep 2014 08:47:14 -0600
|
||||
Subject: [PATCH] alarm fixes
|
||||
Subject: [PATCH 1/2] alarm fixes
|
||||
|
||||
---
|
||||
Makefile | 31 +++++++++----------------------
|
||||
|
@ -74,7 +74,7 @@ index 5f4e414..cb836a5 100644
|
|||
uninstall:
|
||||
rm -rf /usr/bin/omxplayer
|
||||
diff --git a/omxplayer.cpp b/omxplayer.cpp
|
||||
index bde4536..6f5329f 100644
|
||||
index 8fe7bdd..d04cab4 100644
|
||||
--- a/omxplayer.cpp
|
||||
+++ b/omxplayer.cpp
|
||||
@@ -83,8 +83,8 @@ bool m_osd = true;
|
||||
|
@ -89,5 +89,5 @@ index bde4536..6f5329f 100644
|
|||
bool m_asked_for_font = false;
|
||||
bool m_asked_for_italic_font = false;
|
||||
--
|
||||
2.14.1
|
||||
2.18.0
|
||||
|
||||
|
|
39
alarm/omxplayer-git/0002-fix-keyboard-input.patch
Normal file
39
alarm/omxplayer-git/0002-fix-keyboard-input.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
From 5359a817574449563922cefedf402447b23bd5e6 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 4 Oct 2018 06:55:23 -0600
|
||||
Subject: [PATCH 2/2] fix keyboard input
|
||||
|
||||
From: https://github.com/popcornmix/omxplayer/issues/649
|
||||
---
|
||||
Keyboard.cpp | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Keyboard.cpp b/Keyboard.cpp
|
||||
index d38a102..d940421 100644
|
||||
--- a/Keyboard.cpp
|
||||
+++ b/Keyboard.cpp
|
||||
@@ -23,9 +23,11 @@ Keyboard::Keyboard()
|
||||
new_termios = orig_termios;
|
||||
new_termios.c_lflag &= ~(ICANON | ECHO | ECHOCTL | ECHONL);
|
||||
new_termios.c_cflag |= HUPCL;
|
||||
- new_termios.c_cc[VMIN] = 0;
|
||||
-
|
||||
+ new_termios.c_cc[VMIN] = 1;
|
||||
tcsetattr(STDIN_FILENO, TCSANOW, &new_termios);
|
||||
+
|
||||
+ orig_fl = fcntl(STDIN_FILENO, F_GETFL);
|
||||
+ fcntl(STDIN_FILENO, F_SETFL, FNDELAY);
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -67,6 +69,7 @@ void Keyboard::restore_term()
|
||||
if (isatty(STDIN_FILENO))
|
||||
{
|
||||
tcsetattr(STDIN_FILENO, TCSANOW, &orig_termios);
|
||||
+ fcntl(STDIN_FILENO, F_SETFL, orig_fl);
|
||||
}
|
||||
else
|
||||
{
|
||||
--
|
||||
2.18.0
|
||||
|
|
@ -5,7 +5,7 @@
|
|||
buildarch=20
|
||||
|
||||
pkgname=omxplayer-git
|
||||
pkgver=513.9680057
|
||||
pkgver=515.7f3faf6
|
||||
pkgrel=1
|
||||
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
|
||||
arch=('armv6h' 'armv7h')
|
||||
|
@ -17,9 +17,11 @@ optdepends=('ttf-freefont')
|
|||
provides=(omxplayer)
|
||||
conflicts=('omxplayer' 'omxplayer-bin')
|
||||
source=('git://github.com/popcornmix/omxplayer.git'
|
||||
'0001-alarm-fixes.patch')
|
||||
'0001-alarm-fixes.patch'
|
||||
'0002-fix-keyboard-input.patch')
|
||||
md5sums=('SKIP'
|
||||
'ec889c9d5e4d361ab9b4248633e429da')
|
||||
'fe4efaa1cf49570a65c51cef319fdf8b'
|
||||
'28cb317db75a866b22484ac16eb3152a')
|
||||
|
||||
pkgver() {
|
||||
cd omxplayer
|
||||
|
@ -30,6 +32,7 @@ prepare() {
|
|||
cd "${srcdir}/omxplayer"
|
||||
|
||||
git apply ../0001-alarm-fixes.patch
|
||||
git apply ../0002-fix-keyboard-input.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue