mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/elfutils to 0.189-1
This commit is contained in:
parent
0049bed1d3
commit
17c3bdfabb
2 changed files with 7 additions and 76 deletions
|
@ -8,22 +8,19 @@
|
|||
|
||||
pkgbase=elfutils
|
||||
pkgname=(debuginfod elfutils libelf)
|
||||
pkgver=0.188
|
||||
pkgrel=3.1
|
||||
pkgver=0.189
|
||||
pkgrel=1
|
||||
pkgdesc="Handle ELF object files and DWARF debugging information"
|
||||
arch=(x86_64)
|
||||
url="https://sourceware.org/elfutils/"
|
||||
license=(LGPL3 GPL3)
|
||||
makedepends=(bzip2 curl gcc-libs libarchive libmicrohttpd sqlite xz zlib zstd)
|
||||
options=(staticlibs)
|
||||
source=(https://sourceware.org/$pkgbase/ftp/$pkgver/$pkgbase-$pkgver.tar.bz2{,.sig}
|
||||
curl_7.85_compat.patch)
|
||||
sha512sums=('585551b2d937d19d1becfc2f28935db1dd1a3d25571a62f322b70ac8da98c1a741a55d070327705df6c3e2ee026652e0b9a3c733b050a0b0ec5f2fc75d5b74b5'
|
||||
'SKIP'
|
||||
'8f731bf2451ffd195a7da939d469486272873fa9fd19c2dc03a5311814840d7a7242b82de42162efc36404bee9a4fb3a6b85e0eb9fbb81e3c15f989cdd288c37')
|
||||
b2sums=('6b0474f1436eaf6af73b735b9b2ddd5448ab9c03fbaa0be745a31c89ae8f15b0e21a651409c38643ca125794ce82c19d7b46db4a079f3e72cb919d643560e7a4'
|
||||
'SKIP'
|
||||
'92b92aefc011b4be7ed00baca28c3447003baa864be58482bf0c220dcd6ad75133c6e34731eaf7e3cc97dbb3e1f85d1fce88cb532c3da37b36802d2c6e7a9e36')
|
||||
source=(https://sourceware.org/$pkgbase/ftp/$pkgver/$pkgbase-$pkgver.tar.bz2{,.sig})
|
||||
sha512sums=('93a877e34db93e5498581d0ab2d702b08c0d87e4cafd9cec9d6636dfa85a168095c305c11583a5b0fb79374dd93bc8d0e9ce6016e6c172764bcea12861605b71'
|
||||
'SKIP')
|
||||
b2sums=('30596271e14cf3408326abc38a9775b849b8cb0ee119a5455df9434a7d3b9a57afb15e0236a179a26c7bd400d303749964c9d6350c419f747784fd99d12517e0'
|
||||
'SKIP')
|
||||
validpgpkeys=(
|
||||
'47CC0331081B8BC6D0FD4DA08370665B57816A6A' # Mark J. Wielaard <mark@klomp.org>
|
||||
'EC3CFE88F6CA0788774F5C1D1AA44BE649DE760A' # Mark Wielaard <mjw@gnu.org>
|
||||
|
@ -40,12 +37,6 @@ _pick() {
|
|||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$pkgver
|
||||
# Use CURLOPT_PROTOCOLS_STR for libcurl >= 7.85.0
|
||||
# https://sourceware.org/git/?p=elfutils.git;a=commit;h=6560fb26a62ef135a804357ef4f15a47de3e49b3
|
||||
patch -Np1 < ../curl_7.85_compat.patch
|
||||
cd ..
|
||||
|
||||
# remove failing test due to missing glibc debug package during test: https://bugs.archlinux.org/task/74875
|
||||
sed -e 's/run-backtrace-native.sh//g' -i $pkgbase-$pkgver/tests/Makefile.am
|
||||
(
|
||||
|
|
|
@ -1,60 +0,0 @@
|
|||
diff --git a/debuginfod/debuginfod-client.c b/debuginfod/debuginfod-client.c
|
||||
index a16165bd1..1ce456327 100644
|
||||
--- a/debuginfod/debuginfod-client.c
|
||||
+++ b/debuginfod/debuginfod-client.c
|
||||
@@ -1336,8 +1336,13 @@ debuginfod_query_server (debuginfod_client *c,
|
||||
|
||||
/* Only allow http:// + https:// + file:// so we aren't being
|
||||
redirected to some unsupported protocol. */
|
||||
+#if CURL_AT_LEAST_VERSION(7, 85, 0)
|
||||
+ curl_easy_setopt_ck(data[i].handle, CURLOPT_PROTOCOLS_STR,
|
||||
+ "http,https,file");
|
||||
+#else
|
||||
curl_easy_setopt_ck(data[i].handle, CURLOPT_PROTOCOLS,
|
||||
(CURLPROTO_HTTP | CURLPROTO_HTTPS | CURLPROTO_FILE));
|
||||
+#endif
|
||||
curl_easy_setopt_ck(data[i].handle, CURLOPT_URL, data[i].url);
|
||||
if (vfd >= 0)
|
||||
curl_easy_setopt_ck(data[i].handle, CURLOPT_ERRORBUFFER,
|
||||
diff --git a/debuginfod/debuginfod-client.c b/debuginfod/debuginfod-client.c
|
||||
index 8873fcc8c..692aeccec 100644
|
||||
--- a/debuginfod/debuginfod-client.c
|
||||
+++ b/debuginfod/debuginfod-client.c
|
||||
@@ -1456,7 +1456,7 @@ debuginfod_query_server (debuginfod_client *c,
|
||||
deflate-compressing proxies, this number is likely to be
|
||||
unavailable, so -1 may show. */
|
||||
CURLcode curl_res;
|
||||
-#ifdef CURLINFO_CONTENT_LENGTH_DOWNLOAD_T
|
||||
+#if CURL_AT_LEAST_VERSION(7, 55, 0)
|
||||
curl_off_t cl;
|
||||
curl_res = curl_easy_getinfo(target_handle,
|
||||
CURLINFO_CONTENT_LENGTH_DOWNLOAD_T,
|
||||
@@ -1491,7 +1491,7 @@ debuginfod_query_server (debuginfod_client *c,
|
||||
if (target_handle) /* we've committed to a server; report its download progress */
|
||||
{
|
||||
CURLcode curl_res;
|
||||
-#ifdef CURLINFO_SIZE_DOWNLOAD_T
|
||||
+#if CURL_AT_LEAST_VERSION(7, 55, 0)
|
||||
curl_off_t dl;
|
||||
curl_res = curl_easy_getinfo(target_handle,
|
||||
CURLINFO_SIZE_DOWNLOAD_T,
|
||||
diff --git a/debuginfod/debuginfod-client.c b/debuginfod/debuginfod-client.c
|
||||
index 692aeccec..a16165bd1 100644
|
||||
--- a/debuginfod/debuginfod-client.c
|
||||
+++ b/debuginfod/debuginfod-client.c
|
||||
@@ -105,6 +105,13 @@ void debuginfod_end (debuginfod_client *c) { }
|
||||
#include <fts.h>
|
||||
#endif
|
||||
|
||||
+/* Older curl.h don't define CURL_AT_LEAST_VERSION. */
|
||||
+#ifndef CURL_AT_LEAST_VERSION
|
||||
+ #define CURL_VERSION_BITS(x,y,z) ((x)<<16|(y)<<8|(z))
|
||||
+ #define CURL_AT_LEAST_VERSION(x,y,z) \
|
||||
+ (LIBCURL_VERSION_NUM >= CURL_VERSION_BITS(x, y, z))
|
||||
+#endif
|
||||
+
|
||||
#include <pthread.h>
|
||||
|
||||
static pthread_once_t init_control = PTHREAD_ONCE_INIT;
|
||||
--
|
||||
2.31.1
|
Loading…
Reference in a new issue