removed community/snapper

This commit is contained in:
Kevin Mihelich 2018-10-18 00:54:17 +00:00
parent c754cfeae0
commit 17eb9f97c2
2 changed files with 0 additions and 92 deletions

View file

@ -1,65 +0,0 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
# Contributor: Tom Kuther <gimpel@sonnenkinder.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - pass LIBS="-lboost_thread -lboost_system" to configure to fix linking on ARM
pkgname=snapper
pkgver=0.6.0
pkgrel=1
pkgdesc="A tool for managing BTRFS and LVM snapshots. It can create, diff and restore snapshots and provides timelined auto-snapping."
arch=('x86_64')
url="http://snapper.io"
license=('GPL2')
depends=('btrfs-progs' 'libxml2' 'dbus' 'boost-libs' 'acl')
makedepends=('boost' 'lvm2' 'libxslt' 'docbook-xsl' 'pam' 'git' 'systemd')
optdepends=('pam: pam_snapper')
backup=('etc/conf.d/snapper')
source=("ftp://ftp.suse.com/pub/projects/$pkgname/$pkgname-$pkgver.tar.bz2")
sha256sums=('b8b678a926689becd645d28ddccaaa57d4853e0681144d2fdaab57e3e3644f30')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
# cron names
sed -e 's@suse.de-snapper@snapper@g' -i scripts/Makefile.am
# fix sysconf dir
sed -e 's@/etc/sysconfig@/etc/conf.d@g' -i scripts/*snapper*
# fix pam plugin install location
sed -i -e 's@shell echo /@shell echo /usr/@g' pam/Makefile.am
# all in /usr/bin
sed -i -e 's@/usr/sbin@/usr/bin@g' data/org.opensuse.Snapper.service
# NTP drift file location
sed -i -e 's@/var/lib/ntp/drift/ntp.drift@/var/lib/ntp/ntp.drift@' data/base.txt
# man pages sysconfig location
sed -i -e 's@/etc/sysconfig@/etc/conf.d@g' doc/*
}
build() {
cd "$srcdir/$pkgname-$pkgver"
aclocal
libtoolize --force --automake --copy
autoheader
automake --add-missing --copy
autoconf
LIBS="-lboost_thread -lboost_system" ./configure --prefix=/usr \
--sbindir=/usr/bin \
--with-conf=/etc/conf.d \
--disable-zypp \
--disable-silent-rules
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 data/sysconfig.snapper \
"$pkgdir"/etc/conf.d/snapper
}

View file

@ -1,27 +0,0 @@
From 4f3f9d516c68c99b412b6e4b2eaa6e25f389b337 Mon Sep 17 00:00:00 2001
From: Adam Majer <amajer@suse.de>
Date: Tue, 22 May 2018 09:43:21 +0200
Subject: [PATCH] Add missing pthread library for server
While building snapper with Boost 1.67, the following error
occurred,
/usr/lib64/gcc/x86_64-suse-linux/7/../../../../x86_64-suse-linux/bin/ld: Client.o: undefined reference to symbol 'pthread_condattr_setclock@@GLIBC_2.3.3'
/lib64/libpthread.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:440: snapperd] Error 1
make[2]: Leaving directory '/home/abuild/rpmbuild/BUILD/snapper-0.5.4/server'
---
server/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/server/Makefile.am b/server/Makefile.am
index 2a6a4c2d..009fe414 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -14,4 +14,4 @@ snapperd_SOURCES = \
Types.cc Types.h
snapperd_LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lrt
-snapperd_LDFLAGS = -lboost_system -lboost_thread
+snapperd_LDFLAGS = -lboost_system -lboost_thread -lpthread