mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
17faa60863
19 changed files with 136 additions and 127 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=mplayer-vaapi
|
||||
pkgver=36265
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
pkgdesc="A movie player, compiled with vaapi support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://gitorious.org/vaapi/mplayer"
|
||||
|
|
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=mythtv
|
||||
pkgver=0.27
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
epoch=1
|
||||
pkgdesc="A Homebrew PVR project"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -31,10 +31,10 @@ conflicts=('myththemes' 'mythplugins-mythvideo')
|
|||
replaces=('myththemes' 'mythplugins-mythvideo')
|
||||
backup=()
|
||||
install='mythtv.install'
|
||||
source=("http://www.$pkgname.org/download/$pkgname/$pkgver"
|
||||
source=("$pkgname-$pkgver.tar.gz::http://www.$pkgname.org/download/$pkgname/$pkgver"
|
||||
'mythbackend.service'
|
||||
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch')
|
||||
sha256sums=('670b378e379df05a4f2ac28cc3cb2578587b42cb03710e0b230b75d692f8e2b8'
|
||||
sha256sums=('49789de705be73275325b1a4984b727cf8284fdc4ae6b041ad152857c830dc46'
|
||||
'f628f44164ce773ae54d320fb2f65353cacf9deec16981e4e56316ac33000a2f'
|
||||
'8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3')
|
||||
|
||||
|
|
|
@ -1,59 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
|
||||
# Contributor: Paulo Matias <matiasΘarchlinux-br·org>
|
||||
# Contributor: Georgij Kondratjev <smpuj@bk.ru>
|
||||
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - move make NETSURF_* defines into Makefile.config (FS #37104)
|
||||
|
||||
pkgname=netsurf
|
||||
pkgver=3.0
|
||||
pkgrel=4
|
||||
pkgdesc='Lightweight and fast web browser'
|
||||
arch=('x86_64' 'i686')
|
||||
url='http://www.netsurf-browser.org/'
|
||||
license=('MIT' 'GPL2')
|
||||
depends=('gtk2' 'libmng' 'curl' 'librsvg' 'desktop-file-utils' 'libnsbmp' 'libnsgif' 'libcss' 'libwebp' 'libdom' 'lcms') # 'libharu' 'gstreamer0.10'
|
||||
makedepends=('js' 're2c' 'gendesk' 'netsurf-buildsystem' 'libglade' 'addinclude')
|
||||
install="$pkgname.install"
|
||||
source=("netsurf.png::http://ubuntu.allmyapps.com/data/n/e/netsurf-netsurf-web-browser/icon_48x48_netsurf.png"
|
||||
"http://download.$pkgname-browser.org/$pkgname/releases/source/$pkgname-$pkgver-src.tar.gz")
|
||||
sha256sums=('f0dbcc5d80bf03d706aa8b28a322aa7f169a40813848c2d1505691f6e2c7ef00'
|
||||
'7c6a48d3cc3e9a3e3a51b532ddf60f7697e97bf8b61a6d3b2ced1a2e89fbccc6')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
addinclude image/rsvg.c stdio
|
||||
addinclude image/mng.c stdio
|
||||
addinclude image/png.c stdio
|
||||
|
||||
gendesk --pkgname "$pkgname" --pkgdesc "$pkgdesc" --exec 'netsurf %U' \
|
||||
--genericname 'Web Browser' --comment 'Lightweight web browser' \
|
||||
--mimetypes 'text/html;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/geo'
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
echo "override NETSURF_USE_WEBP := YES" > Makefile.config
|
||||
echo "override NETSURF_USE_VIDEO := NO" >> Makefile.config
|
||||
echo "override NETSURF_USE_HARU_PDF := NO" >> Makefile.config
|
||||
|
||||
make \
|
||||
PREFIX=/usr \
|
||||
TARGET=gtk
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
make install PREFIX=/usr DESTDIR="$pkgdir"
|
||||
install -Dm644 "../$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
|
||||
install -Dm644 "$pkgname.desktop" \
|
||||
"$pkgdir/usr/share/applications/$pkgname.desktop"
|
||||
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,14 +0,0 @@
|
|||
post_upgrade() {
|
||||
#gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_install() {
|
||||
post_upgrade
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_upgrade
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -8,7 +8,7 @@
|
|||
# - patch to use the system crypto++ library
|
||||
|
||||
pkgname=synergy
|
||||
pkgver=1.4.14
|
||||
pkgver=1.4.15
|
||||
pkgrel=1
|
||||
pkgdesc="Share a single mouse and keyboard between multiple computers"
|
||||
url="http://synergy-foss.org"
|
||||
|
@ -21,7 +21,7 @@ source=("http://synergy.googlecode.com/files/$pkgname-$pkgver-Source.tar.gz"
|
|||
"system-cryptopp.patch"
|
||||
"synergys.socket"
|
||||
"synergys.service")
|
||||
sha512sums=('3e9ca96f36573e400c9694daba026322cbf36bbabdbf69687cbadb6010834d1afd81845533775564ba7aadbf3a8be8582d9e5b9d33abfa483a174b40e084add4'
|
||||
sha512sums=('857e8cbfb0b32c7dc325de5765f182f4e4fb198443b4a3e26d38c2d3dec3819e57057b91a202b53c86d4fad18154d1d58b401812dd8fabc384255e44d4b4b01a'
|
||||
'6fc79d78c24daaafd7e50c31581788d48fb1591105644a55584282c55c4cdee10e4f374216fecd7253030e692d358165ef349caab1675ed1d1d1f101fb46b8c0'
|
||||
'f7d918faf4a25654786f270fc48b6e4089ecd1b2f504bb90de543b47a862733f7be067e06fd613d621bba48d20dc63214966e2cfbd2cb3fcbfe623d6d41f10ad'
|
||||
'a10dfe5b24ac6f4a2ef3a3a9f8a6a3c432b91d5e59d1fae2258d37c5be00ac8f172656fa0d213012c7dc94ab8c04c3945ae33acfcd5db5fad8b37ccc9f5e980f')
|
||||
|
|
|
@ -16,7 +16,7 @@ noautobuild=1
|
|||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
|
||||
pkgver=4.8.2
|
||||
pkgrel=1
|
||||
pkgrel=3
|
||||
#_snapshot=4.8-20130725
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -24,7 +24,7 @@ license=('GPL' 'LGPL' 'FDL' 'custom')
|
|||
url="http://gcc.gnu.org"
|
||||
makedepends=('binutils>=2.23' 'libmpc' 'cloog' 'doxygen')
|
||||
checkdepends=('dejagnu' 'inetutils')
|
||||
options=('!libtool' '!emptydirs' '!distcc')
|
||||
options=('!emptydirs' '!distcc')
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
gcc-4.8-filename-output.patch)
|
||||
|
@ -139,6 +139,7 @@ package_gcc()
|
|||
pkgdesc="The GNU Compiler Collection - C and C++ frontends"
|
||||
depends=("gcc-libs=$pkgver-$pkgrel" 'binutils>=2.23' 'libmpc' 'cloog')
|
||||
groups=('base-devel')
|
||||
options=('staticlibs')
|
||||
install=gcc.install
|
||||
|
||||
cd ${srcdir}/gcc-build
|
||||
|
@ -161,6 +162,9 @@ package_gcc()
|
|||
rm -f $pkgdir/usr/share/locale/{de,fr}/LC_MESSAGES/libstdc++.mo
|
||||
rm -f $pkgdir/usr/share/man/man1/{gccgo,gfortran}.1
|
||||
|
||||
# remove static libraries - note libstdc++.a is needed for the binutils and glibc testsuite
|
||||
rm $pkgdir/usr/lib/lib{asan,gomp,itm,mudflap{,th},quadmath}.a
|
||||
|
||||
# many packages expect this symlink
|
||||
#install -dm755 ${pkgdir}/lib
|
||||
ln -s gcc ${pkgdir}/usr/bin/cc
|
||||
|
@ -208,6 +212,7 @@ package_gcc-fortran()
|
|||
{
|
||||
pkgdesc="Fortran front-end for GCC"
|
||||
depends=("gcc=$pkgver-$pkgrel")
|
||||
options=('staticlibs' '!emptydirs')
|
||||
install=gcc-fortran.install
|
||||
|
||||
cd ${srcdir}/gcc-build
|
||||
|
@ -218,12 +223,13 @@ package_gcc-fortran()
|
|||
|
||||
ln -s gfortran ${pkgdir}/usr/bin/f95
|
||||
|
||||
# remove files included in gcc-libs or gcc
|
||||
# remove files included in gcc-libs or gcc and unnneeded static lib
|
||||
rm -f ${pkgdir}/usr/lib/lib{gfortran,gcc_s}.so*
|
||||
rm -f ${pkgdir}/usr/lib/libquadmath.{a,so*}
|
||||
rm -f ${pkgdir}/usr/lib/gcc/$CHOST/${pkgver}/{*.o,libgc*}
|
||||
rm -f ${pkgdir}/usr/share/info/libquadmath.info
|
||||
rm -rf ${pkgdir}/usr/lib/gcc/$CHOST/${pkgver}/include
|
||||
rm ${pkgdir}/usr/lib/libgfortran.a
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
|
@ -254,12 +260,14 @@ package_gcc-go()
|
|||
{
|
||||
pkgdesc="Go front-end for GCC"
|
||||
depends=("gcc=$pkgver-$pkgrel")
|
||||
options=('staticlibs' '!emptydirs')
|
||||
install=gcc-go.install
|
||||
|
||||
cd ${srcdir}/gcc-build
|
||||
make -j1 DESTDIR=$pkgdir install-target-libgo
|
||||
make -j1 -C gcc DESTDIR=$pkgdir go.install-{common,man,info}
|
||||
install -Dm755 gcc/go1 $pkgdir/usr/lib/gcc/$CHOST/$pkgver/go1
|
||||
rm $pkgdir/usr/lib/lib{atomic,go}.a
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
|
|
|
@ -4,6 +4,8 @@
|
|||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
|
||||
# NOTE: valgrind requires rebuilt with each major glibc version
|
||||
|
||||
# NOTE: adjust version in install script when locale files are updated
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Patch for ld-linux-armhf.so.3 transition and symlink ld-linux.so.3
|
||||
# - Patch for hard-float ld.so.cache transition
|
||||
|
@ -14,7 +16,7 @@ noautobuild=1
|
|||
|
||||
pkgname=glibc
|
||||
pkgver=2.18
|
||||
pkgrel=5
|
||||
pkgrel=8
|
||||
pkgdesc="GNU C Library"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/libc"
|
||||
|
@ -25,14 +27,15 @@ makedepends=('gcc>=4.7')
|
|||
backup=(etc/gai.conf
|
||||
etc/locale.gen
|
||||
etc/nscd.conf)
|
||||
options=('!strip' '!distcc')
|
||||
options=('!strip' 'staticlibs' '!distcc')
|
||||
install=glibc.install
|
||||
source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
glibc-2.18-make-4.patch
|
||||
glibc-2.18-readdir_r-CVE-2013-4237.patch
|
||||
glibc-2.18-malloc-corrupt-CVE-2013-4332.patch
|
||||
glibc-2.18-strcoll-CVE-2012-4412+4424.patch
|
||||
glibc-2.18-malloc-corrupt-CVE-2013-4332.patch
|
||||
glibc-2.18-strcoll-CVE-2012-4412+4424.patch
|
||||
glibc-2.18-strstr-hackfix.patch
|
||||
glibc-2.18-ptr-mangle-CVE-2013-4788.patch
|
||||
glibc-2.18-ptr-mangle-CVE-2013-4788.patch
|
||||
local-soname-hack.diff
|
||||
fix-hf-ld.so.cache.patch
|
||||
nscd.service
|
||||
|
@ -41,6 +44,7 @@ source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
|
|||
locale-gen)
|
||||
md5sums=('88fbbceafee809e82efd52efa1e3c58f'
|
||||
'SKIP'
|
||||
'e1883c2d1b01ff73650db5f5bb5a5a52'
|
||||
'154da6bf5a5248f42a7bf5bf08e01a47'
|
||||
'b79561ab9dce900e9bbeaf0d49927c2b'
|
||||
'c7264b99d0f7e51922a4d3126182c40a'
|
||||
|
@ -51,11 +55,14 @@ md5sums=('88fbbceafee809e82efd52efa1e3c58f'
|
|||
'd5fab2cd3abea65aa5ae696ea4a47d6b'
|
||||
'da662ca76e7c8d7efbc7986ab7acea2d'
|
||||
'07ac979b6ab5eeb778d55f041529d623'
|
||||
'476e9113489f93b348b21e144b6a8fcf')
|
||||
'b5fd017036fb91199ee76f670da8c15b')
|
||||
|
||||
prepare() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
# compatibility with make-4.0 (submitted upstream)
|
||||
patch -p1 -i $srcdir/glibc-2.18-make-4.patch
|
||||
|
||||
# upstream commit 91ce4085
|
||||
patch -p1 -i $srcdir/glibc-2.18-readdir_r-CVE-2013-4237.patch
|
||||
|
||||
|
@ -125,7 +132,7 @@ build() {
|
|||
}
|
||||
|
||||
check() {
|
||||
# bug to file - the linker commands need to be reordered
|
||||
# the linker commands need to be reordered - fixed in 2.19
|
||||
LDFLAGS=${LDFLAGS/--as-needed,/}
|
||||
|
||||
cd ${srcdir}/glibc-build
|
||||
|
@ -157,6 +164,11 @@ package() {
|
|||
sed -e '1,3d' -e 's|/| |g' -e 's|\\| |g' -e 's|^|#|g' \
|
||||
${srcdir}/glibc-${pkgver}/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
|
||||
|
||||
# remove the static libraries that have a shared counterpart
|
||||
cd $pkgdir/usr/lib
|
||||
# note: keep libc, libdl, libm, libpthread for binutils testsuite
|
||||
rm lib{anl,BrokenLocale,crypt,nsl,resolv,rt,util}.a
|
||||
|
||||
# ALARM: symlink ld-linux.so.3 for hard-float
|
||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && ln -s /lib/ld-${pkgver}.so ${pkgdir}/usr/lib/ld-linux.so.3
|
||||
|
||||
|
|
45
core/glibc/glibc-2.18-make-4.patch
Normal file
45
core/glibc/glibc-2.18-make-4.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
From dc76f0c32dae689a08aa21a1d206d4cd62adb278 Mon Sep 17 00:00:00 2001
|
||||
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
|
||||
Date: Thu, 10 Oct 2013 14:26:12 +0900
|
||||
Subject: [PATCH] configure: allow building with GNU Make 4
|
||||
|
||||
Currently, configure errors telling make 4 is too old
|
||||
since it does not match our regexp.
|
||||
|
||||
configure.in: allow GNU Make 4.*
|
||||
|
||||
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
|
||||
---
|
||||
configure | 2 +-
|
||||
configure.in | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 5e2f4d0..e139bf0 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -4761,7 +4761,7 @@ $as_echo_n "checking version of $MAKE... " >&6; }
|
||||
ac_prog_version=`$MAKE --version 2>&1 | sed -n 's/^.*GNU Make[^0-9]*\([0-9][0-9.]*\).*$/\1/p'`
|
||||
case $ac_prog_version in
|
||||
'') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
|
||||
- 3.79* | 3.[89]*)
|
||||
+ 3.79* | 3.[89]* | 4.*)
|
||||
ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
|
||||
*) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index a7f9881..95c36b6 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -984,7 +984,7 @@ AC_CHECK_PROG_VER(CC, ${ac_tool_prefix}gcc ${ac_tool_prefix}cc, -v,
|
||||
critic_missing="$critic_missing gcc")
|
||||
AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
|
||||
[GNU Make[^0-9]*\([0-9][0-9.]*\)],
|
||||
- [3.79* | 3.[89]*], critic_missing="$critic_missing make")
|
||||
+ [3.79* | 3.[89]* | 4.*], critic_missing="$critic_missing make")
|
||||
|
||||
AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
|
||||
[GNU gettext.* \([0-9]*\.[0-9.]*\)],
|
||||
--
|
||||
1.8.4.1
|
||||
|
|
@ -3,7 +3,10 @@ filelist=(libc.info{,-1,-2,-3,-4,-5,-6,-7,-8,-9,-10,-11})
|
|||
|
||||
post_upgrade() {
|
||||
ldconfig -r .
|
||||
locale-gen
|
||||
|
||||
if [[ $(vercmp 2.18 $2) = 1 ]]; then
|
||||
locale-gen
|
||||
fi
|
||||
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
|
|
|
@ -4,39 +4,53 @@ set -e
|
|||
|
||||
LOCALEGEN=/etc/locale.gen
|
||||
LOCALES=/usr/share/i18n/locales
|
||||
if [ -n "$POSIXLY_CORRECT" ]; then
|
||||
unset POSIXLY_CORRECT
|
||||
fi
|
||||
unset POSIXLY_CORRECT
|
||||
|
||||
|
||||
[ -f $LOCALEGEN -a -s $LOCALEGEN ] || exit 0;
|
||||
[ -s "$LOCALEGEN" ] || exit 0
|
||||
|
||||
# Remove all old locale dir and locale-archive before generating new
|
||||
# locale data.
|
||||
rm -rf /usr/lib/locale/* || true
|
||||
rm -rf /usr/lib/locale/*
|
||||
|
||||
umask 022
|
||||
|
||||
is_entry_ok() {
|
||||
if [ -n "$locale" -a -n "$charset" ] ; then
|
||||
true
|
||||
else
|
||||
echo "error: Bad entry '$locale $charset'"
|
||||
false
|
||||
fi
|
||||
gen() {
|
||||
local locale=$1
|
||||
local charset=$2
|
||||
local input=
|
||||
|
||||
if [ -z "$locale" ] || [ -z "$charset" ]; then
|
||||
echo "error: Bad entry '$locale $charset'"
|
||||
return
|
||||
fi
|
||||
|
||||
printf ' %s.%s\n' "$(echo "$locale" | sed 's/\([^.\@]*\).*/\1/')" "$charset"
|
||||
|
||||
if [ -f "$LOCALES/$locale" ]; then
|
||||
input=$locale
|
||||
else
|
||||
input=$(echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/')
|
||||
fi
|
||||
|
||||
localedef -i "$input" -c -f "$charset" -A /usr/share/locale/locale.alias "$locale"
|
||||
}
|
||||
|
||||
maxjobs=$(grep -c processor /proc/cpuinfo 2>/dev/null || echo 1)
|
||||
echo "Generating locales..."
|
||||
while read locale charset; do \
|
||||
case $locale in \#*) continue;; "") continue;; esac; \
|
||||
is_entry_ok || continue
|
||||
echo -n " `echo $locale | sed 's/\([^.\@]*\).*/\1/'`"; \
|
||||
echo -n ".$charset"; \
|
||||
echo -n `echo $locale | sed 's/\([^\@]*\)\(\@.*\)*/\2/'`; \
|
||||
echo -n '...'; \
|
||||
if [ -f $LOCALES/$locale ]; then input=$locale; else \
|
||||
input=`echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; fi; \
|
||||
localedef -i $input -c -f $charset -A /usr/share/locale/locale.alias $locale; \
|
||||
echo ' done'; \
|
||||
case $locale in
|
||||
\#*|'')
|
||||
continue
|
||||
;;
|
||||
esac
|
||||
gen "$locale" "$charset" &
|
||||
|
||||
# keep no more than $maxjobs jobs in flight
|
||||
while [ $(jobs | wc -l) -ge $maxjobs ]; do
|
||||
sleep 0.25
|
||||
jobs >/dev/null
|
||||
done
|
||||
done < $LOCALEGEN
|
||||
wait
|
||||
|
||||
echo "Generation complete."
|
||||
|
|
|
@ -9,7 +9,7 @@ pkgname=('linux-raspberrypi-latest' 'linux-headers-raspberrypi-latest')
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.11
|
||||
pkgver=${_basekernel}.6
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
bfqver=v6r2
|
||||
uksmver="0.1.2.2"
|
||||
uksmname="v3.10"
|
||||
|
@ -30,7 +30,7 @@ source=('config'
|
|||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${_basekernel}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${_basekernel}.patch"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${_basekernel}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${_basekernel}.0.patch")
|
||||
|
||||
md5sums=('a4ad14279f2a92b1132df438ddfcf86f'
|
||||
md5sums=('4e3e7627f1256e657dbd5afe50e3b957'
|
||||
'c0d63f4d42fd334bf31e4f749d4694f3'
|
||||
'd00814b57448895e65fbbc800e8a58ba'
|
||||
'9335d1263fd426215db69841a380ea26'
|
||||
|
|
|
@ -1937,7 +1937,7 @@ CONFIG_W1_SLAVE_THERM=m
|
|||
CONFIG_W1_SLAVE_SMEM=m
|
||||
CONFIG_W1_SLAVE_DS2408=m
|
||||
CONFIG_W1_SLAVE_DS2408_READBACK=y
|
||||
# CONFIG_W1_SLAVE_DS2413 is not set
|
||||
CONFIG_W1_SLAVE_DS2413=m
|
||||
CONFIG_W1_SLAVE_DS2423=m
|
||||
CONFIG_W1_SLAVE_DS2431=m
|
||||
CONFIG_W1_SLAVE_DS2433=m
|
||||
|
|
|
@ -21,8 +21,8 @@ buildarch=20
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=30.0.1599.101
|
||||
pkgrel=1.1
|
||||
pkgver=30.0.1599.114
|
||||
pkgrel=1
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('armv6h' 'armv7h')
|
||||
url="http://www.chromium.org/"
|
||||
|
@ -47,7 +47,7 @@ source=(https://gsdview.appspot.com/chromium-browser-official/$pkgname-$pkgver.t
|
|||
arm-webrtc-fix.patch
|
||||
skia.patch
|
||||
v6-ffmpeg.patch)
|
||||
sha256sums=('d9596f28c6922bb5c8d03215ece1a7c51421a2e6f882213eb997f98bd34ca42d'
|
||||
sha256sums=('82ff2b54cb6fa9f314098e9905e79d578d97940bab05111a3c0c782217c2b760'
|
||||
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
|
||||
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
|
||||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
|
|
|
@ -9,14 +9,13 @@
|
|||
|
||||
pkgname=fftw
|
||||
pkgver=3.3.3
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="A library for computing the discrete Fourier transform (DFT)"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL2')
|
||||
url="http://www.fftw.org/"
|
||||
depends=('glibc' 'bash')
|
||||
makedepends=('gcc-fortran')
|
||||
options=('!libtool')
|
||||
source=("http://www.fftw.org/${pkgname}-${pkgver}.tar.gz")
|
||||
install=fftw.install
|
||||
sha1sums=('11487180928d05746d431ebe7a176b52fe205cf9')
|
||||
|
|
|
@ -6,13 +6,14 @@
|
|||
|
||||
pkgname=gst-plugins-bad
|
||||
pkgver=1.2.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL')
|
||||
url="http://gstreamer.freedesktop.org/"
|
||||
depends=('mjpegtools' 'gst-plugins-base-libs' 'curl' 'chromaprint' 'libmms' 'faad2' 'mpg123' 'faac' 'celt' 'libdca' 'soundtouch' 'spandsp' 'libdvdnav' 'libmodplug' 'libgme' 'opus' 'wayland' 'neon' 'libofa' 'fluidsynth' 'openjpeg' 'libwebp' 'libsrtp' 'gnutls')
|
||||
makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'valgrind' 'wildmidi')
|
||||
makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'valgrind' 'wildmidi'
|
||||
'gobject-introspection')
|
||||
options=(!libtool !emptydirs)
|
||||
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz)
|
||||
sha256sums=('a12fac6c106a7e4ae8bb2c7da508688d7db532b818319df2202f497cbd930afa')
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
pkgbase=gstreamer0.10-bad
|
||||
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
|
||||
pkgver=0.10.23
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=('i686' 'x86_64')
|
||||
license=('LGPL' 'GPL')
|
||||
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus')
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=libvpx
|
||||
pkgver=1.2.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="The VP8 Codec SDK"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.webmproject.org/"
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
pkgbase=mplayer
|
||||
pkgname=('mplayer' 'mencoder')
|
||||
pkgver=36285
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient'
|
||||
'aalib' 'jack' 'libcaca' 'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx'
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=vlc
|
||||
pkgver=2.1.0
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.videolan.org/vlc/"
|
||||
|
|
Loading…
Reference in a new issue