diff --git a/alarm/raspberrypi-firmware/PKGBUILD b/alarm/raspberrypi-firmware/PKGBUILD
index 52f0081e0..afe8907dc 100644
--- a/alarm/raspberrypi-firmware/PKGBUILD
+++ b/alarm/raspberrypi-firmware/PKGBUILD
@@ -6,7 +6,7 @@ buildarch=28
 
 pkgname=raspberrypi-firmware
 pkgver=20210128
-pkgrel=1
+pkgrel=2
 _commitfirmware=496e65477e06172ea20602e365d3790632c3cc06
 _commituserland=4a0a19b88b43e48c6b51b526b9378289fb712a4c
 pkgdesc="Firmware tools, libraries, and headers for Raspberry Pi"
@@ -18,13 +18,15 @@ replaces=('raspberrypi-firmware-tools')
 provides=('raspberrypi-firmware-tools')
 options=(!strip)
 source=('00-raspberrypi-firmware.conf'
-        '10-raspberrypi-firmware.rules')
+        '10-raspberrypi-firmware.rules'
+        'raspberrypi-firmware.sh')
 source_armv6h=("https://github.com/raspberrypi/firmware/archive/$_commitfirmware.tar.gz")
 source_armv7h=("https://github.com/raspberrypi/userland/archive/$_commitfirmware.tar.gz")
 source_aarch64=("https://github.com/raspberrypi/userland/archive/$_commituserland.tar.gz"
                 "https://raw.githubusercontent.com/raspberrypi/firmware/master/opt/vc/LICENCE")
 md5sums=('72e0d5818fc513ece1b964f25f7e7882'
-         '2ad54baf398afe59ff5a70eb655f1b96')
+         '2ad54baf398afe59ff5a70eb655f1b96'
+         '15a71d74bdd8a8ae9068e38587289a38')
 md5sums_armv6h=('0aa6de64cab765e301662657b85e64c4')
 md5sums_armv7h=('0aa6de64cab765e301662657b85e64c4')
 md5sums_aarch64=('3f5e1c9d4f8295065a283676794b3f57'
@@ -42,6 +44,9 @@ package() {
   # setup permissions on video group for /opt/vc/bin/vcgencmd
   install -Dm0644 "$srcdir/10-raspberrypi-firmware.rules" "$pkgdir/usr/lib/udev/rules.d/10-raspberrypi-firmware.rules"
 
+  # setup PATH to hit /opt/vc/bin/
+  install -Dt "$pkgdir/etc/profile.d" -m644 ../raspberrypi-firmware.sh
+
   if [[ "${CARCH}" = 'aarch64' ]]; then
     mkdir -p "${pkgdir}"/opt/vc
 
diff --git a/alarm/raspberrypi-firmware/raspberrypi-firmware.sh b/alarm/raspberrypi-firmware/raspberrypi-firmware.sh
new file mode 100644
index 000000000..f79c8ec10
--- /dev/null
+++ b/alarm/raspberrypi-firmware/raspberrypi-firmware.sh
@@ -0,0 +1,5 @@
+# Set path to perl scriptdirs if they exist
+
+[ -d /opt/vc/bin ] && append_path '/opt/vc/bin'
+
+export PATH