From 184971be02593e5bffe1f40d4b3c663d5ebbe562 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 1 Sep 2016 00:12:28 +0000
Subject: [PATCH] core/linux-armv5-rc fix

---
 .../0001-at91-ariag25-updates.patch           | 16 +++----
 .../0002-at91-arietta-g25-support.patch       | 10 ++---
 ...ow-mac-address-to-be-set-as-a-parame.patch |  6 +--
 ...vers-atmel-pit-Fix-compilation-error.patch | 45 +++++++++++++++++++
 core/linux-armv5-rc/PKGBUILD                  |  9 ++--
 5 files changed, 67 insertions(+), 19 deletions(-)
 create mode 100644 core/linux-armv5-rc/0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch

diff --git a/core/linux-armv5-rc/0001-at91-ariag25-updates.patch b/core/linux-armv5-rc/0001-at91-ariag25-updates.patch
index cc3449967..7b5dce0a0 100644
--- a/core/linux-armv5-rc/0001-at91-ariag25-updates.patch
+++ b/core/linux-armv5-rc/0001-at91-ariag25-updates.patch
@@ -1,7 +1,7 @@
-From 49e3d1debcd45f07c67e369d12e980bbec391fe2 Mon Sep 17 00:00:00 2001
+From 1e1f9bd80a6175639d9eacd7619df85eae120f9f Mon Sep 17 00:00:00 2001
 From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
 Date: Mon, 12 Aug 2013 10:36:25 -0500
-Subject: [PATCH 1/3] at91: ariag25 updates
+Subject: [PATCH 1/4] at91: ariag25 updates
 
 v2: dropped at91sam9x5 usart fix, as merged mainline
 
@@ -12,10 +12,10 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
  1 file changed, 36 insertions(+), 3 deletions(-)
 
 diff --git a/arch/arm/boot/dts/at91-ariag25.dts b/arch/arm/boot/dts/at91-ariag25.dts
-index e9ced30..8308515 100644
+index 4da011a..4d23221 100644
 --- a/arch/arm/boot/dts/at91-ariag25.dts
 +++ b/arch/arm/boot/dts/at91-ariag25.dts
-@@ -117,7 +117,7 @@
+@@ -108,7 +108,7 @@
  				 * following can be overwritten by bootloader:
  				 * for example u-boot 'ftd set' command
  				 */
@@ -24,7 +24,7 @@ index e9ced30..8308515 100644
  				status = "okay";
  			};
  
-@@ -127,13 +127,41 @@
+@@ -118,13 +118,41 @@
  			 * Change to "okay" if you need additional serial ports
  			 */
  			uart0: serial@f8040000 {
@@ -67,7 +67,7 @@ index e9ced30..8308515 100644
  			adc0: adc@f804c000 {
  				status = "okay";
  				atmel,adc-channels-used = <0xf>;
-@@ -146,7 +174,7 @@
+@@ -137,7 +165,7 @@
  			pinctrl@fffff400 {
  				w1_0 {
  					pinctrl_w1_0: w1_0-0 {
@@ -76,7 +76,7 @@ index e9ced30..8308515 100644
  					};
  				};
  			};
-@@ -154,6 +182,11 @@
+@@ -145,6 +173,11 @@
  			rtc@fffffeb0 {
  				status = "okay";
  			};
@@ -89,5 +89,5 @@ index e9ced30..8308515 100644
  
  		usb0: ohci@00600000 {
 -- 
-2.8.3
+2.9.3
 
diff --git a/core/linux-armv5-rc/0002-at91-arietta-g25-support.patch b/core/linux-armv5-rc/0002-at91-arietta-g25-support.patch
index 674d07bc4..c4001cbb8 100644
--- a/core/linux-armv5-rc/0002-at91-arietta-g25-support.patch
+++ b/core/linux-armv5-rc/0002-at91-arietta-g25-support.patch
@@ -1,7 +1,7 @@
-From 7b311f2091f758961f40af07d234609e1d23e08f Mon Sep 17 00:00:00 2001
+From d19d5b3ba0d66be4b321995019c92ee6603cd658 Mon Sep 17 00:00:00 2001
 From: Kevin Mihelich <kevin@archlinuxarm.org>
 Date: Sat, 13 Jun 2015 13:46:30 -0600
-Subject: [PATCH 2/3] at91: arietta-g25 support
+Subject: [PATCH 2/4] at91: arietta-g25 support
 
 Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
 ---
@@ -13,10 +13,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
  create mode 100644 arch/arm/boot/dts/at91-arietta256.dts
 
 diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 06b6c2d..29d0fdc 100644
+index faacd52..3992360 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -33,6 +33,8 @@ dtb-$(CONFIG_SOC_SAM_V4_V5) += \
+@@ -36,6 +36,8 @@ dtb-$(CONFIG_SOC_AT91SAM9) += \
  	at91sam9n12ek.dtb \
  	at91sam9rlek.dtb \
  	at91-ariag25.dtb \
@@ -376,5 +376,5 @@ index 0000000..cbae789
 +
 +};
 -- 
-2.8.3
+2.9.3
 
diff --git a/core/linux-armv5-rc/0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch b/core/linux-armv5-rc/0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
index 29a759ad9..118719e43 100644
--- a/core/linux-armv5-rc/0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
+++ b/core/linux-armv5-rc/0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
@@ -1,7 +1,7 @@
-From 4e6140b0ca84e5c149d40ba6ed8d249d2b59d6f3 Mon Sep 17 00:00:00 2001
+From 81c4a76ccdbb38cb396dea44a0e369106b8b9ea0 Mon Sep 17 00:00:00 2001
 From: popcornmix <popcornmix@gmail.com>
 Date: Tue, 18 Feb 2014 01:43:50 -0300
-Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
+Subject: [PATCH 3/4] net/smsc95xx: Allow mac address to be set as a parameter
 
 ---
  drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@@ -91,5 +91,5 @@ index dc989a8..912be75 100644
  
  	/* maybe the boot loader passed the MAC address in devicetree */
 -- 
-2.8.3
+2.9.3
 
diff --git a/core/linux-armv5-rc/0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch b/core/linux-armv5-rc/0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch
new file mode 100644
index 000000000..698cad86f
--- /dev/null
+++ b/core/linux-armv5-rc/0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch
@@ -0,0 +1,45 @@
+From 5113578f59cbf01fa77fcce252fca94d0ef935d0 Mon Sep 17 00:00:00 2001
+From: Daniel Lezcano <daniel.lezcano@linaro.org>
+Date: Mon, 29 Aug 2016 08:44:03 +0200
+Subject: [PATCH 4/4] clocksource/drivers/atmel-pit: Fix compilation error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The previous fix introduced a check against the ret variable which
+is not defined, hence producing a compilation error:
+
+linux/drivers/clocksource/timer-atmel-pit.c: In function ‘at91sam926x_pit_dt_init’:
+linux/drivers/clocksource/timer-atmel-pit.c:264:2: error: ‘ret’ undeclared (first use in this function)
+  ret = clk_prepare_enable(data->mck);
+  ^
+linux/drivers/clocksource/timer-atmel-pit.c:264:2: note: each undeclared identifier is reported only once for each function it appears in
+
+Add the missing the variable 'ret'.
+
+Fixes: 504f34c9e45c "clocksource/drivers/atmel-pit: Convert init function to return error"
+Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
+Cc: alexandre.belloni@free-electrons.com
+Cc: motobud@gmail.com
+Cc: realbright@lgcns.com
+Link: http://lkml.kernel.org/r/1472453043-24287-1-git-send-email-daniel.lezcano@linaro.org
+Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
+---
+ drivers/clocksource/timer-atmel-pit.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/clocksource/timer-atmel-pit.c b/drivers/clocksource/timer-atmel-pit.c
+index 3494bc5..7f0f5b2 100644
+--- a/drivers/clocksource/timer-atmel-pit.c
++++ b/drivers/clocksource/timer-atmel-pit.c
+@@ -240,6 +240,7 @@ static int __init at91sam926x_pit_common_init(struct pit_data *data)
+ static int __init at91sam926x_pit_dt_init(struct device_node *node)
+ {
+ 	struct pit_data *data;
++	int ret;
+ 
+ 	data = kzalloc(sizeof(*data), GFP_KERNEL);
+ 	if (!data)
+-- 
+2.9.3
+
diff --git a/core/linux-armv5-rc/PKGBUILD b/core/linux-armv5-rc/PKGBUILD
index 2b3f9546c..6af470b98 100644
--- a/core/linux-armv5-rc/PKGBUILD
+++ b/core/linux-armv5-rc/PKGBUILD
@@ -24,12 +24,14 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
         '0001-at91-ariag25-updates.patch'
         '0002-at91-arietta-g25-support.patch'
         '0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
+        '0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch'
         'config')
 md5sums=('5276563eb1f39a048e4a8a887408c031'
          'a0c0753ff460ff35ef9908ecc97fa943'
-         '77bd4cf88b10ab0a5545c99383675b5e'
-         'a46e1936a8a028342a8cd2286e0a344c'
-         '7feab415253a953c99ae14c4d9d816e3'
+         'f17a49529c9105b1ea685f3a326b540e'
+         'b1a4bd88725f79ad85630cac6a4184e2'
+         'a0f5d7cc82d7374c181debe51f2f2cd9'
+         '456df10122a1b902e94e872d67364950'
          '0365059a0cff74c099ca298e700aada1')
 
 prepare() {
@@ -42,6 +44,7 @@ prepare() {
   git apply ../0001-at91-ariag25-updates.patch
   git apply ../0002-at91-arietta-g25-support.patch
   git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
+  git apply ../0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch
 
   cat "${srcdir}/config" > ./.config