mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-kirkwood-dt to 4.6.3-1
This commit is contained in:
parent
18cc0a0baa
commit
18896a261f
3 changed files with 2 additions and 48 deletions
|
@ -1,25 +0,0 @@
|
|||
From 311bb4a115f653ff9f3202873303483007906c8f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 31 Aug 2014 08:45:13 -0600
|
||||
Subject: [PATCH] disable mv643xx_eth TSO
|
||||
|
||||
---
|
||||
drivers/net/ethernet/marvell/mv643xx_eth.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/net/ethernet/marvell/mv643xx_eth.c b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
index b151a94..e04af62 100644
|
||||
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
@@ -3110,7 +3110,7 @@ static int mv643xx_eth_probe(struct platform_device *pdev)
|
||||
dev->watchdog_timeo = 2 * HZ;
|
||||
dev->base_addr = 0;
|
||||
|
||||
- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
|
||||
+ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
|
||||
dev->vlan_features = dev->features;
|
||||
|
||||
dev->features |= NETIF_F_RXCSUM;
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -6,7 +6,7 @@ buildarch=2
|
|||
pkgbase=linux-kirkwood-dt
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=4.6.2
|
||||
pkgver=4.6.3
|
||||
srcver=${pkgver%.0}
|
||||
pkgrel=1
|
||||
cryptodev_commit=7a3a9ee1329f7224b4fc564b80ef8160457caf76
|
||||
|
@ -38,7 +38,7 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
|||
'linux.preset'
|
||||
'cryptodev_linux_4.6_fix.patch')
|
||||
|
||||
md5sums=('70c4571bfb7ce7ccb14ff43b50165d43'
|
||||
md5sums=('f716e5587f8e6d1fdbda409eb8e1938f'
|
||||
'0bf194fa2c1afeefe4a018607b74f1c5'
|
||||
'de4187921a51d4ec410abc764f6caccc'
|
||||
'SKIP'
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
index 6b4c5ad..4f8618f 100644
|
||||
--- a/drivers/mmc/host/mvsdio.c
|
||||
+++ b/drivers/mmc/host/mvsdio.c
|
||||
@@ -111,10 +111,15 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
mvsd_write(MVSD_BLK_COUNT, data->blocks);
|
||||
mvsd_write(MVSD_BLK_SIZE, data->blksz);
|
||||
|
||||
- if (nodma || (data->blksz | data->sg->offset) & 3) {
|
||||
+ if (nodma || (data->blksz | data->sg->offset) & 3 ||
|
||||
+ ((!(data->flags & MMC_DATA_READ) && data->sg->offset & 0x3f))) {
|
||||
/*
|
||||
* We cannot do DMA on a buffer which offset or size
|
||||
* is not aligned on a 4-byte boundary.
|
||||
+ *
|
||||
+ * It also appears the host to card DMA can corrupt
|
||||
+ * data when the buffer is not aligned on a 64 byte
|
||||
+ * boundary.
|
||||
*/
|
||||
host->pio_size = data->blocks * data->blksz;
|
||||
host->pio_ptr = sg_virt(data->sg);
|
Loading…
Reference in a new issue