core/pacman to 6.0.1-4

This commit is contained in:
Kevin Mihelich 2022-03-08 16:13:12 +00:00
parent 1cfcf9b3d3
commit 18dded5faf
5 changed files with 201 additions and 2 deletions

View file

@ -11,7 +11,7 @@
pkgname=pacman
pkgver=6.0.1
pkgrel=3.1
pkgrel=4
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="https://www.archlinux.org/pacman/"
@ -30,6 +30,9 @@ validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@a
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig}
add-flto-to-LDFLAGS-for-clang.patch
makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
libmakepkg-add-extra-buildflags-only-when-buildflags.patch
make-link-time-optimization-flags-configurable.patch
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
@ -38,15 +41,21 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig
sha256sums=('0db61456e56aa49e260e891c0b025be210319e62b15521f29d3e93b00d3bf731'
'SKIP'
'82ff91b85f4c6ceba19f9330437e2a22aabc966c2b9e2a20a53857f98a42c223'
'b940e6c0c05a185dce1dbb9da0dcbebf742fca7a63f3e3308d49205afe5a6582'
'7d0aee976c9c71fcf7c96ef1d99aa76efe47d8c1f4451842d6d159ec7deb4278'
'5b43e26a76be3ed10a69d4bfb2be48db8cce359baf46583411c7f124737ebe6a'
'f9a8ae2805cc995ef1b787e10f402d574aaee183cc3a23fe26805555b7d87fea'
'7beb2faec0ec37dcb2050d9ed3c95353fb7f73da7e3bbe0e226e9e3f7858a01f'
'0fdbdc3c86b826fe87d8051a5d34db23b366b0a7bdc22f3701b1bf2b01218d59'
'19f189accab294af7085cb709417eb41784d21aa8da07a8aa24bf7591ec3ce94'
'21d75a0d0399d755002deeeddcc4973615a3b6423186d22ab0bd7770b84c6b25')
'd001efcbcbe97e4be27639cb7709813a40803e8aead8f544fc7c5b92fb64b062')
prepare() {
cd "$pkgname-$pkgver"
patch -Np1 -i ../add-flto-to-LDFLAGS-for-clang.patch
patch -Np1 -i ../makepkg-use-ffile-prefix-map-instead-of-fdebug-prefi.patch
patch -Np1 -i ../libmakepkg-add-extra-buildflags-only-when-buildflags.patch
patch -Np1 -i ../make-link-time-optimization-flags-configurable.patch
patch -p1 -i ../0001-Sychronize-filesystem.patch
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch

View file

@ -0,0 +1,41 @@
From 42fe4864a0c8e2846007ffee532fe0cf4b321cdd Mon Sep 17 00:00:00 2001
From: Allan McRae <allan@archlinux.org>
Date: Sun, 9 Jan 2022 12:45:58 +1000
Subject: [PATCH] libmakepkg: add extra buildflags only when buildflags is not
disabled
This means options=('!buildflags') will disable the addition of CFLAG
etc for LTO and debug building.
Signed-off-by: Allan McRae <allan@archlinux.org>
---
scripts/libmakepkg/buildenv/debugflags.sh.in | 2 +-
scripts/libmakepkg/buildenv/lto.sh.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/libmakepkg/buildenv/debugflags.sh.in b/scripts/libmakepkg/buildenv/debugflags.sh.in
index 84ca7b71..1cb58613 100644
--- a/scripts/libmakepkg/buildenv/debugflags.sh.in
+++ b/scripts/libmakepkg/buildenv/debugflags.sh.in
@@ -29,7 +29,7 @@ source "$LIBRARY/util/option.sh"
buildenv_functions+=('buildenv_debugflags')
buildenv_debugflags() {
- if check_option "debug" "y"; then
+ if check_option "debug" "y" && ! check_option "buildflags" "n"; then
DEBUG_CFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
DEBUG_CXXFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
DEBUG_RUSTFLAGS+=" --remap-path-prefix=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
index 081d5648..6e500eab 100644
--- a/scripts/libmakepkg/buildenv/lto.sh.in
+++ b/scripts/libmakepkg/buildenv/lto.sh.in
@@ -30,7 +30,7 @@ build_options+=('lto')
buildenv_functions+=('buildenv_lto')
buildenv_lto() {
- if check_option "lto" "y"; then
+ if check_option "lto" "y" && ! check_option "buildflags" "n"; then
CFLAGS+=" -flto"
CXXFLAGS+=" -flto"
LDFLAGS+=" -flto"

View file

@ -0,0 +1,108 @@
From e1ce2351f5c00dd90104e0f4ce3bf176da28af08 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Thu, 10 Feb 2022 05:15:01 +0200
Subject: [PATCH] Make link time optimization flags configurable
We want to use -flto=auto in Arch Linux to speed up building, but we
can't hardcode it in buildenv/lto.sh because other downstreams might
have clang < 13.0.0 which did not recognize -flto=auto as equivalent
to -flto=full.
Introducing an LTOFLAGS variable to makepkg.conf seems the way to go.
Signed-off-by: Allan McRae <allan@archlinux.org>
---
doc/makepkg.conf.5.asciidoc | 10 ++++++++--
etc/makepkg.conf.in | 1 +
scripts/libmakepkg/buildenv/buildflags.sh.in | 2 +-
scripts/libmakepkg/buildenv/lto.sh.in | 6 +++---
scripts/libmakepkg/lint_config/variable.sh.in | 8 ++++----
5 files changed, 17 insertions(+), 10 deletions(-)
diff --git a/doc/makepkg.conf.5.asciidoc b/doc/makepkg.conf.5.asciidoc
index 39c5c808..a0d9a6d4 100644
--- a/doc/makepkg.conf.5.asciidoc
+++ b/doc/makepkg.conf.5.asciidoc
@@ -81,6 +81,11 @@ Options
usage resembling ``-Wl,--hash-style=gnu''. Read ld(1) for more details on
available linker flags.
+**LTOFLAGS=**"ltoflags"::
+ Additional compiler and linker flags appended to `CFLAGS`, `CXXFLAGS`
+ and `LDFLAGS` when building with link time optimization. If empty,
+ ``-flto'' is used.
+
**MAKEFLAGS=**"makeflags"::
This is often used to set the number of jobs used; for example, `-j2`.
Other flags that make accepts can also be passed.
@@ -190,8 +195,9 @@ Options
package containing the debug symbols when used with `strip'.
*lto*;;
- Enable building packages using link time optimization. Adds '-flto'
- to both CFLAGS and CXXFLAGS.
+ Enable building packages using link time optimization. Adds the
+ flags specified in LTOFLAGS to CFLAGS, CXXFLAGS and LDFLAGS (or
+ ``-flto'' if LTOFLAGS is empty).
*autodep*;;
Enable the automatic addition of libraries to the depends and
diff --git a/etc/makepkg.conf.in b/etc/makepkg.conf.in
index 0c911cce..edc5f442 100644
--- a/etc/makepkg.conf.in
+++ b/etc/makepkg.conf.in
@@ -41,6 +41,7 @@ CHOST="@CHOST@"
#CFLAGS="-O2 -pipe"
#CXXFLAGS="-O2 -pipe"
#LDFLAGS=""
+#LTOFLAGS="-flto"
#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
diff --git a/scripts/libmakepkg/buildenv/buildflags.sh.in b/scripts/libmakepkg/buildenv/buildflags.sh.in
index 74f91988..07b4a730 100644
--- a/scripts/libmakepkg/buildenv/buildflags.sh.in
+++ b/scripts/libmakepkg/buildenv/buildflags.sh.in
@@ -30,6 +30,6 @@ buildenv_functions+=('buildenv_buildflags')
buildenv_buildflags() {
if check_option "buildflags" "n"; then
- unset CPPFLAGS CFLAGS DEBUG_CFLAGS CXXFLAGS DEBUG_CXXFLAGS LDFLAGS RUSTFLAGS DEBUG_RUSTFLAGS
+ unset CPPFLAGS CFLAGS DEBUG_CFLAGS CXXFLAGS DEBUG_CXXFLAGS LDFLAGS LTOFLAGS RUSTFLAGS DEBUG_RUSTFLAGS
fi
}
diff --git a/scripts/libmakepkg/buildenv/lto.sh.in b/scripts/libmakepkg/buildenv/lto.sh.in
index 6e500eab..6492def7 100644
--- a/scripts/libmakepkg/buildenv/lto.sh.in
+++ b/scripts/libmakepkg/buildenv/lto.sh.in
@@ -31,8 +31,8 @@ buildenv_functions+=('buildenv_lto')
buildenv_lto() {
if check_option "lto" "y" && ! check_option "buildflags" "n"; then
- CFLAGS+=" -flto"
- CXXFLAGS+=" -flto"
- LDFLAGS+=" -flto"
+ CFLAGS+=" ${LTOFLAGS:--flto}"
+ CXXFLAGS+=" ${LTOFLAGS:--flto}"
+ LDFLAGS+=" ${LTOFLAGS:--flto}"
fi
}
diff --git a/scripts/libmakepkg/lint_config/variable.sh.in b/scripts/libmakepkg/lint_config/variable.sh.in
index 8327b0a5..03a67ee2 100644
--- a/scripts/libmakepkg/lint_config/variable.sh.in
+++ b/scripts/libmakepkg/lint_config/variable.sh.in
@@ -32,10 +32,10 @@ lint_config_variables() {
local array=(DLAGENTS VCSCLIENTS BUILDENV OPTIONS INTEGRITY_CHECK MAN_DIRS
DOC_DIRS PURGE_TARGETS COMPRESSGZ COMPRESSBZ2 COMPRESSXZ
COMPRESSLRZ COMPRESSLZO COMPRESSZ)
- local string=(CARCH CHOST CPPFLAGS CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS DEBUG_CFLAGS
- DEBUG_CXXFLAGS DEBUG_RUSTFLAGS DISTCC_HOSTS BUILDDIR STRIP_BINARIES
- STRIP_SHARED STRIP_STATIC PKGDEST SRCDEST SRCPKGDEST LOGDEST PACKAGER
- GPGKEY PKGEXT SRCEXT)
+ local string=(CARCH CHOST CPPFLAGS CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS LTOFLAGS
+ DEBUG_CFLAGS DEBUG_CXXFLAGS DEBUG_RUSTFLAGS DISTCC_HOSTS BUILDDIR
+ STRIP_BINARIES STRIP_SHARED STRIP_STATIC PKGDEST SRCDEST SRCPKGDEST
+ LOGDEST PACKAGER GPGKEY PKGEXT SRCEXT)
local i keys ret=0

View file

@ -0,0 +1,40 @@
From e37f7d8b6b4d2f9accf97eb96d0eacbddf2a1345 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sat, 1 Jan 2022 14:40:24 +0100
Subject: [PATCH] makepkg: use -ffile-prefix-map instead of -fdebug-prefix-map
>From gcc(1):
-ffile-prefix-map=old=new
[...] Specifying this option is equivalent to specifying all the
individual -f*-prefix-map options. This can be used to make reproducible
builds that are location independent.
Specifically, this additionally enables -fmacro-prefix-map=, which causes
prefix mapping to be applied to expansions of __FILE__ and similar macros.
Without this option, if source files are compiled by passing the
absolute file path to the compiler (as done by e.g. cmake), any
expansions of __FILE__ (e.g. from uses of assert()) will contain
$srcdir.
Signed-off-by: Allan McRae <allan@archlinux.org>
---
scripts/libmakepkg/buildenv/debugflags.sh.in | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/libmakepkg/buildenv/debugflags.sh.in b/scripts/libmakepkg/buildenv/debugflags.sh.in
index e0a1ed00..84ca7b71 100644
--- a/scripts/libmakepkg/buildenv/debugflags.sh.in
+++ b/scripts/libmakepkg/buildenv/debugflags.sh.in
@@ -30,8 +30,8 @@ buildenv_functions+=('buildenv_debugflags')
buildenv_debugflags() {
if check_option "debug" "y"; then
- DEBUG_CFLAGS+=" -fdebug-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
- DEBUG_CXXFLAGS+=" -fdebug-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ DEBUG_CFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
+ DEBUG_CXXFLAGS+=" -ffile-prefix-map=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
DEBUG_RUSTFLAGS+=" --remap-path-prefix=$srcdir=${DBGSRCDIR:-/usr/src/debug}"
CFLAGS+=" $DEBUG_CFLAGS"
CXXFLAGS+=" $DEBUG_CXXFLAGS"

View file

@ -45,6 +45,7 @@ CFLAGS="@CARCHFLAGS@-O2 -pipe -fstack-protector-strong -fno-plt -fexceptions \
-fstack-clash-protection"
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
LTOFLAGS=""
#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"