extra/qt6-webengine to 6.7.0-2

This commit is contained in:
Kevin Mihelich 2024-05-19 19:32:43 +00:00
parent f5d5a2e01a
commit 19063e563a
3 changed files with 39 additions and 2 deletions

View file

@ -1,7 +1,7 @@
pkgbase = qt6-webengine
pkgdesc = Provides support for web applications using the Chromium browser project
pkgver = 6.7.0
pkgrel = 1
pkgrel = 2
url = https://www.qt.io
arch = x86_64
groups = qt6
@ -67,7 +67,9 @@ pkgbase = qt6-webengine
optdepends = pipewire: WebRTC desktop sharing under Wayland
source = git+https://code.qt.io/qt/qtwebengine#tag=v6.7.0
source = git+https://code.qt.io/qt/qtwebengine-chromium
source = qtwebengine-6.7.0-ninja1.12.patch
sha256sums = dbb5c0191c2907a405ec31c9a13b4b7010c53445ab2c76485310af9a56ffeace
sha256sums = SKIP
sha256sums = c037cccc1d43bcd9d67045354ca48b405acec217149cb4b2bd3cfb7b5561cc33
pkgname = qt6-webengine

View file

@ -11,7 +11,7 @@ highmem=1
pkgname=qt6-webengine
_qtver=6.7.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -78,10 +78,12 @@ groups=(qt6)
_pkgfn=${pkgname/6-/}
source=(git+https://code.qt.io/qt/$_pkgfn#tag=v$pkgver
git+https://code.qt.io/qt/qtwebengine-chromium
qtwebengine-6.7.0-ninja1.12.patch
0001-ARM-toolchain-fixes.patch
0002-Run-blink-bindings-generation-single-threaded.patch)
sha256sums=('dbb5c0191c2907a405ec31c9a13b4b7010c53445ab2c76485310af9a56ffeace'
'SKIP'
'c037cccc1d43bcd9d67045354ca48b405acec217149cb4b2bd3cfb7b5561cc33'
'772aeba76d16387e28ef629285965109a4bfaa02ca2dd466e9526fe2030773ec'
'eff4ebf2e714185ef6e36e30c8d2158da6b41a46e3168d06472d35f6c9977aaf')
@ -91,6 +93,9 @@ prepare() {
git submodule set-url src/3rdparty "$srcdir"/qtwebengine-chromium
git -c protocol.file.allow=always submodule update
# Fix build with ninja 1.12 - Gentoo patch
patch -Np1 -i ../qtwebengine-6.7.0-ninja1.12.patch
if [[ $CARCH == "armv7h" ]]; then
export MAKEFLAGS="-j1"
export ALARM_NINJA_JOBS="1"

View file

@ -0,0 +1,30 @@
Patch status: pending being looked at upstream
Issue[1][2][3] also exist in chromium itself[4], and unclear
why this started happening only with ninja-1.12.0 at the moment.
Just a quickfix, likely not fully correct and seems there may
be further unresolved race issues.
[1] https://bugs.gentoo.org/930107
[2] https://bugreports.qt.io/browse/QTBUG-124375
[3] https://github.com/ninja-build/ninja/issues/2417
[4] https://bugs.gentoo.org/930112
--- a/src/3rdparty/chromium/content/browser/BUILD.gn
+++ b/src/3rdparty/chromium/content/browser/BUILD.gn
@@ -198,2 +198,3 @@
"//components/services/storage/public/mojom",
+ "//components/spellcheck:buildflags",
"//components/sqlite_proto",
--- a/src/3rdparty/chromium/extensions/browser/api/declarative_net_request/BUILD.gn
+++ b/src/3rdparty/chromium/extensions/browser/api/declarative_net_request/BUILD.gn
@@ -22,2 +22,3 @@
"//content/public/browser",
+ "//components/web_cache/public/mojom",
"//extensions/common",
--- a/src/core/configure/BUILD.root.gn.in
+++ b/src/core/configure/BUILD.root.gn.in
@@ -235,2 +235,3 @@
deps = [
+ "//chrome/app:generated_resources",
"//components/zoom",