mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/ocaml to 4.04.0-1
This commit is contained in:
parent
66867e0ade
commit
1937623afe
2 changed files with 9 additions and 9 deletions
|
@ -6,7 +6,7 @@
|
|||
|
||||
pkgbase='ocaml'
|
||||
pkgname=('ocaml' 'ocaml-compiler-libs')
|
||||
pkgver=4.03.0
|
||||
pkgver=4.04.0
|
||||
pkgrel=1
|
||||
pkgdesc="A functional language with OO extensions"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -15,10 +15,10 @@ url="http://caml.inria.fr/"
|
|||
depends=('gdbm')
|
||||
makedepends=('tk>=8.6.0' 'ncurses>=5.6-7' 'libx11')
|
||||
optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
|
||||
source=(http://caml.inria.fr/distrib/ocaml-4.03/${pkgname}-${pkgver}.tar.xz
|
||||
source=(http://caml.inria.fr/distrib/ocaml-${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
|
||||
arm.patch)
|
||||
md5sums=('89f62881e03dfad0cf04991fbc03f955'
|
||||
'bf67fe35a844f0d1a13a489f4414fd6d')
|
||||
sha1sums=('1878ba4338e4fad5b057428e182fba806c545d57'
|
||||
'113e296557473dbd26b87c4e652af5207c8cf072')
|
||||
options=('!makeflags' '!emptydirs' 'staticlibs')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
diff -urN a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
|
||||
--- a/asmcomp/CSEgen.ml 2014-10-09 03:21:33.000000000 -0600
|
||||
+++ b/asmcomp/CSEgen.ml 2014-12-06 14:17:49.879574784 -0700
|
||||
@@ -216,7 +216,8 @@
|
||||
--- a/asmcomp/CSEgen.ml 2016-11-04 10:08:24.000000000 -0600
|
||||
+++ b/asmcomp/CSEgen.ml 2016-11-15 12:07:58.685253738 -0700
|
||||
@@ -252,7 +252,8 @@
|
||||
(* Perform CSE on the given instruction [i] and its successors.
|
||||
[n] is the value numbering current at the beginning of [i]. *)
|
||||
|
||||
|
@ -9,9 +9,9 @@ diff -urN a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
|
|||
+method private cse n i = i
|
||||
+(*
|
||||
match i.desc with
|
||||
| Iend | Ireturn | Iop(Itailcall_ind) | Iop(Itailcall_imm _)
|
||||
| Iend | Ireturn | Iop(Itailcall_ind _) | Iop(Itailcall_imm _)
|
||||
| Iexit _ | Iraise _ ->
|
||||
@@ -315,6 +316,7 @@
|
||||
@@ -357,6 +358,7 @@
|
||||
{i with desc = Itrywith(self#cse n body,
|
||||
self#cse empty_numbering handler);
|
||||
next = self#cse empty_numbering i.next}
|
||||
|
|
Loading…
Reference in a new issue