mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-odroid-c1 to 3.10.80-1
This commit is contained in:
parent
87b3f070dc
commit
194a1e875d
3 changed files with 6 additions and 95 deletions
|
@ -1,43 +0,0 @@
|
|||
From d65a7d93ea65dc8cbb133497334ce1c529815a78 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 19 Mar 2015 18:31:00 -0600
|
||||
Subject: [PATCH 1/2] remove backports cflags
|
||||
|
||||
---
|
||||
backports/Makefile | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/backports/Makefile b/backports/Makefile
|
||||
index 5636a22..740fcf9 100644
|
||||
--- a/backports/Makefile
|
||||
+++ b/backports/Makefile
|
||||
@@ -14,8 +14,7 @@ NOSTDINC_FLAGS := \
|
||||
-DCONFIG_BACKPORT_VERSION=\"$(BACKPORTS_VERSION)\" \
|
||||
-DCONFIG_BACKPORT_KERNEL_VERSION=\"$(BACKPORTED_KERNEL_VERSION)\" \
|
||||
-DCONFIG_BACKPORT_KERNEL_NAME=\"$(BACKPORTED_KERNEL_NAME)\" \
|
||||
- $(BACKPORTS_GIT_TRACKER_DEF) \
|
||||
- $(CFLAGS)
|
||||
+ $(BACKPORTS_GIT_TRACKER_DEF)
|
||||
|
||||
export backport_srctree = $(M)
|
||||
else
|
||||
@@ -26,8 +25,7 @@ NOSTDINC_FLAGS := \
|
||||
-I$(BACKPORT_DIR)/backport-include/uapi \
|
||||
-I$(BACKPORT_DIR)/include/ \
|
||||
-I$(BACKPORT_DIR)/include/uapi \
|
||||
- -include $(BACKPORT_DIR)/backport-include/backport/backport.h \
|
||||
- $(CFLAGS)
|
||||
+ -include $(BACKPORT_DIR)/backport-include/backport/backport.h
|
||||
endif
|
||||
|
||||
|
||||
@@ -54,4 +52,4 @@ obj-$(CONFIG_BACKPORT_IEEE802154) += drivers/net/ieee802154/
|
||||
|
||||
obj-$(CONFIG_BACKPORT_USB_WDM) += drivers/usb/class/
|
||||
obj-$(CONFIG_BACKPORT_USB_USBNET) += drivers/net/usb/
|
||||
-obj-y += drivers/realtek/
|
||||
\ No newline at end of file
|
||||
+obj-y += drivers/realtek/
|
||||
--
|
||||
2.4.1
|
||||
|
|
@ -1,39 +0,0 @@
|
|||
From 46de4e3a5f56c5915beb4a69e4a3af9c88aaa482 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 30 Apr 2015 20:15:13 -0600
|
||||
Subject: [PATCH 2/2] AUFS fix for 3.10.76
|
||||
|
||||
---
|
||||
fs/aufs/debug.c | 2 +-
|
||||
fs/aufs/hnotify.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
|
||||
index a26b5bd..7cedc88 100644
|
||||
--- a/fs/aufs/debug.c
|
||||
+++ b/fs/aufs/debug.c
|
||||
@@ -156,7 +156,7 @@ void au_dpri_dalias(struct inode *inode)
|
||||
struct dentry *d;
|
||||
|
||||
spin_lock(&inode->i_lock);
|
||||
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
|
||||
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
|
||||
au_dpri_dentry(d);
|
||||
spin_unlock(&inode->i_lock);
|
||||
}
|
||||
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
|
||||
index 1bd7a9a..927beb6 100644
|
||||
--- a/fs/aufs/hnotify.c
|
||||
+++ b/fs/aufs/hnotify.c
|
||||
@@ -198,7 +198,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
|
||||
AuDebugOn(!name);
|
||||
au_iigen_dec(inode);
|
||||
spin_lock(&inode->i_lock);
|
||||
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
|
||||
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
|
||||
spin_lock(&d->d_lock);
|
||||
dname = &d->d_name;
|
||||
if (dname->len != nlen
|
||||
--
|
||||
2.4.1
|
||||
|
|
@ -4,12 +4,12 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-odroid-c1
|
||||
_commit=5fd2c0a66767fc6a92ff9c0b5daed57215c78ebc
|
||||
_commit=fd1a173ee708c0e4992fb01092b1f44538527baa
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-C1"
|
||||
pkgver=3.10.79
|
||||
pkgrel=4
|
||||
pkgver=3.10.80
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="https://github.com/hardkernel/linux"
|
||||
license=('GPL2')
|
||||
|
@ -18,24 +18,17 @@ options=('!strip')
|
|||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
"git+https://github.com/mdrjr/c1_bootini.git"
|
||||
'config'
|
||||
'amlogic.service'
|
||||
'0001-remove-backports-cflags.patch'
|
||||
'0002-AUFS-fix-for-3.10.76.patch')
|
||||
md5sums=('5e25414b8054c8cdb44af268e2998958'
|
||||
'amlogic.service')
|
||||
md5sums=('e9168c89618641c5a685dfa95bad6013'
|
||||
'SKIP'
|
||||
'892014616cf866d7f46e13e63659e187'
|
||||
'b8956789318f49cec5b8bb0b41654a9b'
|
||||
'5cbceb4671d498ebd3548c6d02b5324d'
|
||||
'160a47ab9efd5cbbf4b0ac392ae59180')
|
||||
'b8956789318f49cec5b8bb0b41654a9b')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
git apply ../0001-remove-backports-cflags.patch
|
||||
git apply ../0002-AUFS-fix-for-3.10.76.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
|
|
Loading…
Reference in a new issue