mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/java8-openjdk: fix
This commit is contained in:
parent
4378defd44
commit
1a0e400046
3 changed files with 2 additions and 49 deletions
|
@ -30,18 +30,6 @@ diff --git openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make openjdk/hots
|
|||
|
||||
# If FDLIBM_CFLAGS is non-empty it holds CFLAGS needed to be passed to
|
||||
# the compiler so as to be able to produce optimized objects
|
||||
diff --git openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
+++ openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
@@ -100,7 +100,7 @@
|
||||
case T_DOUBLE:
|
||||
case T_VOID:
|
||||
return result;
|
||||
- default : ShouldNotReachHere();
|
||||
+ default : ShouldNotReachHere(); return NULL_WORD;
|
||||
}
|
||||
}
|
||||
|
||||
diff --git openjdk.orig/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp openjdk/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
+++ openjdk/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
# HG changeset patch
|
||||
# User andrew
|
||||
# Date 1518667645 0
|
||||
# Thu Feb 15 04:07:25 2018 +0000
|
||||
# Node ID 1d35411eb7bdf16191e220ffe3b1dc4d5d0c6041
|
||||
# Parent 999983606f5c61b093c6f6316a7b26c4cd4ca79e
|
||||
8197981, PR3548: Missing return statement in __sync_val_compare_and_swap_8
|
||||
Summary: Fix issue discovered by -Wreturn-type on systems without LP64.
|
||||
Reviewed-by: aph
|
||||
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
+++ openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
@@ -457,6 +457,7 @@
|
||||
long long unsigned int oldval,
|
||||
long long unsigned int newval) {
|
||||
ShouldNotCallThis();
|
||||
+ return 0;
|
||||
}
|
||||
};
|
||||
#endif // !_LP64
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
+++ openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
@@ -498,6 +498,7 @@
|
||||
long long unsigned int oldval,
|
||||
long long unsigned int newval) {
|
||||
ShouldNotCallThis();
|
||||
+ return 0;
|
||||
}
|
||||
};
|
||||
#endif // !_LP64
|
|
@ -34,8 +34,7 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
8143245-pr3548.patch
|
||||
8197981-pr3548.patch)
|
||||
8143245-pr3548.patch)
|
||||
|
||||
sha256sums=('26946f5d9040d03657ccf92b11d77f57daba194f79d9ab992262c8c664204a95'
|
||||
'88254a0608727121a0e455ba07cd24af8a1bd6c8f65d5d95a005ac6547011d7f'
|
||||
|
@ -45,8 +44,7 @@ sha256sums=('26946f5d9040d03657ccf92b11d77f57daba194f79d9ab992262c8c664204a95'
|
|||
'a8a93f89621036ce3a239bc1fa4beb02d2b9c5942558bfd7e419180c9d4d0dd2'
|
||||
'44f21ba2d4e440ea32bd00268e4b6dc14be378a7400d959ca4c9fbca39de7c60'
|
||||
'c714859516d66a1b8a3ca18e06c24f8ff9d9bb7dfc1114663a24187668be16e9'
|
||||
'305c779ab087853a0eba3532355225be52a779c38b5652fc7485794533d8cf8d'
|
||||
'c0bb1ae19f08c221156df15d7d8c5a4168c55179a186f3054dd4ac0591ec8501')
|
||||
'cebae4e056c738d54833c086e9379d2054ff80887c1f4e4ad14496c7ec65f665')
|
||||
|
||||
case "${CARCH}" in
|
||||
'x86_64') _JARCH=amd64 ; _DOC_ARCH=x86_64 ;;
|
||||
|
@ -72,7 +70,6 @@ prepare() {
|
|||
# Fix zero with up to date GCC and glibc
|
||||
cd ../hotspot-${_repo_ver}
|
||||
patch -p2 -i ../8143245-pr3548.patch
|
||||
patch -p2 -i ../8197981-pr3548.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue