mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/mkinitcpio to 34-2
This commit is contained in:
parent
257fb5754f
commit
1a1e30608b
3 changed files with 17 additions and 16 deletions
|
@ -1,4 +1,4 @@
|
|||
From 24a642d73cd76fd82ffb6e6eb395a1766113f2e8 Mon Sep 17 00:00:00 2001
|
||||
From a85995cb175bcbc806435443a21f0b0b70f2b170 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 20 Feb 2021 10:02:34 -0700
|
||||
Subject: [PATCH 1/2] use gzip for compression by default
|
||||
|
@ -10,10 +10,10 @@ Subject: [PATCH 1/2] use gzip for compression by default
|
|||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/man/mkinitcpio.conf.5.txt b/man/mkinitcpio.conf.5.txt
|
||||
index fdb8d91..d2ec118 100644
|
||||
index 59909f3..69bc683 100644
|
||||
--- a/man/mkinitcpio.conf.5.txt
|
||||
+++ b/man/mkinitcpio.conf.5.txt
|
||||
@@ -55,7 +55,7 @@ Variables
|
||||
@@ -56,7 +56,7 @@ Variables
|
||||
Defines a program to filter the generated image through. The kernel
|
||||
understands the compression formats yielded by the *zstd*, *gzip*, *bzip2*,
|
||||
*lz4*, *lzop*, *lzma*, and *xz* compressors. If unspecified, this setting
|
||||
|
@ -23,10 +23,10 @@ index fdb8d91..d2ec118 100644
|
|||
+
|
||||
It's not hard to realize that a filter such as a *tac* or *rev* will cause
|
||||
diff --git a/mkinitcpio b/mkinitcpio
|
||||
index f6787a7..8f6c2ec 100755
|
||||
index 49ca3f9..952e049 100755
|
||||
--- a/mkinitcpio
|
||||
+++ b/mkinitcpio
|
||||
@@ -725,7 +725,7 @@ if [[ $_optgenimg ]]; then
|
||||
@@ -734,7 +734,7 @@ if [[ $_optgenimg ]]; then
|
||||
die 'Unable to write to %s' "$_optgenimg"
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From d8b51b2bfb33bfd0854a20c976eb4c9fa4c5fca5 Mon Sep 17 00:00:00 2001
|
||||
From efe14b76219f065b99983f305ac0d71e8c8658a4 Mon Sep 17 00:00:00 2001
|
||||
From: Janne Grunau <j@jannau.net>
|
||||
Date: Sun, 30 Jan 2022 10:01:43 +0000
|
||||
Subject: [PATCH 2/2] functions: handle gzip compressed kernels in kver_generic
|
||||
|
@ -9,10 +9,10 @@ Signed-off-by: Janne Grunau <j@jannau.net>
|
|||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/functions b/functions
|
||||
index e0a68e2..5ad3106 100644
|
||||
index 9939e25..7e58d57 100644
|
||||
--- a/functions
|
||||
+++ b/functions
|
||||
@@ -221,6 +221,11 @@ kver_generic() {
|
||||
@@ -222,6 +222,11 @@ kver_generic() {
|
||||
|
||||
read _ _ kver _ < <($reader "$1" | grep -m1 -aoE 'Linux version .(\.[-[:alnum:]+]+)+')
|
||||
|
||||
|
|
|
@ -9,15 +9,16 @@
|
|||
# - patch for gzip kernel image support (https://github.com/archlinux/mkinitcpio/pull/86)
|
||||
|
||||
pkgname=mkinitcpio
|
||||
pkgver=33
|
||||
pkgver=34
|
||||
pkgrel=2
|
||||
pkgdesc="Modular initramfs image creation utility"
|
||||
arch=('any')
|
||||
url='https://github.com/archlinux/mkinitcpio'
|
||||
url='https://gitlab.archlinux.org/archlinux/mkinitcpio/mkinitcpio'
|
||||
license=('GPL')
|
||||
depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.23' 'libarchive' 'coreutils'
|
||||
'bash' 'binutils' 'diffutils' 'findutils' 'grep' 'filesystem>=2011.10-1' 'gzip' 'systemd')
|
||||
makedepends=('asciidoc')
|
||||
checkdepends=('bash-bats' 'bash-bats-assert' 'lzop')
|
||||
optdepends=('xz: Use lzma or xz compression for the initramfs image'
|
||||
'bzip2: Use bzip2 compression for the initramfs image'
|
||||
'lzop: Use lzo compression for the initramfs image'
|
||||
|
@ -30,16 +31,16 @@ source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,
|
|||
'0001-use-gzip-for-compression-by-default.patch'
|
||||
'0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch')
|
||||
install=mkinitcpio.install
|
||||
sha512sums=('13526e749d23f2933db4a9ed74f138b0fafaf9b93f455dcf686b29b950247f0b62f8f6a091d7006c41642b4106bf8bcd666af03ec44a9f0ee7cf2b57b5714cf0'
|
||||
sha512sums=('cf8ab66d4609911ca6a1d2af1bfcf320eed99d29657c0ccfeca2fdc8ea00cfb6575e55645424de13fcf37aa12a39ac7b43a330c716e73e9c16a75178738ebe70'
|
||||
'SKIP'
|
||||
'a43e66101edc301ae893a25eee6caa83c56a790cbac1685697fb999008c8210e46ca49e0700242f8321731264084462641285954db55d3daa2c7e8b62d1cc66c'
|
||||
'711fa620fcd5685e07f19772626eb838f710e8eea8a47c33c48689935e57bfa60f6b420b70fdb351b8222d2fd5310859864be26f640c6d72c486f871dd61d48d'
|
||||
'9f5d0129c93823175b04ec0a42c82fa4cc8adffb8a836773b9b08bb7d28767b1a1810f44b78501f1c501d19abd84a6d9a87d30e0d3e95c8d76f56ee5210fd5f3')
|
||||
b2sums=('1a85152e6ce465e419e87a1915860be83c198f4e7a6ecab44277a68f2f1ecb316c7fed6e8af93b0282b646c2de1a8057831668749788030eb3e5256eeb28979b'
|
||||
'08472d71eeefa7f547033096250703138658d056ae7922841c586bb419c6ae7063b4cfa7ec8bdc0a50b10a7d18e201f10a5db98ab5fe25d6e7f0d8e801904c4a'
|
||||
'e9b1bc7eb74271738c18a20cc8f4e391d7c3342c20763615ba8dadafc5259147bfad98ad059e5c1b19e3cb25f2f214a816bb8864351edef5b9db170abe4bc72d')
|
||||
b2sums=('06a6c6a0951b9b6161e2db01e2956d87da303b2ec029bdd183efed3b074b176a9f107e9a723fc6a7fa157ecd703d7627d8aaa0b9290022a09e30daa46784841c'
|
||||
'SKIP'
|
||||
'a2ed9e8ff4b6fab1d6f6c1dae4dcf890b4434cb31ebdfe73ea54fd4af499849e2b98e565915cc331bd97f15f21d9147ee0499cf75b516562bfd7f1793e838e99'
|
||||
'5ce998c788e90abb22df2104f9cd58a5707fad2ebad21bf29b7e4e4d3f65cb99b74e3417b93c91c45c72569262403932c5f4af5ac5becf03a8ee2e4f38be2ebf'
|
||||
'8804b5b1594de02e54530f6f07fb8c41d89fef19f597dd34f5fb9bc04b601a466daeffe5474e22d7139b59f20a82ac255301b16bb623e4dc3db1406d3cda6301')
|
||||
'f7760eadafa2916875cf37ce22dc66d8fa0ef9c844f18e5462e37f5d5d6b5654ec515a404aeefb63fb2ec2bd6f442c42c69513800ff62e51ebf55d392d5dbc6e'
|
||||
'9cd2d5c8aa9c26ee92a2c047f6f54f619102b764d76585d90a58a9d9616d09683734ca13404d8f8e7217c3bbe9ae988ea58adf7c71f7b8353079f555277c6455')
|
||||
validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
|
||||
'C100346676634E80C940FB9E9C02FF419FECBE16') # Morten Linderud
|
||||
|
||||
|
|
Loading…
Reference in a new issue