mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/calligra to 3.2.1-27
This commit is contained in:
parent
8e6b5b9745
commit
1a3f12dc85
4 changed files with 113 additions and 2 deletions
72
extra/calligra/068cd9ae.patch
Normal file
72
extra/calligra/068cd9ae.patch
Normal file
|
@ -0,0 +1,72 @@
|
|||
From 068cd9aec11052733e393976142516d2190e4564 Mon Sep 17 00:00:00 2001
|
||||
From: Pierre Ducroquet <pinaraf@pinaraf.info>
|
||||
Date: Sun, 28 Feb 2021 23:23:02 +0100
|
||||
Subject: [PATCH] Fix some more warnings
|
||||
|
||||
diff --git a/filters/words/msword-odf/wv2/src/styles.cpp b/filters/words/msword-odf/wv2/src/styles.cpp
|
||||
index f47c3dd8d51..d2c96e3d92b 100644
|
||||
--- a/filters/words/msword-odf/wv2/src/styles.cpp
|
||||
+++ b/filters/words/msword-odf/wv2/src/styles.cpp
|
||||
@@ -42,7 +42,6 @@ STD::STD()
|
||||
}
|
||||
|
||||
STD::STD( U16 baseSize, U16 totalSize, OLEStreamReader* stream, bool preservePos )
|
||||
-throw(InvalidFormatException)
|
||||
{
|
||||
clearInternal();
|
||||
if (!read( baseSize, totalSize, stream, preservePos )) {
|
||||
@@ -112,7 +111,6 @@ STD& STD::operator=( const STD& rhs )
|
||||
}
|
||||
|
||||
bool STD::read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos )
|
||||
-throw(InvalidFormatException)
|
||||
{
|
||||
U16 shifterU16;
|
||||
S32 startOffset=stream->tell(); // address where the STD starts
|
||||
@@ -938,7 +936,7 @@ void Style::mergeUpechpx( const Style* parentStyle, WordVersion version )
|
||||
}
|
||||
|
||||
|
||||
-StyleSheet::StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ) throw(InvalidFormatException)
|
||||
+StyleSheet::StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf )
|
||||
: m_udsNum(0)
|
||||
{
|
||||
WordVersion version = Word8;
|
||||
diff --git a/filters/words/msword-odf/wv2/src/styles.h b/filters/words/msword-odf/wv2/src/styles.h
|
||||
index ba02def6845..41c8278dd21 100644
|
||||
--- a/filters/words/msword-odf/wv2/src/styles.h
|
||||
+++ b/filters/words/msword-odf/wv2/src/styles.h
|
||||
@@ -58,8 +58,9 @@ struct STD
|
||||
STD();
|
||||
/**
|
||||
* Simply calls read(...)
|
||||
+ * @throw InvalidFormatException
|
||||
*/
|
||||
- STD( U16 stdfSize, U16 totalSize, OLEStreamReader* stream, bool preservePos = false ) throw(InvalidFormatException);
|
||||
+ STD( U16 stdfSize, U16 totalSize, OLEStreamReader* stream, bool preservePos = false );
|
||||
/**
|
||||
* Attention: This struct allocates memory on the heap
|
||||
*/
|
||||
@@ -74,8 +75,9 @@ struct STD
|
||||
* false the state of stream will be changed!
|
||||
*
|
||||
* @return true - success, false - failed
|
||||
+ * @throw InvalidFormatException
|
||||
*/
|
||||
- bool read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos = false ) throw(InvalidFormatException);
|
||||
+ bool read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos = false );
|
||||
|
||||
/**
|
||||
* Same as reading :)
|
||||
@@ -365,7 +367,10 @@ class WV2_EXPORT Style
|
||||
class WV2_EXPORT StyleSheet
|
||||
{
|
||||
public:
|
||||
- StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ) throw(InvalidFormatException);
|
||||
+ /**
|
||||
+ * @throw InvalidFormatException
|
||||
+ */
|
||||
+ StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf );
|
||||
~StyleSheet();
|
||||
|
||||
/**
|
22
extra/calligra/2ac46db5.patch
Normal file
22
extra/calligra/2ac46db5.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
From 2ac46db52c6ad401f67ae5b5fcd859a5872f0311 Mon Sep 17 00:00:00 2001
|
||||
From: Pierre Ducroquet <pinaraf@pinaraf.info>
|
||||
Date: Sat, 1 May 2021 15:08:57 +0200
|
||||
Subject: [PATCH] Small CMake modernization
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index fe6502493ed..b237f68fcb6 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -105,11 +90,7 @@ endif()
|
||||
message(STATUS "Release build: ${RELEASE_BUILD}")
|
||||
|
||||
# use CPP-11
|
||||
-if (CMAKE_VERSION VERSION_LESS "3.1")
|
||||
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
|
||||
-else ()
|
||||
- set (CMAKE_CXX_STANDARD 11)
|
||||
-endif ()
|
||||
+set (CMAKE_CXX_STANDARD 11)
|
||||
|
||||
############
|
||||
#############
|
|
@ -7,6 +7,16 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
index b237f68fcb6..cdcc02f0236 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -89,9 +89,6 @@ if(NOT DEFINED RELEASE_BUILD)
|
||||
endif()
|
||||
message(STATUS "Release build: ${RELEASE_BUILD}")
|
||||
|
||||
-# use CPP-11
|
||||
-set (CMAKE_CXX_STANDARD 11)
|
||||
-
|
||||
############
|
||||
#############
|
||||
## Options ##
|
||||
@@ -599,8 +593,8 @@ if(NOT WIN32 AND NOT APPLE)
|
||||
)
|
||||
endif()
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
pkgname=calligra
|
||||
pkgdesc='A set of applications for productivity and creative usage'
|
||||
pkgver=3.2.1
|
||||
pkgrel=26
|
||||
pkgrel=27
|
||||
arch=(x86_64)
|
||||
url='https://www.calligra-suite.org/'
|
||||
license=(FDL1.2 GPL2 LGPL)
|
||||
|
@ -29,21 +29,28 @@ optdepends=('libwpg: Corel WordPerfect Graphics image importer'
|
|||
'qt5-webengine: for Calligra Gemini')
|
||||
source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
calligra-openexr3.patch
|
||||
068cd9ae.patch
|
||||
2ac46db5.patch
|
||||
62f51070.patch)
|
||||
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
|
||||
'SKIP'
|
||||
'96fbe4f06bf184e60ff653a1574f0f0523af5b4672ced2a501cd54642961dffe'
|
||||
'9e2a0797ce0667212ec07a3056435a4550e07371ff1f6eefdf65dc3642d24165')
|
||||
'4516d15421209e5d8c8b5008140dbcb1eefa96b0e96e0da49b343e1799a8cefd'
|
||||
'c88e6d7a1f67c1b5413b624aa67fca2841205fdf4201f6682f69bae737582922'
|
||||
'8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867')
|
||||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
|
||||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgname-$pkgver -p1 < calligra-openexr3.patch # Fix build with OpenEXR 3
|
||||
patch -d $pkgname-$pkgver -p1 < 068cd9ae.patch # Remove dynamic exception specifications
|
||||
patch -d $pkgname-$pkgver -p1 < 2ac46db5.patch # Prerequisite for the following patch
|
||||
patch -d $pkgname-$pkgver -p1 < 62f51070.patch # Fix fontconfig linking
|
||||
}
|
||||
|
||||
build() {
|
||||
cmake -B build -S $pkgname-$pkgver \
|
||||
-DCMAKE_CXX_STANDARD=17 \
|
||||
-DBUILD_TESTING=OFF
|
||||
cmake --build build
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue