extra/chromium to 101.0.4951.64-1

This commit is contained in:
Kevin Mihelich 2022-05-11 12:48:07 +00:00
parent 4d0f3c971c
commit 1a48a6232e
3 changed files with 63 additions and 2 deletions

View file

@ -15,7 +15,7 @@
highmem=1
pkgname=chromium
pkgver=101.0.4951.54
pkgver=101.0.4951.64
pkgrel=1
_launcher_ver=8
_gcc_patchset=4
@ -36,6 +36,8 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
fix-no-member-named-tie-in-namespace-std.patch
iwyu-add-utility-for-std-exchange.patch
enable-GlobalMediaControlsCastStartStop.patch
chromium-libxml-unbundle.patch
sql-make-VirtualCursor-standard-layout-type.patch
@ -43,9 +45,11 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('c26cc6fd453d9a42a6b5e46fa4f3ee62ed368bb78101512b6816bc5d8f4200b5'
sha256sums=('9c5896e4135563453ac10d15698c18ef61eb5535dc611325b230ece4c5a8d8f7'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'8ed519d21ccd8b382ddd384e9c15306a60d2e3495f48a62dea07c9be9bbffebd'
'7ad0106161bbf25e2e603ae1a723ae4217155ebb26eb4778363ad396e8c14156'
'6f666ef0acb08704ca58cc0d5e97e7ce64d8fea51042e593adae1ce15a61231c'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'fd3bf124aacc45f2d0a4f1dd86303fa7f2a3d4f4eeaf33854631d6cb39e12485'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
@ -122,6 +126,8 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
patch -Np1 -i ../fix-no-member-named-tie-in-namespace-std.patch
patch -Np1 -i ../iwyu-add-utility-for-std-exchange.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342

View file

@ -0,0 +1,28 @@
From 68c9c63c0b148ff5246a0cdad59000697bbd8645 Mon Sep 17 00:00:00 2001
From: Maksim Sisov <msisov@igalia.com>
Date: Tue, 12 Apr 2022 15:11:34 +0000
Subject: [PATCH] Fix no member named 'tie' in namespace 'std'
Bug: None
Change-Id: I8a097af2b16b738fa9bbb8231536bca85522f350
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3581869
Auto-Submit: Maksim Sisov <msisov@igalia.com>
Reviewed-by: Matt Menke <mmenke@chromium.org>
Commit-Queue: Matt Menke <mmenke@chromium.org>
Cr-Commit-Position: refs/heads/main@{#991529}
---
net/base/address_list.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/net/base/address_list.h b/net/base/address_list.h
index 029af1aded3..a93093e41f3 100644
--- a/net/base/address_list.h
+++ b/net/base/address_list.h
@@ -8,6 +8,7 @@
#include <stdint.h>
#include <string>
+#include <tuple>
#include <utility>
#include <vector>

View file

@ -0,0 +1,27 @@
From 9dd0503835dc875807ab63efb1f477bffed2a852 Mon Sep 17 00:00:00 2001
From: Stephan Hartmann <stha09@googlemail.com>
Date: Mon, 25 Apr 2022 23:18:30 +0000
Subject: [PATCH] IWYU: add utility for std::exchange
Bug: 957519
Change-Id: I307d520fdc34d2452018ed32a505e7e519739410
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3604643
Reviewed-by: Wez <wez@chromium.org>
Commit-Queue: Stephan Hartmann <stha09@googlemail.com>
Cr-Commit-Position: refs/heads/main@{#995855}
---
base/third_party/symbolize/symbolize.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/base/third_party/symbolize/symbolize.h b/base/third_party/symbolize/symbolize.h
index 99029a968d5..278078f6071 100644
--- a/base/third_party/symbolize/symbolize.h
+++ b/base/third_party/symbolize/symbolize.h
@@ -61,6 +61,7 @@
#ifdef HAVE_SYMBOLIZE
#include <algorithm>
+#include <utility>
#if defined(__ELF__) // defined by gcc
#if defined(__OpenBSD__)