mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/mysql-workbench: fix
This commit is contained in:
parent
da0de907b8
commit
1a49c17d5c
3 changed files with 98 additions and 144 deletions
88
community/mysql-workbench/0001-fix-buiild-for-32-bit.patch
Normal file
88
community/mysql-workbench/0001-fix-buiild-for-32-bit.patch
Normal file
|
@ -0,0 +1,88 @@
|
|||
From ab7ee7f3786c1cf83e4835f50e509261573f39df Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 15 Nov 2019 18:43:53 -0700
|
||||
Subject: [PATCH] fix buiild for 32-bit
|
||||
|
||||
---
|
||||
backend/wbprivate/sqlide/wb_sql_editor_form.cpp | 2 +-
|
||||
library/ssh/SSHCommon.cpp | 12 ++++++------
|
||||
library/ssh/SSHSession.cpp | 6 +++---
|
||||
3 files changed, 10 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/backend/wbprivate/sqlide/wb_sql_editor_form.cpp b/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
index 6a2f65d..528fd96 100644
|
||||
--- a/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
+++ b/backend/wbprivate/sqlide/wb_sql_editor_form.cpp
|
||||
@@ -2016,7 +2016,7 @@ grt::StringRef SqlEditorForm::do_exec_sql(Ptr self_ptr, std::shared_ptr<std::str
|
||||
|
||||
bool results_left = false;
|
||||
for (auto &statement_range : statement_ranges) {
|
||||
- logDebug3("Executing statement range: %lu, %lu...\n", statement_range.first, statement_range.second);
|
||||
+ logDebug3("Executing statement range: %u, %u...\n", statement_range.first, statement_range.second);
|
||||
|
||||
statement = sql->substr(statement_range.first, statement_range.second);
|
||||
std::list<std::string> sub_statements;
|
||||
diff --git a/library/ssh/SSHCommon.cpp b/library/ssh/SSHCommon.cpp
|
||||
index e65ecb6..093ec3e 100644
|
||||
--- a/library/ssh/SSHCommon.cpp
|
||||
+++ b/library/ssh/SSHCommon.cpp
|
||||
@@ -168,11 +168,11 @@ namespace ssh {
|
||||
|
||||
void SSHConnectionConfig::dumpConfig() const {
|
||||
logDebug2("SSH Connection config info:\n");
|
||||
- logDebug2("SSH bufferSize: %lu\n", bufferSize);
|
||||
- logDebug2("SSH connectTimeout: %lu\n", connectTimeout);
|
||||
- logDebug2("SSH readWriteTimeout: %lu\n", readWriteTimeout);
|
||||
- logDebug2("SSH commandTimeout: %lu\n", commandTimeout);
|
||||
- logDebug2("SSH commandRetryCount: %lu\n", commandRetryCount);
|
||||
+ logDebug2("SSH bufferSize: %u\n", bufferSize);
|
||||
+ logDebug2("SSH connectTimeout: %u\n", connectTimeout);
|
||||
+ logDebug2("SSH readWriteTimeout: %u\n", readWriteTimeout);
|
||||
+ logDebug2("SSH commandTimeout: %u\n", commandTimeout);
|
||||
+ logDebug2("SSH commandRetryCount: %u\n", commandRetryCount);
|
||||
logDebug2("SSH optionsDir: %s\n", optionsDir.c_str());
|
||||
logDebug2("SSH known hosts file: %s\n", knownHostsFile.c_str());
|
||||
logDebug2("SSH local host: %s\n", localhost.c_str());
|
||||
@@ -180,7 +180,7 @@ namespace ssh {
|
||||
logDebug2("SSH remote host: %s\n", remotehost.c_str());
|
||||
logDebug2("SSH remote port: %d\n", remoteport);
|
||||
logDebug2("SSH remote ssh host: %s\n", remoteSSHhost.c_str());
|
||||
- logDebug2("SSH remote ssh port: %lu\n", remoteSSHport);
|
||||
+ logDebug2("SSH remote ssh port: %u\n", remoteSSHport);
|
||||
logDebug2("SSH strict host key check: %s\n", strictHostKeyCheck ? "yes" : "no");
|
||||
}
|
||||
|
||||
diff --git a/library/ssh/SSHSession.cpp b/library/ssh/SSHSession.cpp
|
||||
index a30ebbc..b223171 100644
|
||||
--- a/library/ssh/SSHSession.cpp
|
||||
+++ b/library/ssh/SSHSession.cpp
|
||||
@@ -147,7 +147,7 @@ namespace ssh {
|
||||
try {
|
||||
_session->connect();
|
||||
} catch (ssh::SshException &exc) {
|
||||
- logError("Unable to connect: %s:%lu\nError was: %s\n", config.remoteSSHhost.c_str(), config.remoteSSHport,
|
||||
+ logError("Unable to connect: %s:%u\nError was: %s\n", config.remoteSSHhost.c_str(), config.remoteSSHport,
|
||||
exc.getError().c_str());
|
||||
return std::make_tuple(SSHReturnType::CONNECTION_FAILURE, exc.getError());
|
||||
}
|
||||
@@ -360,7 +360,7 @@ namespace ssh {
|
||||
}
|
||||
} while (true);
|
||||
|
||||
- logDebug3("Bytes read: %lu\n", bytesRead);
|
||||
+ logDebug3("Bytes read: %u\n", bytesRead);
|
||||
return std::make_tuple(so.str(), retError, channel->getExitStatus());
|
||||
}
|
||||
|
||||
@@ -479,7 +479,7 @@ namespace ssh {
|
||||
}
|
||||
} while (true);
|
||||
|
||||
- logDebug3("Bytes read: %lu\n", bytesRead);
|
||||
+ logDebug3("Bytes read: %u\n", bytesRead);
|
||||
return std::make_tuple(so.str(), retError, channel->getExitStatus());
|
||||
}
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
|
@ -1,139 +0,0 @@
|
|||
From 73b6b2f8526080644c0686cf68f621f02d5ef7c7 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Wed, 8 Feb 2017 13:26:51 +0100
|
||||
Subject: [PATCH] fix build for 32bit systems
|
||||
|
||||
---
|
||||
library/base/jsonparser.cpp | 6 ++++--
|
||||
library/forms/jsonview.cpp | 12 ++++++++++++
|
||||
2 files changed, 16 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/library/base/jsonparser.cpp b/library/base/jsonparser.cpp
|
||||
index 6ed4b3f4..fb4e0550 100644
|
||||
--- a/library/base/jsonparser.cpp
|
||||
+++ b/library/base/jsonparser.cpp
|
||||
@@ -343,7 +343,7 @@ namespace JsonParser {
|
||||
*/
|
||||
JsonValue &JsonArray::at(SizeType pos) {
|
||||
if (pos > _data.size())
|
||||
- throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
|
||||
+ throw std::out_of_range(base::strfmt("Index '%zu' is out of range.", pos));
|
||||
return _data.at(pos);
|
||||
}
|
||||
|
||||
@@ -358,7 +358,7 @@ namespace JsonParser {
|
||||
*/
|
||||
const JsonValue &JsonArray::at(SizeType pos) const {
|
||||
if (pos > _data.size())
|
||||
- throw std::out_of_range(base::strfmt("Index '%lu' is out of range.", pos));
|
||||
+ throw std::out_of_range(base::strfmt("Index '%zu' is out of range.", pos));
|
||||
return _data.at(pos);
|
||||
}
|
||||
|
||||
@@ -1668,12 +1668,14 @@ namespace JsonParser {
|
||||
case VDouble:
|
||||
_output += std::to_string((double)value);
|
||||
break;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
case VInt64:
|
||||
_output += std::to_string((int64_t)value);
|
||||
break;
|
||||
case VUint64:
|
||||
_output += std::to_string((uint64_t)value);
|
||||
break;
|
||||
+#endif
|
||||
case VObject:
|
||||
write((JsonObject)value);
|
||||
break;
|
||||
diff --git a/library/forms/jsonview.cpp b/library/forms/jsonview.cpp
|
||||
index dedca7b9..ca894dfe 100644
|
||||
--- a/library/forms/jsonview.cpp
|
||||
+++ b/library/forms/jsonview.cpp
|
||||
@@ -651,8 +651,10 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||
if (data != nullptr) {
|
||||
std::stringstream buffer;
|
||||
double number = 0;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
int64_t number2 = 0;
|
||||
uint64_t number3 = 0;
|
||||
+#endif
|
||||
bool retBool = false;
|
||||
auto &storedValue = data->getData();
|
||||
switch (storedValue.getType()) {
|
||||
@@ -664,6 +666,7 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||
storedValue = number;
|
||||
setData = true;
|
||||
break;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
case VInt64:
|
||||
if (!base::is_number(value))
|
||||
break;
|
||||
@@ -680,6 +683,7 @@ void JsonTreeBaseView::setCellValue(mforms::TreeNodeRef node, int column, const
|
||||
storedValue = number3;
|
||||
setData = true;
|
||||
break;
|
||||
+#endif
|
||||
case VBoolean:
|
||||
if (!base::isBool(value))
|
||||
break;
|
||||
@@ -1073,6 +1077,7 @@ void JsonTreeView::generateNumberInTree(JsonParser::JsonValue &value, int /*colu
|
||||
node->set_string(1, std::to_string((double)value));
|
||||
node->set_string(2, "Double");
|
||||
break;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
case VInt64:
|
||||
node->set_string(1, std::to_string((int64_t)value));
|
||||
node->set_string(2, "Long Integer");
|
||||
@@ -1081,6 +1086,7 @@ void JsonTreeView::generateNumberInTree(JsonParser::JsonValue &value, int /*colu
|
||||
node->set_string(1, std::to_string((uint64_t)value));
|
||||
node->set_string(2, "Unsigned Long Integer");
|
||||
break;
|
||||
+#endif
|
||||
default:
|
||||
break;
|
||||
}
|
||||
@@ -1322,8 +1328,10 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||
if (data != NULL) {
|
||||
std::stringstream buffer;
|
||||
double number = 0;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
int64_t number2 = 0;
|
||||
uint64_t number3 = 0;
|
||||
+#endif
|
||||
bool retBool = false;
|
||||
switch (storedValue.getType()) {
|
||||
case VDouble:
|
||||
@@ -1334,6 +1342,7 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||
storedValue = number;
|
||||
node->set_float(column, number);
|
||||
_dataChanged(false);
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
break;
|
||||
case VInt64:
|
||||
if (!base::is_number(value))
|
||||
@@ -1353,6 +1362,7 @@ void JsonGridView::setCellValue(mforms::TreeNodeRef node, int column, const std:
|
||||
node->set_float(column, (double)number3);
|
||||
_dataChanged(false);
|
||||
break;
|
||||
+#endif
|
||||
case VBoolean:
|
||||
if (!base::isBool(value))
|
||||
break;
|
||||
@@ -1612,12 +1622,14 @@ void JsonGridView::generateNumberInTree(JsonParser::JsonValue &value, int column
|
||||
case VDouble:
|
||||
node->set_float(columnId, (double)value);
|
||||
break;
|
||||
+#ifdef DEFINE_UINT64_T_FUNCTIONS
|
||||
case VInt64:
|
||||
node->set_long(columnId, (int64_t)value);
|
||||
break;
|
||||
case VUint64:
|
||||
node->set_long(columnId, (uint64_t)value);
|
||||
break;
|
||||
+#endif
|
||||
default:
|
||||
break;
|
||||
}
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -6,7 +6,8 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use our cxxflags plus -fsigned-char
|
||||
# - keep build fix for i686 (fixes 32-bit ARM)
|
||||
# - patch to fix build on 32-bit
|
||||
# - remove -Wno-deprecated-copy flag from CMakeLists.txt
|
||||
|
||||
highmem=1
|
||||
buildarch=12
|
||||
|
@ -37,7 +38,7 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0004-fix-build-for-i686.patch'
|
||||
'0001-fix-buiild-for-32-bit.patch'
|
||||
'atomic.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('4bd3c31ac5463ac51085f77ae09f629771f19d1e804da98b5f9e8de67aa7d615'
|
||||
|
@ -50,7 +51,7 @@ sha256sums=('4bd3c31ac5463ac51085f77ae09f629771f19d1e804da98b5f9e8de67aa7d615'
|
|||
'430ae8354789de4fd19ee52f3b1f739e1fba576f0aded0897c3c2bc00fb38778'
|
||||
'cdf687f23bc6e8d52dbee9fa02b23d755e80f88476f0fc2e7c4c71cdfed3792f'
|
||||
'2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18'
|
||||
'763925b336d9a398c15fdd757b6567a2f374a822090d32ffdefca018231128a4'
|
||||
'719501bbd1de673767007c429feed2fc48d1176d456161c4ba69cf3165c0438a'
|
||||
'17294a67637ab7ffff5c39262208e63d21acac72cc2492f616ef1d8e0ae9ac02'
|
||||
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
||||
|
||||
|
@ -67,8 +68,6 @@ prepare() {
|
|||
|
||||
# be happy with more recent antlr
|
||||
sed -i '/set(ANTLR_JAR_FILENAME/s/4.7.1/4.7.2/' CMakeLists.txt
|
||||
# fix build for i686
|
||||
patch -Np1 < "${srcdir}"/0004-fix-build-for-i686.patch
|
||||
|
||||
# GCC 7.x introduced some new warnings, remove '-Werror' for the build to complete
|
||||
sed -i '/^set/s|-Werror -Wall|-Wall|' CMakeLists.txt
|
||||
|
@ -82,6 +81,12 @@ prepare() {
|
|||
# make sure to link against bundled libraries
|
||||
sed -i "/target_link_libraries/s|\\$|-L${srcdir}/install-bundle/usr/lib/ \\$|" backend/wbpublic/CMakeLists.txt
|
||||
|
||||
# remove -Wno-deprecated-copy
|
||||
sed -i 's|-Wno-deprecated-copy||' CMakeLists.txt
|
||||
|
||||
# fix build with 32-bit
|
||||
[[ $CARCH != "aarch64" ]] && patch -Np1 < "${srcdir}"/0001-fix-buiild-for-32-bit.patch
|
||||
|
||||
# link v6 against libatomic
|
||||
cd "${srcdir}/mysql-${_mysql_version}"
|
||||
if [[ $CARCH == "armv6h" ]]; then
|
||||
|
|
Loading…
Reference in a new issue