core/linux-kirkwood-dt to 3.18.3-1

This commit is contained in:
moonman 2015-01-23 02:10:34 +00:00
parent acb6225bc4
commit 1abd691cf4
4 changed files with 15 additions and 111 deletions

View file

@ -1,86 +0,0 @@
From b4e9c2511bfe0eed13f7d0550241b60f6730d76a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 18 Dec 2014 00:41:44 -0700
Subject: [PATCH] AUFS fix for 3.18.1
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
fs/aufs/dcsub.c | 4 ++--
fs/aufs/debug.c | 2 +-
fs/aufs/export.c | 2 +-
fs/aufs/hnotify.c | 4 ++--
4 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/fs/aufs/dcsub.c b/fs/aufs/dcsub.c
index 9fbc218..04663e5 100644
--- a/fs/aufs/dcsub.c
+++ b/fs/aufs/dcsub.c
@@ -134,7 +134,7 @@ resume:
while (next != &this_parent->d_subdirs) {
struct list_head *tmp = next;
struct dentry *dentry = list_entry(tmp, struct dentry,
- d_u.d_child);
+ d_child);
next = tmp->next;
spin_lock_nested(&dentry->d_lock, DENTRY_D_LOCK_NESTED);
@@ -170,7 +170,7 @@ resume:
this_parent = tmp;
spin_lock(&this_parent->d_lock);
rcu_read_unlock();
- next = child->d_u.d_child.next;
+ next = child->d_child.next;
goto resume;
}
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
index e3ee24d..563bac0 100644
--- a/fs/aufs/debug.c
+++ b/fs/aufs/debug.c
@@ -169,7 +169,7 @@ void au_dpri_dalias(struct inode *inode)
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff --git a/fs/aufs/export.c b/fs/aufs/export.c
index 32df1ed..864ec30 100644
--- a/fs/aufs/export.c
+++ b/fs/aufs/export.c
@@ -243,7 +243,7 @@ static struct dentry *decode_by_ino(struct super_block *sb, ino_t ino,
dentry = d_find_alias(inode);
else {
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
if (!au_test_anon(d)
&& d->d_parent->d_inode->i_ino == dir_ino) {
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
index e120c55..94d6d6e 100644
--- a/fs/aufs/hnotify.c
+++ b/fs/aufs/hnotify.c
@@ -211,7 +211,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
@@ -378,7 +378,7 @@ static struct dentry *lookup_wlock_by_name(char *name, unsigned int nlen,
dentry = NULL;
spin_lock(&parent->d_lock);
- list_for_each_entry(d, &parent->d_subdirs, d_u.d_child) {
+ list_for_each_entry(d, &parent->d_subdirs, d_child) {
/* AuDbg("%pd\n", d); */
spin_lock_nested(&d->d_lock, DENTRY_D_LOCK_NESTED);
dname = &d->d_name;
--
2.1.3

View file

@ -6,10 +6,10 @@ buildarch=2
pkgbase=linux-kirkwood-dt
_kernelname=${pkgbase#linux}
_desc="Marvell Kirkwood DT"
pkgver=3.18.1
pkgver=3.18.3
pkgrel=1
cryptodev_commit=6aa62a2c320b04f55fdfe0ed015c3d9b48997239
bfqver=v7r6
bfqver=v7r7
arch=('arm')
url="http://www.kernel.org/"
@ -20,32 +20,28 @@ options=('!strip')
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${pkgver}.tar.xz"
'config'
'archlinuxarm.patch'
'mach-types::http://www.arm.linux.org.uk/developer/machines/download.php'
'usb-add-reset-resume-quirk-for-several-webcams.patch'
'0001-disable-mv643xx_eth-TSO.patch'
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
# "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}"
'0001-AUFS-fix-for-3.18.1.patch'
'cryptodev::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz'
# "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}.1+"
"cryptodev.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
'goflexhome_dtb.patch'
'pogo_e02_dtb.patch'
'mvsdio TX DMA workaround.patch')
'mvsdio_TX-DMA_workaround.patch')
md5sums=('79c9b73a01e1dce0a4c28828496ef02c'
md5sums=('7f37f59b9f01945c9503bc9deed88820'
'5dbb04ebed1afb6d2e1408598cd34ad7'
'e319a8e1a596a39a8951fc6454664b15'
'78aa4e6802026e4db4207940788ab83e'
'9b5a265440abf57d2052838f31486a3a'
'09d44b9f07abfaeaf4f688ee52034786'
'SKIP'
'aa83d1bca3a3583aa4011d03ff23bfd5'
'ddf7876487c876f6676ef0e050e9d204'
'f84f5f809a0f92e5e469d7c9e2dbac58'
'22ef862652608c8d6b07536e990d4bcb'
'b031b1aafd416453d1c8579bd6823fca'
'1c7c2d0338939a9e6953a64d80861471'
'a81346cce95baeac2c56cf60d3c7e5b6'
'8f2743651280f5a022e541f4e95e5546'
'e42c64b6f4b54f382cf3d7e8d82968f1'
'341f8164dad19b6baf05d764a800862a'
'fd50ede1d3bfdd4b00a3c830ebf2db0d')
@ -54,19 +50,14 @@ prepare() {
cd "${srcdir}/linux-${pkgver}"
msg2 "Copying aufs3 patches into the kernel source tree"
cp -ru "${srcdir}/aufs3-standalone/Documentation" "${srcdir}/linux-${pkgver}/"
cp -ru "${srcdir}/aufs3-standalone/fs" "${srcdir}/linux-${pkgver}/"
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/linux-${pkgver}/include/linux/"
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/linux-${pkgver}/include/uapi/linux/"
cp -ru "${srcdir}/aufs3-standalone/"{Documentation,fs} "${srcdir}/linux-${pkgver}/"
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/linux-${pkgver}/include/"{linux/,uapi/linux/}
msg2 "Applying aufs3 patches"
patch -Np1 -i ../aufs3-standalone/aufs3-kbuild.patch
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
# Remove when updated upstream
patch -Np1 -i ../0001-AUFS-fix-for-3.18.1.patch
msg2 "Disable buggy TCP segmentation offload implementation"
msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
@ -77,11 +68,10 @@ msg2 "Add the USB_QUIRK_RESET_RESUME for several webcams"
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
msg2 "Work around broken TX DMA in mvsdio"
patch -Np1 -i "${srcdir}/mvsdio TX DMA workaround.patch"
patch -Np1 -i "${srcdir}/mvsdio_TX-DMA_workaround.patch"
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers, mach-types"
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
cp "${srcdir}/mach-types" arch/arm/tools
patch -Np1 -i "${srcdir}/goflexhome_dtb.patch"
patch -Np1 -i "${srcdir}/pogo_e02_dtb.patch"

View file

@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-kirkwood-dt
KERNEL_VERSION=3.17.0-1-ARCH
KERNEL_VERSION=3.18.3-1-ARCH
post_install () {
# updating module dependencies