mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
alarm/uboot-pandaboard to 2016.05-1
This commit is contained in:
parent
f86d6ecb92
commit
1b8012c2f7
2 changed files with 47 additions and 14 deletions
|
@ -1,14 +1,38 @@
|
|||
From 155254c40177888573014c52c256cc530eb210d1 Mon Sep 17 00:00:00 2001
|
||||
From 774ceae7a29cc5492ad6559169fdf7f43c48608e Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 16 Mar 2016 20:06:42 -0600
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
---
|
||||
include/configs/ti_omap4_common.h | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
configs/omap4_panda_defconfig | 5 ++++-
|
||||
include/configs/ti_omap4_common.h | 7 ++++---
|
||||
2 files changed, 8 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
|
||||
index 406f0ac..8f62717 100644
|
||||
--- a/configs/omap4_panda_defconfig
|
||||
+++ b/configs/omap4_panda_defconfig
|
||||
@@ -3,6 +3,10 @@ CONFIG_OMAP44XX=y
|
||||
CONFIG_TARGET_OMAP4_PANDA=y
|
||||
CONFIG_SPL=y
|
||||
CONFIG_HUSH_PARSER=y
|
||||
+CONFIG_AUTOBOOT_KEYED=y
|
||||
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
|
||||
+CONFIG_AUTOBOOT_DELAY_STR="d"
|
||||
+CONFIG_AUTOBOOT_STOP_STR=" "
|
||||
CONFIG_CMD_BOOTZ=y
|
||||
# CONFIG_CMD_IMLS is not set
|
||||
CONFIG_CMD_ASKENV=y
|
||||
@@ -19,7 +23,6 @@ CONFIG_CMD_MII=y
|
||||
CONFIG_CMD_PING=y
|
||||
CONFIG_CMD_EXT2=y
|
||||
CONFIG_CMD_EXT4=y
|
||||
-CONFIG_CMD_EXT4_WRITE=y
|
||||
CONFIG_CMD_FAT=y
|
||||
CONFIG_CMD_FS_GENERIC=y
|
||||
CONFIG_SYS_NS16550=y
|
||||
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
||||
index 8b6c065..03d9e7a 100644
|
||||
index 5fad3c1..8d97f56 100644
|
||||
--- a/include/configs/ti_omap4_common.h
|
||||
+++ b/include/configs/ti_omap4_common.h
|
||||
@@ -12,6 +12,8 @@
|
||||
|
@ -20,7 +44,16 @@ index 8b6c065..03d9e7a 100644
|
|||
/*
|
||||
* High Level Configuration Options
|
||||
*/
|
||||
@@ -96,9 +98,8 @@
|
||||
@@ -45,7 +47,7 @@
|
||||
* the timings to use or use pre-determined timings (based on using the
|
||||
* dynamic method. Default to the static timing infomation.
|
||||
*/
|
||||
-#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
||||
+/*#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS*/
|
||||
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
||||
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
||||
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
||||
@@ -95,9 +97,8 @@
|
||||
|
||||
#define BOOT_TARGET_DEVICES(func) \
|
||||
func(MMC, mmc, 0) \
|
||||
|
@ -32,5 +65,5 @@ index 8b6c065..03d9e7a 100644
|
|||
func(DHCP, dhcp, na)
|
||||
|
||||
--
|
||||
2.7.3
|
||||
2.9.0
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-pandaboard
|
||||
pkgver=2016.03
|
||||
pkgver=2016.05
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
|
||||
arch=('armv7h')
|
||||
|
@ -13,33 +13,33 @@ makedepends=('bc' 'dtc' 'git')
|
|||
license=('GPL')
|
||||
install=${pkgname}.install
|
||||
backup=('boot/boot.txt' 'boot/boot.scr')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'boot.txt'
|
||||
'mkscr')
|
||||
md5sums=('973c1d896be751321cc3aafa564f64b2'
|
||||
'87c8adf701979f8bbb85360856bd9b23'
|
||||
md5sums=('3a8613d753dfa707c937991a35404510'
|
||||
'ce9ea0db31915fda7e4527e88d3d57d3'
|
||||
'4908cf55626f1109276f14111b11117d'
|
||||
'021623a04afd29ac3f368977140cfbfd')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
git apply ../0001-arch-linux-arm-modifications.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
unset LDFLAGS
|
||||
|
||||
make distclean
|
||||
make omap4_panda_config
|
||||
make omap4_panda_defconfig
|
||||
make EXTRAVERSION=-${pkgrel}
|
||||
}
|
||||
|
||||
package() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp MLO u-boot.img "${pkgdir}"/boot
|
||||
|
|
Loading…
Reference in a new issue