mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt6-webengine: fix
This commit is contained in:
parent
eba7ac792c
commit
1bc67f7bd4
4 changed files with 17 additions and 45 deletions
|
@ -1,14 +1,14 @@
|
|||
From 28ee70e324c7946a4e939515d4f6a8e1f5d87e83 Mon Sep 17 00:00:00 2001
|
||||
From 46dc6b6a276e974341328f78451678d756c382f9 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH 1/3] ARM toolchain fixes
|
||||
Subject: [PATCH 1/2] ARM toolchain fixes
|
||||
|
||||
---
|
||||
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
||||
1 file changed, 10 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
|
||||
index e562f5a5f26..6defaf00db2 100644
|
||||
index 0c0b0a3321e..fa147fa5667 100644
|
||||
--- a/chromium/build/toolchain/linux/BUILD.gn
|
||||
+++ b/chromium/build/toolchain/linux/BUILD.gn
|
||||
@@ -31,15 +31,13 @@ clang_toolchain("clang_arm64") {
|
||||
|
@ -54,5 +54,5 @@ index e562f5a5f26..6defaf00db2 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.33.0
|
||||
2.35.1
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From f93cfb3e00903cb4d7a068f2030683d28dc27bb8 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Jul 2019 07:10:36 -0600
|
||||
Subject: [PATCH 2/3] Fix ARM skia ICE
|
||||
|
||||
---
|
||||
chromium/third_party/skia/third_party/skcms/src/Transform_inl.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
index 4ec175c245e..26b61d02035 100644
|
||||
--- a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
+++ b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
@@ -690,7 +690,7 @@ SI void sample_clut_16(const skcms_A2B* a2b, I32 ix, F* r, F* g, F* b) {
|
||||
// GCC 7.2.0 hits an internal compiler error with -finline-functions (or -O3)
|
||||
// when targeting MIPS 64, i386, or s390x, I think attempting to inline clut() into exec_ops().
|
||||
#if 1 && defined(__GNUC__) && !defined(__clang__) \
|
||||
- && (defined(__mips64) || defined(__i386) || defined(__s390x__))
|
||||
+ && (defined(__mips64) || defined(__i386) || defined(__s390x__) || defined(__arm__))
|
||||
#define MAYBE_NOINLINE __attribute__((noinline))
|
||||
#else
|
||||
#define MAYBE_NOINLINE
|
||||
--
|
||||
2.33.0
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 917a82b9fd93d6c994c9bac6ea1deeaefeadd6f3 Mon Sep 17 00:00:00 2001
|
||||
From 8b1d4ec4b3f5c569eef9d8e5d40cb0e961d6ba31 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:59 -0700
|
||||
Subject: [PATCH 3/3] Run blink bindings generation single threaded
|
||||
Subject: [PATCH 2/2] Run blink bindings generation single threaded
|
||||
|
||||
When not single threaded this process will eat all the RAM.
|
||||
---
|
||||
|
@ -9,17 +9,17 @@ When not single threaded this process will eat all the RAM.
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/chromium/third_party/blink/renderer/bindings/BUILD.gn b/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
index 61c9e7f59da..a33c9e4144d 100644
|
||||
index 30017570a13..f88e5906f23 100644
|
||||
--- a/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
+++ b/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
@@ -178,6 +178,7 @@ template("generate_bindings") {
|
||||
@@ -148,6 +148,7 @@ template("generate_bindings") {
|
||||
outputs = invoker.outputs
|
||||
|
||||
args = [
|
||||
+ "--single_process",
|
||||
"--web_idl_database",
|
||||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
+ "--single_process",
|
||||
"--web_idl_database",
|
||||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
--
|
||||
2.33.0
|
||||
2.35.1
|
||||
|
|
@ -28,13 +28,11 @@ _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
|
|||
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
|
||||
qt6-webengine-system-icu.patch::https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=75f0f4eb
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch
|
||||
0003-Run-blink-bindings-generation-single-threaded.patch)
|
||||
0002-Run-blink-bindings-generation-single-threaded.patch)
|
||||
sha256sums=('2001b45dd81dcb7ad1bc6cf1aa32f2eca5367a11fed49656053c75676c4d093d'
|
||||
'ec28b71135f293f624365a50be0c329e396eaa9433655386af146614837e82a2'
|
||||
'3dba0f507498ed078dbe5dc5753c593fa6babb7252be1cb964c404b62bf600ab'
|
||||
'20f5f470bdd350e40046eb11cd786730aaa777a2ad6b68d004f7464313792320'
|
||||
'005e5c1476b2c6e8edd6ab0637315cf268060090a7d3a89060a339f9ce4c9851')
|
||||
'c5d8fc6b3b832a2b4b14c926c36051d7245d5fc37a1c3a54657afd5b5c4ed623'
|
||||
'1a5858dd198dd0db649c55357941c9bfa9ad678b5d4b93121f87fa9f314d4e6e')
|
||||
|
||||
prepare() {
|
||||
patch -d $_pkgfn/src/3rdparty -p1 < qt6-webengine-system-icu.patch # Fix build with system ICU
|
||||
|
@ -47,8 +45,7 @@ prepare() {
|
|||
fi
|
||||
cd "$srcdir/$_pkgfn/src/3rdparty"
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
|
||||
patch -p1 -i ${srcdir}/0003-Run-blink-bindings-generation-single-threaded.patch
|
||||
patch -p1 -i ${srcdir}/0002-Run-blink-bindings-generation-single-threaded.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue