diff --git a/core/kernel26-trimslice/PKGBUILD b/core/kernel26-trimslice/PKGBUILD
index a56490aa6..4157dc3ba 100644
--- a/core/kernel26-trimslice/PKGBUILD
+++ b/core/kernel26-trimslice/PKGBUILD
@@ -38,7 +38,7 @@ build() {
   cd $srcdir
   git clone git://gitorious.org/trimslice-kernel/trimslice-kernel.git --depth 1
   cd trimslice-kernel
-  git checkout trimslice/ldk-alpha-upstream
+  git checkout trimslice/1.01-upstream
 
   # Add -ARCH patches
   # See http://projects.archlinux.org/linux-2.6-ARCH.git/
@@ -57,13 +57,13 @@ build() {
   make clean # sometimes git isn't clean
   make mrproper # same as above
   # Configure the kernel. Replace the line below with one of your choice.
-  make trimslice_chrome_defconfig # The branch we're using
+  make trimslice_defconfig # The branch we're using
   #make menuconfig # CLI menu for configuration
   #make nconfig # new CLI menu for configuration
   #make oldconfig # using old config from previous kernel version
 
   # Make the config compatible with Arch Linux's naming scheme
-  sed 's|CONFIG_LOCALVERSION="-ldk-alpha-rc1"|CONFIG_LOCALVERSION="-ARCH"|g' -i .config
+  sed 's|CONFIG_LOCALVERSION="-trimslice-1.01"|CONFIG_LOCALVERSION="-ARCH"|g' -i .config
 
   # Copy back our configuration (use with new kernel version)
   #cp ./.config ../${_basekernel}.config