mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mesa to 12.0.1-1
This commit is contained in:
parent
1badaab1fd
commit
1bf7664299
2 changed files with 35 additions and 15 deletions
|
@ -7,31 +7,34 @@
|
||||||
# - Removed libgles, libegl and khrplatform-devel from conflicts for marvell-libgfx compatibility.
|
# - Removed libgles, libegl and khrplatform-devel from conflicts for marvell-libgfx compatibility.
|
||||||
# - Moved .pc files to mesa-libgl that reference libraries in mesa-libgl
|
# - Moved .pc files to mesa-libgl that reference libraries in mesa-libgl
|
||||||
# - Build vc4 gallium driver for v6/v7
|
# - Build vc4 gallium driver for v6/v7
|
||||||
# - Keep prepare function for older llvm (remove when llvm is fixed)
|
|
||||||
|
|
||||||
pkgbase=mesa
|
pkgbase=mesa
|
||||||
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
|
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
|
||||||
pkgver=11.2.2
|
pkgver=12.0.1
|
||||||
pkgrel=1.1
|
pkgrel=1
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||||
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'elfutils' 'llvm'
|
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'elfutils' 'llvm'
|
||||||
'systemd' 'libomxil-bellagio' 'libgcrypt' 'clang')
|
'systemd' 'libomxil-bellagio' 'libgcrypt' 'clang')
|
||||||
url="http://mesa3d.sourceforge.net"
|
url="http://mesa3d.sourceforge.net"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
options=('!libtool')
|
options=('!libtool')
|
||||||
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
|
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
|
||||||
LICENSE)
|
LICENSE
|
||||||
sha256sums=('40e148812388ec7c6d7b6657d5a16e2e8dabba8b97ddfceea5197947647bdfb4'
|
remove-libpthread-stubs.patch)
|
||||||
|
sha256sums=('bab24fb79f78c876073527f515ed871fc9c81d816f66c8a0b051d8d653896389'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
|
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||||
|
'd82c329e89754266eb1538df29b94d33692a66e3b6882b2cee78f4d5aab4a39c')
|
||||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${srcdir}/?esa-*
|
cd ${srcdir}/?esa-*
|
||||||
|
|
||||||
# Fix detection of libLLVM when built with CMake
|
# Now mesa checks for libpthread-stubs - so remove the check
|
||||||
sed -i 's/LLVM_SO_NAME=.*/LLVM_SO_NAME=LLVM/' configure
|
patch -Np1 -i ../remove-libpthread-stubs.patch
|
||||||
|
|
||||||
|
autoreconf -fiv
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -46,17 +49,17 @@ build() {
|
||||||
--with-dri-drivers=nouveau,swrast \
|
--with-dri-drivers=nouveau,swrast \
|
||||||
--with-egl-platforms=x11,drm,wayland \
|
--with-egl-platforms=x11,drm,wayland \
|
||||||
--with-sha1=libgcrypt \
|
--with-sha1=libgcrypt \
|
||||||
--enable-llvm-shared-libs \
|
|
||||||
--enable-egl \
|
|
||||||
--enable-gbm \
|
|
||||||
--enable-gallium-llvm \
|
--enable-gallium-llvm \
|
||||||
|
--enable-llvm-shared-libs \
|
||||||
--enable-shared-glapi \
|
--enable-shared-glapi \
|
||||||
|
--enable-egl \
|
||||||
--enable-glx \
|
--enable-glx \
|
||||||
--enable-glx-tls \
|
--enable-glx-tls \
|
||||||
--enable-dri \
|
|
||||||
--enable-osmesa \
|
|
||||||
--enable-gles1 \
|
--enable-gles1 \
|
||||||
--enable-gles2 \
|
--enable-gles2 \
|
||||||
|
--enable-gbm \
|
||||||
|
--enable-dri \
|
||||||
|
--enable-osmesa \
|
||||||
--enable-texture-float \
|
--enable-texture-float \
|
||||||
--enable-omx \
|
--enable-omx \
|
||||||
--enable-nine \
|
--enable-nine \
|
||||||
|
@ -100,7 +103,7 @@ package_mesa() {
|
||||||
install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
|
install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
|
||||||
# ati-dri, nouveau-dri, intel-dri, svga-dri, swrast
|
# ati-dri, nouveau-dri, intel-dri, svga-dri, swrast
|
||||||
cp -av ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/* ${pkgdir}/usr/lib/xorg/modules/dri
|
cp -av ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/* ${pkgdir}/usr/lib/xorg/modules/dri
|
||||||
|
|
||||||
cp -rv ${srcdir}/fakeinstall/usr/lib/bellagio ${pkgdir}/usr/lib
|
cp -rv ${srcdir}/fakeinstall/usr/lib/bellagio ${pkgdir}/usr/lib
|
||||||
cp -rv ${srcdir}/fakeinstall/usr/lib/d3d ${pkgdir}/usr/lib
|
cp -rv ${srcdir}/fakeinstall/usr/lib/d3d ${pkgdir}/usr/lib
|
||||||
cp -rv ${srcdir}/fakeinstall/usr/lib/lib{gbm,glapi}.so* ${pkgdir}/usr/lib/
|
cp -rv ${srcdir}/fakeinstall/usr/lib/lib{gbm,glapi}.so* ${pkgdir}/usr/lib/
|
||||||
|
@ -111,6 +114,9 @@ package_mesa() {
|
||||||
cp -rv ${srcdir}/fakeinstall/usr/lib/pkgconfig ${pkgdir}/usr/lib/
|
cp -rv ${srcdir}/fakeinstall/usr/lib/pkgconfig ${pkgdir}/usr/lib/
|
||||||
rm ${pkgdir}/usr/lib/pkgconfig/{egl,gl,glesv1_cm,glesv2}.pc
|
rm ${pkgdir}/usr/lib/pkgconfig/{egl,gl,glesv1_cm,glesv2}.pc
|
||||||
|
|
||||||
|
# remove vulkan headers
|
||||||
|
rm -rf ${pkgdir}/usr/include/vulkan
|
||||||
|
|
||||||
install -m755 -d ${pkgdir}/usr/lib/mesa
|
install -m755 -d ${pkgdir}/usr/lib/mesa
|
||||||
# move libgl/EGL/glesv*.so to not conflict with blobs - may break .pc files ?
|
# move libgl/EGL/glesv*.so to not conflict with blobs - may break .pc files ?
|
||||||
cp -rv ${srcdir}/fakeinstall/usr/lib/libGL.so* ${pkgdir}/usr/lib/mesa/
|
cp -rv ${srcdir}/fakeinstall/usr/lib/libGL.so* ${pkgdir}/usr/lib/mesa/
|
||||||
|
|
14
extra/mesa/remove-libpthread-stubs.patch
Normal file
14
extra/mesa/remove-libpthread-stubs.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
diff -ur mesa-orig/configure.ac mesa-origb/configure.ac
|
||||||
|
--- mesa-orig/configure.ac 2016-05-25 15:37:44.191643017 +0200
|
||||||
|
+++ mesa-origb/configure.ac 2016-05-25 15:42:20.861654709 +0200
|
||||||
|
@@ -813,10 +813,6 @@
|
||||||
|
dnl pkgconfig files.
|
||||||
|
test -z "$PTHREAD_LIBS" && PTHREAD_LIBS="-lpthread"
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(PTHREADSTUBS, pthread-stubs)
|
||||||
|
-AC_SUBST(PTHREADSTUBS_CFLAGS)
|
||||||
|
-AC_SUBST(PTHREADSTUBS_LIBS)
|
||||||
|
-
|
||||||
|
dnl SELinux awareness.
|
||||||
|
AC_ARG_ENABLE([selinux],
|
||||||
|
[AS_HELP_STRING([--enable-selinux],
|
Loading…
Reference in a new issue