mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added extra/speexdsp
This commit is contained in:
parent
35c3d3a527
commit
1c1b3b5000
2 changed files with 77 additions and 0 deletions
41
extra/speexdsp/PKGBUILD
Normal file
41
extra/speexdsp/PKGBUILD
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - configure with --disable-neon
|
||||
|
||||
pkgname=speexdsp
|
||||
pkgver=1.2rc3
|
||||
pkgrel=2.1
|
||||
pkgdesc="DSP library derived from Speex"
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.speex.org/"
|
||||
license=(BSD)
|
||||
depends=(glibc)
|
||||
source=(http://downloads.us.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz
|
||||
speexdsp-fixbuilds-774c87d.patch)
|
||||
sha256sums=('4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1'
|
||||
'76cd6b1187f415d966c8d62003cd87cfb66e4030b250a316aab8f0fbc2de226a')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -Np1 -i ../speexdsp-fixbuilds-774c87d.patch
|
||||
autoreconf -vi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static --disable-neon
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
make -k check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
36
extra/speexdsp/speexdsp-fixbuilds-774c87d.patch
Normal file
36
extra/speexdsp/speexdsp-fixbuilds-774c87d.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index 2cd2d1e..1de0c23 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
|
||||
AC_SUBST([SIZE32])
|
||||
AC_SUBST([USIZE32])
|
||||
|
||||
+AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
|
||||
+ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
|
||||
+ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
|
||||
+
|
||||
+AC_SUBST([INCLUDE_STDINT])
|
||||
+
|
||||
AC_CONFIG_FILES([
|
||||
Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
|
||||
include/Makefile include/speex/Makefile speexdsp.pc
|
||||
diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
|
||||
index 02b82fd..5ea7b55 100644
|
||||
--- a/include/speex/speexdsp_config_types.h.in
|
||||
+++ b/include/speex/speexdsp_config_types.h.in
|
||||
@@ -1,13 +1,7 @@
|
||||
#ifndef __SPEEX_TYPES_H__
|
||||
#define __SPEEX_TYPES_H__
|
||||
|
||||
-#if defined HAVE_STDINT_H
|
||||
-# include <stdint.h>
|
||||
-#elif defined HAVE_INTTYPES_H
|
||||
-# include <inttypes.h>
|
||||
-#elif defined HAVE_SYS_TYPES_H
|
||||
-# include <sys/types.h>
|
||||
-#endif
|
||||
+@INCLUDE_STDINT@
|
||||
|
||||
typedef @SIZE16@ spx_int16_t;
|
||||
typedef @USIZE16@ spx_uint16_t;
|
Loading…
Reference in a new issue