extra/chromium to 107.0.5304.87-1

This commit is contained in:
Kevin Mihelich 2022-10-28 12:38:22 +00:00
parent a2449099fd
commit 1c1c64178c
3 changed files with 46 additions and 17 deletions

View file

@ -15,7 +15,7 @@
highmem=1
pkgname=chromium
pkgver=107.0.5304.68
pkgver=107.0.5304.87
pkgrel=1
_launcher_ver=8
_gcc_patchset=1
@ -37,24 +37,24 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
REVERT-enable-GlobalMediaControlsCastStartStop.patch
REVERT-roll-src-third_party-ffmpeg-m102.patch
REVERT-roll-src-third_party-ffmpeg-m106.patch
chromium-system-zlib.patch
angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch
0004-Fix-missing-cmath-header-build-failure-in-renderer-e.patch)
sha256sums=('aac4f19b2e12e3ec3fd8179de26b306a4e209ec2a39b24e9e04fcce057cdb84c'
sha256sums=('6c0e00c186e22a1be29177ea410ba40ff0bf65f3ded67a345eb5b17f76c93c59'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'2b26c16f8326803ef287fb443a17bc139a440673955c5a6a38e9368bcaeed7c4'
'b908f37c5a886e855953f69e4dd6b90baa35e79f5c74673f7425f2cdb642eb00'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
'4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152'
'59b5eb171ea5e7b8c65ee405fd2cba08215f25b42d1cc2c5f685b9150e4e2bae'
'cd0d9d2a1d6a522d47c3c0891dabe4ad72eabbebc0fe5642b9e22efa3d5ee572'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'85eeb28b1a7b1ecf5ceda9c71ae1b071e916729a6b57af5c09d69c9f5b6e60eb'
@ -138,9 +138,7 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
# Fix build with unbundled zlip (patch from Gentoo)
patch -Np1 -i ../chromium-system-zlib.patch
patch -Np1 -i ../re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342

View file

@ -1,10 +0,0 @@
--- a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
+++ b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
@@ -19,7 +19,6 @@ limitations under the License.
#include <cstdio>
#include "absl/strings/string_view.h" // from @com_google_absl
-#include "contrib/minizip/ioapi.h"
namespace tflite {
namespace metadata {

View file

@ -0,0 +1,41 @@
From dda01a706453ded8c01c41775707cb5ef4e316f8 Mon Sep 17 00:00:00 2001
From: Andres Salomon <dilinger@queued.net>
Date: Tue, 25 Oct 2022 21:11:46 +0000
Subject: [PATCH] Re-fix TFLite build error on linux when using the system zlib
In commit ae0f9adb7e14c0d19ca695ef6ad40b321a8cb64c, I fixed some build
errors related to minizip patch inclusion in TFLite. However, after that
when TFLite Support was rolled to HEAD, a small part of that patch got
dropped. The result is the following build error with 107.0.5304.62:
../../third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc:22:10: fatal error: 'contrib/minizip/ioapi.h' file not found
^~~~~~~~~~~~~~~~~~~~~~~~~
1 error generated.
This commit re-adds the lost fix.
R=junzou@chromium.org
Change-Id: Ie96c3571894b5100a1e2a2771da29699eff0beb3
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3972087
Reviewed-by: Robert Ogden <robertogden@chromium.org>
Commit-Queue: Robert Ogden <robertogden@chromium.org>
Auto-Submit: Andres Salomon <dilinger@queued.net>
Cr-Commit-Position: refs/heads/main@{#1063478}
---
.../metadata/cc/utils/zip_readonly_mem_file.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
index 392b6b411fe..525ae4a2b45 100644
--- a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
+++ b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
@@ -19,7 +19,7 @@ limitations under the License.
#include <cstdio>
#include "absl/strings/string_view.h" // from @com_google_absl
-#include "contrib/minizip/ioapi.h"
+#include "third_party/zlib/contrib/minizip/ioapi.h"
namespace tflite {
namespace metadata {