mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-armv5: add patches
This commit is contained in:
parent
8a51b6f109
commit
1c27a373f3
4 changed files with 271 additions and 0 deletions
|
@ -0,0 +1,83 @@
|
|||
From 8ffdb635b9440b1cc33e2b916709aa4bdb3bdad5 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Tue, 1 Apr 2014 16:55:30 -0500
|
||||
Subject: [PATCH 1/4] Revert "mmc: mxs: use mmc_of_parse to parse devicetree
|
||||
properties"
|
||||
|
||||
This reverts commit d1a1dfb2f5dad3fbcea71b95791d525f4775cff5.
|
||||
---
|
||||
drivers/mmc/host/mxs-mmc.c | 37 ++++++++++++++++++++++++++-----------
|
||||
1 file changed, 26 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
||||
index 073e871..13016e2 100644
|
||||
--- a/drivers/mmc/host/mxs-mmc.c
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c
|
||||
@@ -76,11 +76,7 @@ static int mxs_mmc_get_cd(struct mmc_host *mmc)
|
||||
{
|
||||
struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
struct mxs_ssp *ssp = &host->ssp;
|
||||
- int present, ret;
|
||||
-
|
||||
- ret = mmc_gpio_get_cd(mmc);
|
||||
- if (ret >= 0)
|
||||
- return ret;
|
||||
+ int present;
|
||||
|
||||
present = !(readl(ssp->base + HW_SSP_STATUS(ssp)) &
|
||||
BM_SSP_STATUS_CARD_DETECT);
|
||||
@@ -568,12 +564,15 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
{
|
||||
const struct of_device_id *of_id =
|
||||
of_match_device(mxs_mmc_dt_ids, &pdev->dev);
|
||||
+ struct device_node *np = pdev->dev.of_node;
|
||||
struct mxs_mmc_host *host;
|
||||
struct mmc_host *mmc;
|
||||
struct resource *iores;
|
||||
- int ret = 0, irq_err;
|
||||
+ int ret = 0, irq_err, gpio;
|
||||
struct regulator *reg_vmmc;
|
||||
+ enum of_gpio_flags flags;
|
||||
struct mxs_ssp *ssp;
|
||||
+ u32 bus_width = 0;
|
||||
|
||||
iores = platform_get_resource(pdev, IORESOURCE_MEM, 0);
|
||||
irq_err = platform_get_irq(pdev, 0);
|
||||
@@ -634,13 +633,29 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
mmc->caps = MMC_CAP_SD_HIGHSPEED | MMC_CAP_MMC_HIGHSPEED |
|
||||
MMC_CAP_SDIO_IRQ | MMC_CAP_NEEDS_POLL;
|
||||
|
||||
- mmc->f_min = 400000;
|
||||
- mmc->f_max = 288000000;
|
||||
+ of_property_read_u32(np, "bus-width", &bus_width);
|
||||
+ if (bus_width == 4)
|
||||
+ mmc->caps |= MMC_CAP_4_BIT_DATA;
|
||||
+ else if (bus_width == 8)
|
||||
+ mmc->caps |= MMC_CAP_4_BIT_DATA | MMC_CAP_8_BIT_DATA;
|
||||
+ if (of_property_read_bool(np, "broken-cd"))
|
||||
+ mmc->caps |= MMC_CAP_NEEDS_POLL;
|
||||
+ if (of_property_read_bool(np, "non-removable"))
|
||||
+ mmc->caps |= MMC_CAP_NONREMOVABLE;
|
||||
+ gpio = of_get_named_gpio_flags(np, "wp-gpios", 0, &flags);
|
||||
+ if (gpio_is_valid(gpio)) {
|
||||
+ ret = mmc_gpio_request_ro(mmc, gpio);
|
||||
+ if (ret)
|
||||
+ goto out_clk_disable;
|
||||
+ if (!(flags & OF_GPIO_ACTIVE_LOW))
|
||||
+ mmc->caps2 |= MMC_CAP2_RO_ACTIVE_HIGH;
|
||||
+ }
|
||||
|
||||
- ret = mmc_of_parse(mmc);
|
||||
- if (ret)
|
||||
- goto out_clk_disable;
|
||||
+ if (of_property_read_bool(np, "cd-inverted"))
|
||||
+ mmc->caps2 |= MMC_CAP2_CD_ACTIVE_HIGH;
|
||||
|
||||
+ mmc->f_min = 400000;
|
||||
+ mmc->f_max = 288000000;
|
||||
mmc->ocr_avail = MMC_VDD_32_33 | MMC_VDD_33_34;
|
||||
|
||||
mmc->max_segs = 52;
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -0,0 +1,89 @@
|
|||
From 3c423c1a7be6c502a07ce3dee4e7f7d49a49cd4d Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Tue, 1 Apr 2014 16:55:42 -0500
|
||||
Subject: [PATCH 2/4] Revert "mmc: mxs: use mmc_gpio_get_ro for detecting
|
||||
read-only status"
|
||||
|
||||
This reverts commit abd37cccd47fe950e893578da12e7dc0604078de.
|
||||
---
|
||||
drivers/mmc/host/mxs-mmc.c | 34 +++++++++++++++++++++++-----------
|
||||
1 file changed, 23 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
||||
index 13016e2..3dd2f4c 100644
|
||||
--- a/drivers/mmc/host/mxs-mmc.c
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c
|
||||
@@ -38,7 +38,6 @@
|
||||
#include <linux/mmc/host.h>
|
||||
#include <linux/mmc/mmc.h>
|
||||
#include <linux/mmc/sdio.h>
|
||||
-#include <linux/mmc/slot-gpio.h>
|
||||
#include <linux/gpio.h>
|
||||
#include <linux/regulator/consumer.h>
|
||||
#include <linux/module.h>
|
||||
@@ -70,8 +69,26 @@ struct mxs_mmc_host {
|
||||
unsigned char bus_width;
|
||||
spinlock_t lock;
|
||||
int sdio_irq_en;
|
||||
+ int wp_gpio;
|
||||
+ bool wp_inverted;
|
||||
};
|
||||
|
||||
+static int mxs_mmc_get_ro(struct mmc_host *mmc)
|
||||
+{
|
||||
+ struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
+ int ret;
|
||||
+
|
||||
+ if (!gpio_is_valid(host->wp_gpio))
|
||||
+ return -EINVAL;
|
||||
+
|
||||
+ ret = gpio_get_value(host->wp_gpio);
|
||||
+
|
||||
+ if (host->wp_inverted)
|
||||
+ ret = !ret;
|
||||
+
|
||||
+ return ret;
|
||||
+}
|
||||
+
|
||||
static int mxs_mmc_get_cd(struct mmc_host *mmc)
|
||||
{
|
||||
struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
@@ -534,7 +551,7 @@ static void mxs_mmc_enable_sdio_irq(struct mmc_host *mmc, int enable)
|
||||
|
||||
static const struct mmc_host_ops mxs_mmc_ops = {
|
||||
.request = mxs_mmc_request,
|
||||
- .get_ro = mmc_gpio_get_ro,
|
||||
+ .get_ro = mxs_mmc_get_ro,
|
||||
.get_cd = mxs_mmc_get_cd,
|
||||
.set_ios = mxs_mmc_set_ios,
|
||||
.enable_sdio_irq = mxs_mmc_enable_sdio_irq,
|
||||
@@ -568,7 +585,7 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
struct mxs_mmc_host *host;
|
||||
struct mmc_host *mmc;
|
||||
struct resource *iores;
|
||||
- int ret = 0, irq_err, gpio;
|
||||
+ int ret = 0, irq_err;
|
||||
struct regulator *reg_vmmc;
|
||||
enum of_gpio_flags flags;
|
||||
struct mxs_ssp *ssp;
|
||||
@@ -642,14 +659,9 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
mmc->caps |= MMC_CAP_NEEDS_POLL;
|
||||
if (of_property_read_bool(np, "non-removable"))
|
||||
mmc->caps |= MMC_CAP_NONREMOVABLE;
|
||||
- gpio = of_get_named_gpio_flags(np, "wp-gpios", 0, &flags);
|
||||
- if (gpio_is_valid(gpio)) {
|
||||
- ret = mmc_gpio_request_ro(mmc, gpio);
|
||||
- if (ret)
|
||||
- goto out_clk_disable;
|
||||
- if (!(flags & OF_GPIO_ACTIVE_LOW))
|
||||
- mmc->caps2 |= MMC_CAP2_RO_ACTIVE_HIGH;
|
||||
- }
|
||||
+ host->wp_gpio = of_get_named_gpio_flags(np, "wp-gpios", 0, &flags);
|
||||
+ if (flags & OF_GPIO_ACTIVE_LOW)
|
||||
+ host->wp_inverted = 1;
|
||||
|
||||
if (of_property_read_bool(np, "cd-inverted"))
|
||||
mmc->caps2 |= MMC_CAP2_CD_ACTIVE_HIGH;
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -0,0 +1,53 @@
|
|||
From 693ae32da4dd06e3f98bf1ff2595e1d461ad1402 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Tue, 1 Apr 2014 16:55:53 -0500
|
||||
Subject: [PATCH 3/4] Revert "mmc: mxs: use standard flag for cd inverted"
|
||||
|
||||
This reverts commit 6c3331d3ace7989688fa59f541f5e722e44ac373.
|
||||
---
|
||||
drivers/mmc/host/mxs-mmc.c | 14 ++++----------
|
||||
1 file changed, 4 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
||||
index 3dd2f4c..02210ce 100644
|
||||
--- a/drivers/mmc/host/mxs-mmc.c
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c
|
||||
@@ -71,6 +71,7 @@ struct mxs_mmc_host {
|
||||
int sdio_irq_en;
|
||||
int wp_gpio;
|
||||
bool wp_inverted;
|
||||
+ bool cd_inverted;
|
||||
};
|
||||
|
||||
static int mxs_mmc_get_ro(struct mmc_host *mmc)
|
||||
@@ -93,15 +94,9 @@ static int mxs_mmc_get_cd(struct mmc_host *mmc)
|
||||
{
|
||||
struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
struct mxs_ssp *ssp = &host->ssp;
|
||||
- int present;
|
||||
|
||||
- present = !(readl(ssp->base + HW_SSP_STATUS(ssp)) &
|
||||
- BM_SSP_STATUS_CARD_DETECT);
|
||||
-
|
||||
- if (mmc->caps2 & MMC_CAP2_CD_ACTIVE_HIGH)
|
||||
- present = !present;
|
||||
-
|
||||
- return present;
|
||||
+ return !(readl(ssp->base + HW_SSP_STATUS(ssp)) &
|
||||
+ BM_SSP_STATUS_CARD_DETECT) ^ host->cd_inverted;
|
||||
}
|
||||
|
||||
static int mxs_mmc_reset(struct mxs_mmc_host *host)
|
||||
@@ -663,8 +658,7 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
if (flags & OF_GPIO_ACTIVE_LOW)
|
||||
host->wp_inverted = 1;
|
||||
|
||||
- if (of_property_read_bool(np, "cd-inverted"))
|
||||
- mmc->caps2 |= MMC_CAP2_CD_ACTIVE_HIGH;
|
||||
+ host->cd_inverted = of_property_read_bool(np, "cd-inverted");
|
||||
|
||||
mmc->f_min = 400000;
|
||||
mmc->f_max = 288000000;
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -0,0 +1,46 @@
|
|||
From 0e57cce7c9572286f421b8cbea899d5a917fdea8 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Nelson <robertcnelson@gmail.com>
|
||||
Date: Tue, 1 Apr 2014 16:56:05 -0500
|
||||
Subject: [PATCH 4/4] Revert "mmc: mxs: use standard flag for broken card
|
||||
detection"
|
||||
|
||||
This reverts commit a91fe279ae750d67d65039bb4ac2cc6ef51e7a2a.
|
||||
---
|
||||
drivers/mmc/host/mxs-mmc.c | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
||||
index 02210ce..374fca7 100644
|
||||
--- a/drivers/mmc/host/mxs-mmc.c
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c
|
||||
@@ -72,6 +72,7 @@ struct mxs_mmc_host {
|
||||
int wp_gpio;
|
||||
bool wp_inverted;
|
||||
bool cd_inverted;
|
||||
+ bool broken_cd;
|
||||
};
|
||||
|
||||
static int mxs_mmc_get_ro(struct mmc_host *mmc)
|
||||
@@ -95,7 +96,8 @@ static int mxs_mmc_get_cd(struct mmc_host *mmc)
|
||||
struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
struct mxs_ssp *ssp = &host->ssp;
|
||||
|
||||
- return !(readl(ssp->base + HW_SSP_STATUS(ssp)) &
|
||||
+ return host->broken_cd ||
|
||||
+ !(readl(ssp->base + HW_SSP_STATUS(ssp)) &
|
||||
BM_SSP_STATUS_CARD_DETECT) ^ host->cd_inverted;
|
||||
}
|
||||
|
||||
@@ -650,8 +652,7 @@ static int mxs_mmc_probe(struct platform_device *pdev)
|
||||
mmc->caps |= MMC_CAP_4_BIT_DATA;
|
||||
else if (bus_width == 8)
|
||||
mmc->caps |= MMC_CAP_4_BIT_DATA | MMC_CAP_8_BIT_DATA;
|
||||
- if (of_property_read_bool(np, "broken-cd"))
|
||||
- mmc->caps |= MMC_CAP_NEEDS_POLL;
|
||||
+ host->broken_cd = of_property_read_bool(np, "broken-cd");
|
||||
if (of_property_read_bool(np, "non-removable"))
|
||||
mmc->caps |= MMC_CAP_NONREMOVABLE;
|
||||
host->wp_gpio = of_get_named_gpio_flags(np, "wp-gpios", 0, &flags);
|
||||
--
|
||||
1.9.1
|
||||
|
Loading…
Reference in a new issue