mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/p7zip to 16.02-6
This commit is contained in:
parent
3651ea08c2
commit
1c49536279
2 changed files with 32 additions and 2 deletions
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
# Contributor: Gaetan Bisson <bisson@archlinux.org>
|
||||
# Contributor: Thayer Williams <thayer@archlinux.org>
|
||||
|
@ -11,7 +10,7 @@
|
|||
|
||||
pkgname=p7zip
|
||||
pkgver=16.02
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
pkgdesc="Command-line file archiver with high compression ratio"
|
||||
arch=('x86_64')
|
||||
url="http://p7zip.sourceforge.net/"
|
||||
|
@ -21,11 +20,13 @@ makedepends_i686=('nasm')
|
|||
makedepends_x86_64=('yasm')
|
||||
install=$pkgname.install
|
||||
source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2
|
||||
gcc10-conversion.patch
|
||||
CVE-2016-9296.patch
|
||||
CVE-2017-17969.patch
|
||||
CVE-2018-5996.patch
|
||||
CVE-2018-10115.patch)
|
||||
sha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f'
|
||||
'f90013d66d3c9865cb56fed2fb0432057a07283d5361e2ae9e98c3d3657f42a1'
|
||||
'f9bcbf21d4aa8938861a6cba992df13dec19538286e9ed747ccec6d9a4e8f983'
|
||||
'c6af5ba588b8932a5e99f3741fcf1011b7c94b533de903176c7d1d4c02a9ebef'
|
||||
'9c92b9060fb0ecc3e754e6440d7773d04bc324d0f998ebcebc263264e5a520df'
|
||||
|
@ -34,6 +35,9 @@ sha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f'
|
|||
prepare() {
|
||||
cd "$srcdir/${pkgname}_$pkgver"
|
||||
|
||||
# https://sourceforge.net/p/p7zip/bugs/226/ (patch from Fedora)
|
||||
patch -Np1 -i ../gcc10-conversion.patch
|
||||
|
||||
# https://sourceforge.net/p/p7zip/bugs/185/
|
||||
patch -Np1 -i ../CVE-2016-9296.patch
|
||||
|
||||
|
|
26
extra/p7zip/gcc10-conversion.patch
Normal file
26
extra/p7zip/gcc10-conversion.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -Nrup a/CPP/Windows/ErrorMsg.cpp b/CPP/Windows/ErrorMsg.cpp
|
||||
--- a/CPP/Windows/ErrorMsg.cpp 2015-01-18 11:20:28.000000000 -0700
|
||||
+++ b/CPP/Windows/ErrorMsg.cpp 2019-09-24 13:01:18.887289152 -0600
|
||||
@@ -14,14 +14,14 @@ UString MyFormatMessage(DWORD errorCode)
|
||||
AString msg;
|
||||
|
||||
switch(errorCode) {
|
||||
- case ERROR_NO_MORE_FILES : txt = "No more files"; break ;
|
||||
- case E_NOTIMPL : txt = "E_NOTIMPL"; break ;
|
||||
- case E_NOINTERFACE : txt = "E_NOINTERFACE"; break ;
|
||||
- case E_ABORT : txt = "E_ABORT"; break ;
|
||||
- case E_FAIL : txt = "E_FAIL"; break ;
|
||||
- case STG_E_INVALIDFUNCTION : txt = "STG_E_INVALIDFUNCTION"; break ;
|
||||
- case E_OUTOFMEMORY : txt = "E_OUTOFMEMORY"; break ;
|
||||
- case E_INVALIDARG : txt = "E_INVALIDARG"; break ;
|
||||
+ case unsigned (ERROR_NO_MORE_FILES) : txt = "No more files"; break ;
|
||||
+ case unsigned (E_NOTIMPL) : txt = "E_NOTIMPL"; break ;
|
||||
+ case unsigned (E_NOINTERFACE) : txt = "E_NOINTERFACE"; break ;
|
||||
+ case unsigned (E_ABORT) : txt = "E_ABORT"; break ;
|
||||
+ case unsigned (E_FAIL) : txt = "E_FAIL"; break ;
|
||||
+ case unsigned (STG_E_INVALIDFUNCTION) : txt = "STG_E_INVALIDFUNCTION"; break ;
|
||||
+ case unsigned (E_OUTOFMEMORY) : txt = "E_OUTOFMEMORY"; break ;
|
||||
+ case unsigned (E_INVALIDARG) : txt = "E_INVALIDARG"; break ;
|
||||
case ERROR_DIRECTORY : txt = "Error Directory"; break ;
|
||||
default:
|
||||
txt = strerror(errorCode);
|
Loading…
Reference in a new issue