mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/thunderbird fixes
This commit is contained in:
parent
5b5b98effa
commit
1c81818324
2 changed files with 202 additions and 4 deletions
|
@ -6,9 +6,10 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes for ARM
|
||||
# - patch to remove NEON/SIMD checks from configure
|
||||
# - memory saving LDFLAGS
|
||||
|
||||
buildarch=20
|
||||
noautobuild=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=24.3.0
|
||||
|
@ -25,19 +26,23 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
|
|||
mozconfig
|
||||
thunderbird.desktop
|
||||
thunderbird-install-dir.patch
|
||||
vendor.js)
|
||||
vendor.js
|
||||
no-neon.patch)
|
||||
options=(!emptydirs)
|
||||
sha256sums=('b8cc29ed8e3d1bd9d410b8c6c2c069c38ded11844121f93a6fa1b0d1d753e51d'
|
||||
'SKIP'
|
||||
'1e5fad181194155f65e4496759ff94523de8bcbc9838d257d65c303a9c409292'
|
||||
'd506b771e765e09e2e039b975e25befade8eec97e8950813a32463604955ab4e'
|
||||
'929a7ceca0e90d0635a2099b7df24033e865fb5b5b8c5824468c4561c21c377d'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed')
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'e9c75dbc86d96efec6f8bb4fea949fafe20d72bfefacc427decbd7fab801bd00')
|
||||
|
||||
prepare() {
|
||||
cd comm-esr24
|
||||
patch -Np1 -i "$srcdir/thunderbird-install-dir.patch"
|
||||
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
|
||||
cp "$srcdir/mozconfig" .mozconfig
|
||||
|
||||
# configure script misdetects the preprocessor without an optimization level
|
||||
|
@ -48,7 +53,7 @@ prepare() {
|
|||
build() {
|
||||
cd comm-esr24
|
||||
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/thunderbird"
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/thunderbird -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
export PYTHON="/usr/bin/python2"
|
||||
|
||||
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
|
||||
|
|
193
extra/thunderbird/no-neon.patch
Normal file
193
extra/thunderbird/no-neon.patch
Normal file
|
@ -0,0 +1,193 @@
|
|||
--- mozilla/configure.orig 2014-02-16 19:18:34.782768334 -0700
|
||||
+++ mozilla/configure 2014-02-16 19:18:53.287522296 -0700
|
||||
@@ -6675,91 +6675,9 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6681: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6685 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6692: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6715: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:6720: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 6724 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:6731: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=0
|
||||
- else
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
-
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
||||
|
||||
|
||||
--- mozilla/js/src/configure.orig 2014-02-16 19:15:10.325465791 -0700
|
||||
+++ mozilla/js/src/configure 2014-02-16 19:15:28.820223476 -0700
|
||||
@@ -5900,90 +5900,9 @@
|
||||
|
||||
|
||||
|
||||
-if test "$CPU_ARCH" = "arm"; then
|
||||
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5906: checking for ARM SIMD support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 5910 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm("uqadd8 r1, r1, r2");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:5917: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_SIMD ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_SIMD 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_SIMD=1
|
||||
- fi
|
||||
-
|
||||
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5940: checking ARM version support in compiler" >&5
|
||||
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9]*\).*/\1/p'`
|
||||
- echo "$ac_t"""$ARM_ARCH"" 1>&6
|
||||
-
|
||||
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
|
||||
-echo "configure:5945: checking for ARM NEON support in compiler" >&5
|
||||
- # We try to link so that this also fails when
|
||||
- # building with LTO.
|
||||
- cat > conftest.$ac_ext <<EOF
|
||||
-#line 5949 "configure"
|
||||
-#include "confdefs.h"
|
||||
-
|
||||
-int main() {
|
||||
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:5956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- result="yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- result="no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
- echo "$ac_t"""$result"" 1>&6
|
||||
- if test "$result" = "yes"; then
|
||||
- cat >> confdefs.pytmp <<\EOF
|
||||
- (''' HAVE_ARM_NEON ''', ' 1 ')
|
||||
-EOF
|
||||
-cat >> confdefs.h <<\EOF
|
||||
-#define HAVE_ARM_NEON 1
|
||||
-EOF
|
||||
-
|
||||
- HAVE_ARM_NEON=1
|
||||
-
|
||||
- if test -n "$ARM_ARCH"; then
|
||||
- if test "$ARM_ARCH" -lt 7; then
|
||||
- BUILD_ARM_NEON=0
|
||||
- else
|
||||
- BUILD_ARM_NEON=1
|
||||
- fi
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
-fi # CPU_ARCH = arm
|
||||
-
|
||||
+HAVE_ARM_NEON=0
|
||||
+BUILD_ARM_NEON=0
|
||||
+HAVE_ARM_SIMD=0
|
||||
|
||||
|
||||
|
Loading…
Reference in a new issue