mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/webkit2gtk to 2.20.3-1
This commit is contained in:
parent
9ad95f1be0
commit
1c9b64909a
3 changed files with 22 additions and 62 deletions
|
@ -1,14 +1,14 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
# Contributor: Eric Bélanger <eric@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - do not use LLINT assembly for v5/v6
|
||||
# - remove Atomics.cpp from build for v5/v6 - https://bugs.webkit.org/show_bug.cgi?id=161900
|
||||
|
||||
highmem=1
|
||||
|
||||
pkgname=webkit2gtk
|
||||
pkgver=2.20.2
|
||||
pkgver=2.20.3
|
||||
pkgrel=1
|
||||
pkgdesc="GTK+ Web content engine library"
|
||||
arch=(x86_64)
|
||||
|
@ -21,24 +21,15 @@ optdepends=('gtk2: Netscape plugin support'
|
|||
'gst-plugins-base: free media decoding'
|
||||
'gst-plugins-good: media decoding'
|
||||
'gst-libav: nonfree media decoding')
|
||||
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc}
|
||||
gtk-doc.diff
|
||||
remove_atomics.patch)
|
||||
sha256sums=('dffe93a241f03f1c73b369f4e323e4d8f12e39d33d5515948cbf454ca4b526e2'
|
||||
'SKIP'
|
||||
'4f116b4508d4501498d1e1483555bc5d4e3f5504c5a2f3ec6a21c646b874cdb4'
|
||||
'd0a1469fdaa5d6f4ff7e498d26470224916b64a6dbe28ba7ad699c19da9ee9ab')
|
||||
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc})
|
||||
sha256sums=('579b307d78fa16a73f112790178022166d7ad17d4147492ced9b9fba48f20dd8'
|
||||
'SKIP')
|
||||
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
cd webkitgtk-$pkgver
|
||||
patch -Np1 -i ../gtk-doc.diff
|
||||
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
|
||||
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../remove_atomics.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -47,8 +38,7 @@ build() {
|
|||
# do not use LLINT assembly for v5/v6
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG="-DENABLE_JIT=OFF"
|
||||
|
||||
cmake \
|
||||
-G Ninja \
|
||||
cmake ../webkitgtk-$pkgver -G Ninja \
|
||||
-DPORT=GTK \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
|
@ -57,18 +47,25 @@ build() {
|
|||
-DLIBEXEC_INSTALL_DIR=/usr/lib \
|
||||
-DLIB_INSTALL_DIR=/usr/lib \
|
||||
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
|
||||
$CONFIG ../webkitgtk-$pkgver
|
||||
ninja
|
||||
$CONFIG
|
||||
cmake --build .
|
||||
}
|
||||
|
||||
check() {
|
||||
: # cmake --build build --target tests
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" ninja -C build install
|
||||
DESTDIR="$pkgdir" cmake --build build --target install
|
||||
|
||||
cd webkitgtk-$pkgver
|
||||
find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | while IFS= read -d $'\0' -r _f
|
||||
do
|
||||
echo "### $_f ###"
|
||||
cat "$_f"
|
||||
echo
|
||||
done | install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | sort -z |
|
||||
while IFS= read -d $'\0' -r _f; do
|
||||
echo "### $_f ###"
|
||||
cat "$_f"
|
||||
echo
|
||||
done |
|
||||
install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
diff -u -r webkitgtk-2.20.2/Source/PlatformGTK.cmake webkitgtk-2.20.2-doc/Source/PlatformGTK.cmake
|
||||
--- webkitgtk-2.20.2/Source/PlatformGTK.cmake 2018-05-07 10:30:18.000000000 +0200
|
||||
+++ webkitgtk-2.20.2-doc/Source/PlatformGTK.cmake 2018-05-07 18:03:44.333500803 +0200
|
||||
@@ -15,10 +15,10 @@
|
||||
|
||||
if (ENABLE_GTKDOC)
|
||||
install(DIRECTORY ${CMAKE_BINARY_DIR}/Documentation/webkit2gtk-${WEBKITGTK_API_VERSION}/html/webkit2gtk-${WEBKITGTK_API_VERSION}
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/gtk-doc/html/webkit2gtk-${WEBKITGTK_API_VERSION}"
|
||||
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/gtk-doc/html"
|
||||
)
|
||||
install(DIRECTORY ${CMAKE_BINARY_DIR}/Documentation/webkitdomgtk-${WEBKITGTK_API_VERSION}/html/webkitdomgtk-${WEBKITGTK_API_VERSION}
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/gtk-doc/html/webkitdomgtk-${WEBKITGTK_API_VERSION}"
|
||||
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/gtk-doc/html"
|
||||
)
|
||||
endif ()
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
--- Source/WTF/wtf/CMakeLists.txt.orig 2018-02-19 02:36:10.000000000 -0700
|
||||
+++ Source/WTF/wtf/CMakeLists.txt 2018-03-24 21:42:12.759186320 -0600
|
||||
@@ -315,7 +315,6 @@
|
||||
|
||||
set(WTF_SOURCES
|
||||
Assertions.cpp
|
||||
- Atomics.cpp
|
||||
AutomaticThread.cpp
|
||||
BitVector.cpp
|
||||
CPUTime.cpp
|
||||
--- Source/JavaScriptCore/CMakeLists.txt.orig 2018-03-24 21:36:40.067891066 -0600
|
||||
+++ Source/JavaScriptCore/CMakeLists.txt 2018-03-24 21:38:06.715707122 -0600
|
||||
@@ -120,7 +120,7 @@
|
||||
# __atomic_fetch_add_8 is not available as a compiler intrinsic. It is
|
||||
# available on other platforms (including 32-bit Arm), so the link with
|
||||
# libatomic is only neede on MIPS.
|
||||
-if (WTF_CPU_MIPS)
|
||||
+if (WTF_CPU_MIPS OR WTF_CPU_ARM)
|
||||
list(APPEND JavaScriptCore_LIBRARIES
|
||||
-latomic
|
||||
)
|
Loading…
Reference in a new issue