extra/libreoffice-fresh to 24.8.2-3

This commit is contained in:
Kevin Mihelich 2024-11-12 12:54:52 +00:00
parent 85ab24095a
commit 1ca2d95cad
3 changed files with 25 additions and 4 deletions

View file

@ -1,6 +1,6 @@
pkgbase = libreoffice-fresh
pkgver = 24.8.2
pkgrel = 2
pkgrel = 3
url = https://www.libreoffice.org/
arch = x86_64
license = MPL-2.0
@ -151,6 +151,7 @@ pkgbase = libreoffice-fresh
source = soffice-template.desktop.in
source = libreoffice-fresh.sh
source = libreoffice-fresh.csh
source = poppler-24.10.patch
validpgpkeys = C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3
sha256sums = ab301baeb64114a9a1bce5dcb914ee0bf3e2ac7b8d74d32f3233f5f312bcc4cf
sha256sums = SKIP
@ -180,6 +181,7 @@ pkgbase = libreoffice-fresh
sha256sums = d0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879
sha256sums = 9fb33dbc3ffeb6af2ea7341b58242142d4eca903584c21c5f4b44ff27fbf5b5f
sha256sums = 512355b5ef646791089da8c2b35cf8b019673c0c8a58685962af3b5d9eb5d6bb
sha256sums = 6dd6736c3089907050d3b346ae08570bd5901bd85d9a2111d7a97f63ea5e27ea
pkgname = libreoffice-fresh-sdk
pkgdesc = Software Development Kit for LibreOffice Fresh

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=24.8.2.1
pkgver=24.8.2
pkgrel=2
pkgrel=3
arch=('x86_64')
license=('MPL-2.0' 'LGPL-3.0-or-later')
url="https://www.libreoffice.org/"
@ -70,7 +70,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
soffice-template.desktop.in
libreoffice-fresh.sh libreoffice-fresh.csh)
libreoffice-fresh.sh libreoffice-fresh.csh
poppler-24.10.patch)
noextract=(a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
language-subtag-registry-2021-03-05.tar.bz2
@ -119,7 +120,8 @@ sha256sums=('ab301baeb64114a9a1bce5dcb914ee0bf3e2ac7b8d74d32f3233f5f312bcc4cf'
'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
'9fb33dbc3ffeb6af2ea7341b58242142d4eca903584c21c5f4b44ff27fbf5b5f'
'512355b5ef646791089da8c2b35cf8b019673c0c8a58685962af3b5d9eb5d6bb')
'512355b5ef646791089da8c2b35cf8b019673c0c8a58685962af3b5d9eb5d6bb'
'6dd6736c3089907050d3b346ae08570bd5901bd85d9a2111d7a97f63ea5e27ea')
prepare() {
@ -142,6 +144,8 @@ prepare() {
export ARCH_FLAGS
export CFLAGS="$ARCH_FLAGS"
export CXXFLAGS="$ARCH_FLAGS"
patch -p1 -i ../poppler-24.10.patch # Fix build with Poppler 24.10 (KaoS patch)
export CPPFLAGS+=" -D_FILE_OFFSET_BITS=64"
}

View file

@ -0,0 +1,15 @@
diff -up libreoffice-24.8.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.omv~ libreoffice-24.8.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
--- libreoffice-24.8.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.omv~ 2024-10-20 19:08:49.935352230 +0200
+++ libreoffice-24.8.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2024-10-20 20:01:30.448965822 +0200
@@ -1306,9 +1306,9 @@ poppler_bool PDFOutDev::tilingPatternFil
0, nBitmapWidth * nBitmapHeight, Object(objNull)));
auto aDecode = Object(objNull);
std::unique_ptr<GfxImageColorMap> pRgbIdentityColorMap(new GfxImageColorMap(8, &aDecode,
- new GfxDeviceRGBColorSpace()));
+ std::make_unique<GfxDeviceRGBColorSpace>()));
std::unique_ptr<GfxImageColorMap> pGrayIdentityColorMap(new GfxImageColorMap(8, &aDecode,
- new GfxDeviceGrayColorSpace()));
+ std::make_unique<GfxDeviceGrayColorSpace>()));
OutputBuffer aBuf; initBuf(aBuf);
writePng_(aBuf, pRgbStr.get(), nBitmapWidth, nBitmapHeight, pRgbIdentityColorMap.get(),