Merge pull request #925 from pumphaus/qt5-cmake-fix

Raspberry Pi: Pass the library dirs along to find_library to fix cmake/qt5 builds
This commit is contained in:
Kevin Mihelich 2014-07-29 20:39:28 -06:00
commit 1ce7e5af13
2 changed files with 14 additions and 2 deletions

View file

@ -35,7 +35,7 @@ pkgname=('qt5-base'
'qt5-x11extras' 'qt5-x11extras'
'qt5-xmlpatterns') 'qt5-xmlpatterns')
pkgver=5.3.1 pkgver=5.3.1
pkgrel=1.1 pkgrel=1.2
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
url='http://qt-project.org/' url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom') license=('GPL3' 'LGPL' 'FDL' 'custom')
@ -58,7 +58,7 @@ md5sums=('f9a24a0d5645efa0715b6ff0fa13d60f'
'188da8f4c87316e730ebf1c6217bf5a0' '188da8f4c87316e730ebf1c6217bf5a0'
'322b419b16c75d4de0ee7ad0a246caa1' '322b419b16c75d4de0ee7ad0a246caa1'
'a378deccf363bd6079da459c89aff7b9' 'a378deccf363bd6079da459c89aff7b9'
'8df638e1dbf41617ffb0827978b54c8e' '762b33b1b083c0d19ccbd1ac2b9eb5c7'
'd9eb94a6cf4f178a7d77d6b8a9280ee2') 'd9eb94a6cf4f178a7d77d6b8a9280ee2')
prepare() { prepare() {

View file

@ -32,3 +32,15 @@
if compileTest qpa/egl "EGL" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then if compileTest qpa/egl "EGL" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
CFG_EGL=yes CFG_EGL=yes
if compileTest qpa/egl-x11 "EGL-X11" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then if compileTest qpa/egl-x11 "EGL-X11" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
--- qt-everywhere-opensource-src-5.3.1/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in.orig 2014-07-29 19:23:45.000000000 +0200
+++ qt-everywhere-opensource-src-5.3.1/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-07-29 19:41:12.000000000 +0200
@@ -96,8 +96,8 @@
string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
if (NOT TARGET Qt5::Gui_${_cmake_lib_name} AND NOT _Qt5Gui_${_cmake_lib_name}_LIBRARY_DONE)
find_library(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib}
+ HINTS \"${LibDir}\"
!!IF !isEmpty(CROSS_COMPILE)
- PATHS \"${LibDir}\"
!!IF !mac
NO_DEFAULT_PATH
!!ENDIF