diff --git a/alarm/kodi-rpi-git/0001-mcpu-cortex-application-to-ffmpeg.patch b/alarm/kodi-rpi-git/0001-mcpu-cortex-application-to-ffmpeg.patch
index 22e51cb43..4e1e3fde1 100644
--- a/alarm/kodi-rpi-git/0001-mcpu-cortex-application-to-ffmpeg.patch
+++ b/alarm/kodi-rpi-git/0001-mcpu-cortex-application-to-ffmpeg.patch
@@ -1,6 +1,6 @@
-From 666fd7f69f684d7dd23b1ee665b0902e29953b76 Mon Sep 17 00:00:00 2001
+From 5e0e966976fe08314b8a28eb53583563986f8c9d Mon Sep 17 00:00:00 2001
 From: graysky <graysky@archlinux.us>
-Date: Sat, 12 Dec 2020 09:29:51 -0500
+Date: Mon, 7 Mar 2022 18:05:02 -0500
 Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
 
 Get build system to patch ffmpeg source removing the -march= flag
@@ -10,17 +10,17 @@ Get build system to patch ffmpeg source removing the -march= flag
  1 file changed, 1 insertion(+)
 
 diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
-index 9ce807c..a18b21c 100644
+index ee600d0d83..5a7fd2e70f 100644
 --- a/cmake/modules/FindFFMPEG.cmake
 +++ b/cmake/modules/FindFFMPEG.cmake
-@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
-                                     ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
-                                     <SOURCE_DIR> &&
-                                     patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
-+                                    patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
-                                     echo "########################################## patched ffmpeg ##############################"
-                      )
+@@ -89,6 +89,7 @@ macro(buildFFMPEG)
+                     ${CMAKE_SOURCE_DIR}/cmake/modules/FindGnuTLS.cmake
+                     <SOURCE_DIR> &&
+                     patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
++                    patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
+                     echo "########################################## patched ffmpeg ##############################"
+                 )
  
 -- 
-2.29.2
+2.35.1
 
diff --git a/alarm/kodi-rpi-git/PKGBUILD b/alarm/kodi-rpi-git/PKGBUILD
index daae5e859..0f5c8152e 100644
--- a/alarm/kodi-rpi-git/PKGBUILD
+++ b/alarm/kodi-rpi-git/PKGBUILD
@@ -13,8 +13,8 @@ pkgname=(
   'kodi-rpi-git-eventclients' 'kodi-rpi-git-tools-texturepacker' 'kodi-rpi-git-dev'
 )
 
-_commitnumber=59805
-_commit=f4f71c213a3b6babd02f8e9c163a0980e7a2084d
+_commitnumber=59836
+_commit=343136d090c0e5bc0262f08093aaac5e33948e82
 
 # set this to anything to build with clang
 # recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
@@ -23,7 +23,7 @@ _clangbuild=
 pkgver="20.x.$_commitnumber.${_commit:0:10}"
 pkgrel=1
 arch=('armv7h' 'aarch64')
-url="https://github.com/graysky2/xbmc/tree/gs-gbm_nexus-v2"
+url="https://github.com/graysky2/xbmc/tree/gs-gbm_nexus-v3"
 license=('GPL2')
 makedepends=(
   'afpfs-ng' 'bluez-libs' 'cmake' 'curl' 'dav1d' 'doxygen' 'git' 'glew'
@@ -81,7 +81,7 @@ noextract=(
   "flatbuffers-$_flatbuffers_version.tar.gz"
   "libudfread-$_libudfread_version.tar.gz"
 )
-sha256sums=('13e8a19b7ca679b52705e29f426406dd7442e5b93d1ff68d7e8bb91f759c8dd3'
+sha256sums=('029f25dc0f6b230239653a218fca7e12cdbbdd017af4698abe45aaeb0d1e5116'
             '38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
             '071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
             'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
@@ -95,7 +95,7 @@ sha256sums=('13e8a19b7ca679b52705e29f426406dd7442e5b93d1ff68d7e8bb91f759c8dd3'
             'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
             '23f105f914f3372afa432251b69c7601e50c22d1a88168185105ee859005f5cd'
             '16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
-            '76eafede11af936bb554932b2be71ce91d4bf1c07107d847500ebbf3ff7d7245')
+            'c187f597020bad875d893bfe4cf094ee31de824bdc4af9b6ce9d7700487a3c8c')
 
 prepare() {
   [[ -d kodi-build ]] && rm -rf kodi-build
@@ -128,9 +128,9 @@ build() {
     export CFLAGS+=" -mcpu=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard"
     export CXXFLAGS="${CFLAGS}"
   elif [[ $CARCH = "aarch64" ]]; then
-    # note that linux-raspberrypi4 for aarch64 will currently NOT boot on RPi3 so we can use
-    # a value of cortex-a72 here although the ffmpeg patch is using cortex-a53
-    export CFLAGS+=" -mcpu=cortex-a72+crc"
+    # note that we use a value of cortex-a53 here to allow RPi3 and RPi4 to use the same package
+    # consistent with rationale of previous comment
+    export CFLAGS+=" -mcpu=cortex-a53"
     export CXXFLAGS="${CFLAGS}"
   fi
 
@@ -218,6 +218,7 @@ package_kodi-rpi-git() {
   install -Dm0644 "$srcdir/kodi.config.txt" "$pkgdir/boot/kodi.config.txt"
 
   # rpi4 wants 512 MB of memory
+  # this might be a problem for RPi3 ???
   sed -i 's/@@@/512/' "$pkgdir/boot/kodi.config.txt"
 
   _initshit="$srcdir/kodi-standalone-service-$_init_version/arm"