community/linux-tools to 4.8-1

This commit is contained in:
Kevin Mihelich 2016-10-09 15:15:45 +00:00
parent f44a868d49
commit 1d1940aee3
3 changed files with 16 additions and 52 deletions

View file

@ -1,21 +0,0 @@
# Seblu was here
--- a/tools/perf/config/Makefile 2014-02-13 23:00:14.000000000 +0100
+++ b/tools/perf/config/Makefile 2014-02-17 20:01:33.370539725 +0100
@@ -561,7 +561,7 @@
bindir = $(prefix)/$(bindir_relative)
mandir = share/man
infodir = share/info
-perfexecdir = libexec/perf-core
+perfexecdir = lib/perf
sharedir = $(prefix)/share
template_dir = share/perf-core/templates
htmldir = share/doc/perf-doc
@@ -573,7 +573,7 @@
ETC_PERFCONFIG = etc/perfconfig
endif
ifeq ($(ARCH)$(IS_64_BIT), x861)
-lib = lib64
+lib = lib
else
lib = lib
endif

View file

@ -1,13 +0,0 @@
# Copyright 2014 Sébastien Luttringer
--- a/tools/usb/usbip/libsrc/usbip_common.h 2014-10-06 02:13:09.295856364 +0200
+++ b/tools/usb/usbip/libsrc/usbip_common.h 2014-10-06 02:13:03.607873728 +0200
@@ -15,7 +15,7 @@
#include <syslog.h>
#include <unistd.h>
#include <linux/usb/ch9.h>
-#include <linux/usbip.h>
+#include "../../../include/uapi/linux/usbip.h"
#ifndef USBIDS_FILE
#define USBIDS_FILE "/usr/share/hwdata/usb.ids"

View file

@ -16,8 +16,8 @@ pkgname=(
'tmon'
'usbip'
)
pkgver=4.7
pkgrel=3
pkgver=4.8
pkgrel=1
license=('GPL2')
arch=('i686' 'x86_64')
url='http://www.kernel.org'
@ -36,28 +36,23 @@ makedepends+=('glib2' 'sysfsutils' 'udev')
makedepends+=('ncurses')
groups=("$pkgbase")
source=("https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz"
'https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.7.5.xz'
#'https://cdn.kernel.org/pub/linux/kernel/v4.x/patch-4.7.5.xz'
'cpupower.default'
'cpupower.systemd'
'cpupower.service'
'usbipd.service'
'01-cpupower-governor-fix.patch'
'02-archlinux-paths.patch'
'04-fix-usip-h-path.patch')
md5sums=('SKIP'
'c5f3473be15411f7b02f36b7f52cc9d1'
'01-cpupower-governor-fix.patch')
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
'56883c159381ba89e50ab8ea65efec77'
'34f5ecc19770a1abbcd0fd65bfd1f065'
'86c4e419e4ba80835c330d49ba3f56ad'
'bb35634f480325a78b943f7e10165e86'
'33c871519adfd4e5575643c4579d019b'
'1bc4f8c7a21a30e1a873d07e69fb698b'
'a73ea3ea6d9c9ecb1cc910871eead3ff')
'33c871519adfd4e5575643c4579d019b')
prepare() {
cd linux-$pkgver
# apply stable kernel patch
patch -p1 -N -i "$srcdir"/patch-4.7.5
#patch -p1 -N -i "$srcdir"/patch-4.7.5
# apply patch from the source array (should be a pacman feature)
local filename
for filename in "${source[@]}"; do
@ -76,10 +71,11 @@ build() {
msg2 'perf'
pushd linux-$pkgver/tools/perf
make \
make -f Makefile.perf \
prefix=/usr \
DESTDIR="$pkgdir" \
WERROR=0 \
lib=lib/perf \
perfexecdir=lib/perf \
NO_SDT=1 \
PYTHON=python2 \
PYTHON_CONFIG=python2-config \
PERF_VERSION=$pkgver-$pkgrel \
@ -143,13 +139,15 @@ package_perf() {
optdepends=('gtk2: support GTK2 browser for perf report')
cd linux-$pkgver/tools/perf
make \
make -f Makefile.perf \
prefix=/usr \
DESTDIR="$pkgdir" \
WERROR=0 \
lib=lib/perf \
perfexecdir=lib/perf \
NO_SDT=1 \
PYTHON=python2 \
PYTHON_CONFIG=python2-config \
PERF_VERSION=$pkgver-$pkgrel \
DESTDIR="$pkgdir" \
install install-man
cd "$pkgdir"
# move completion in new directory