extra/chromium to 107.0.5304.68-1

This commit is contained in:
Kevin Mihelich 2022-10-26 01:57:21 +00:00
parent fc9d2664ce
commit 1d19a436a3
2 changed files with 26 additions and 8 deletions

View file

@ -15,17 +15,17 @@
highmem=1
pkgname=chromium
pkgver=106.0.5249.119
pkgrel=2
pkgver=107.0.5304.68
pkgrel=1
_launcher_ver=8
_gcc_patchset=2
_gcc_patchset=1
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
url="https://www.chromium.org/Home"
license=('BSD')
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
'wayland' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
@ -40,19 +40,21 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
REVERT-enable-GlobalMediaControlsCastStartStop.patch
REVERT-roll-src-third_party-ffmpeg-m102.patch
REVERT-roll-src-third_party-ffmpeg-m106.patch
chromium-system-zlib.patch
angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch
0004-Fix-missing-cmath-header-build-failure-in-renderer-e.patch)
sha256sums=('0f091b4950e120d5c3e23ab391bacfdb6ce8eb8d0acab55e9dae1a8c247dd192'
sha256sums=('aac4f19b2e12e3ec3fd8179de26b306a4e209ec2a39b24e9e04fcce057cdb84c'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'2ad419439379d17385b7fd99039aca875ba36ca31b591b9cd4ccef84273be121'
'2b26c16f8326803ef287fb443a17bc139a440673955c5a6a38e9368bcaeed7c4'
'b908f37c5a886e855953f69e4dd6b90baa35e79f5c74673f7425f2cdb642eb00'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
'4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152'
'59b5eb171ea5e7b8c65ee405fd2cba08215f25b42d1cc2c5f685b9150e4e2bae'
'cd0d9d2a1d6a522d47c3c0891dabe4ad72eabbebc0fe5642b9e22efa3d5ee572'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'85eeb28b1a7b1ecf5ceda9c71ae1b071e916729a6b57af5c09d69c9f5b6e60eb'
@ -137,6 +139,9 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../unbundle-jsoncpp-avoid-CFI-faults-with-is_cfi-true.patch
# Fix build with unbundled zlip (patch from Gentoo)
patch -Np1 -i ../chromium-system-zlib.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
patch -Rp1 -F3 -i ../REVERT-enable-GlobalMediaControlsCastStartStop.patch
@ -152,7 +157,6 @@ prepare() {
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-103-VirtualCursor-std-layout.patch
patch -Np1 -i ../patches/chromium-106-AutofillPopupControllerImpl-namespace.patch
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
@ -194,6 +198,7 @@ build() {
local _flags=(
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'clang_base_path="/usr"'
'clang_use_chrome_plugins=false'
'clang_use_default_sample_profile=false'
'use_allocator="none"'
@ -208,10 +213,13 @@ build() {
'proprietary_codecs=true'
'rtc_use_pipewire=true'
'link_pulseaudio=true'
'use_custom_libcxx=false'
'use_gnome_keyring=false'
'use_qt=false' # look into enabling this for M108
'use_gold=false'
'use_sysroot=false'
'use_custom_libcxx=false'
'use_system_libwayland_server=true'
'use_system_wayland_scanner=true'
'enable_hangout_services_extension=true'
'enable_widevine=true'
'enable_nacl=false'

View file

@ -0,0 +1,10 @@
--- a/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
+++ b/third_party/tflite_support/src/tensorflow_lite_support/metadata/cc/utils/zip_readonly_mem_file.cc
@@ -19,7 +19,6 @@ limitations under the License.
#include <cstdio>
#include "absl/strings/string_view.h" // from @com_google_absl
-#include "contrib/minizip/ioapi.h"
namespace tflite {
namespace metadata {