extra/texlive-bin to 2019.51075-7

This commit is contained in:
Kevin Mihelich 2020-03-07 16:15:17 +00:00
parent 12f3232c79
commit 1d72057324
2 changed files with 16 additions and 3 deletions

View file

@ -9,7 +9,7 @@
pkgname=('texlive-bin' 'libsynctex')
pkgver=2019.51075
pkgrel=6
pkgrel=7
license=('GPL')
arch=('x86_64')
makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
@ -19,11 +19,12 @@ makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
url='https://tug.org/texlive/'
_commit=74c2495978a4a84ffae10252c0fd244f1140228e # texlive-2019.2 r51075
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}"
"pdftex-poppler0.76.patch" texlive-poppler-0.83.patch texlive-poppler-0.84.patch)
"pdftex-poppler0.76.patch" texlive-poppler-0.83.patch texlive-poppler-0.84.patch texlive-poppler-0.86.patch)
sha256sums=('SKIP'
'5da9f5356ca14d950c222108b431baaf5c27667460ffab9597b29ef11b426c0f'
'ae68858b3ed60f6ef49cf29f31f601d0660908551484afe86283bc6054e9d9f8'
'4a4ff82c85cecafc5bbf544e568d80022e9456c3223648fa8d64e699526646c5')
'4a4ff82c85cecafc5bbf544e568d80022e9456c3223648fa8d64e699526646c5'
'3438c1a3b7e1422ca964819b5cdf9ece086881c6448d0e2e3cfffdc1b082bb5d')
prepare() {
cd "$srcdir/texlive-source"
@ -38,6 +39,7 @@ prepare() {
patch -p1 -i ../texlive-poppler-0.83.patch
patch -p1 -i ../texlive-poppler-0.84.patch # Gentoo patch
patch -p1 -i ../texlive-poppler-0.86.patch
}
build() {

View file

@ -0,0 +1,11 @@
--- a/texk/web2c/pdftexdir/pdftoepdf.cc 2020-03-03 21:11:35.102711802 +0000
+++ b/texk/web2c/pdftexdir/pdftoepdf.cc 2020-03-03 21:13:13.057420111 +0000
@@ -757,7 +757,7 @@
if (page_name) {
// get page by name
GString name(page_name);
- LinkDest *link = pdf_doc->doc->findDest(&name);
+ LinkDest *link = pdf_doc->doc->findDest(&name).get();
if (link == 0 || !link->isOk())
pdftex_fail("PDF inclusion: invalid destination <%s>", page_name);
Ref ref = link->getPageRef();