mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-espressobin to 5.10.16-1
This commit is contained in:
parent
8abea22502
commit
1d85079406
2 changed files with 2 additions and 58 deletions
|
@ -1,51 +0,0 @@
|
|||
From 7dc7170b1314236f54ccef07b1a0f356ad594d04 Mon Sep 17 00:00:00 2001
|
||||
From: Chuck Lever <chuck.lever@oracle.com>
|
||||
Date: Sun, 31 Jan 2021 16:16:23 -0500
|
||||
Subject: [PATCH] SUNRPC: Fix NFS READs that start at non-page-aligned offsets
|
||||
|
||||
Anj Duvnjak reports that the Kodi.tv NFS client is not able to read
|
||||
video files from a v5.10.11 Linux NFS server.
|
||||
|
||||
The new sendpage-based TCP sendto logic was not attentive to non-
|
||||
zero page_base values. nfsd_splice_read() sets that field when a
|
||||
READ payload starts in the middle of a page.
|
||||
|
||||
The Linux NFS client rarely emits an NFS READ that is not page-
|
||||
aligned. All of my testing so far has been with Linux clients, so I
|
||||
missed this one.
|
||||
|
||||
Reported-by: A. Duvnjak <avian@extremenerds.net>
|
||||
BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=211471
|
||||
Fixes: 4a85a6a3320b ("SUNRPC: Handle TCP socket sends with kernel_sendpage() again")
|
||||
Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
|
||||
Tested-by: A. Duvnjak <avian@extremenerds.net>
|
||||
---
|
||||
net/sunrpc/svcsock.c | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
|
||||
index 4404c491eb38..fa7b7ae2c2c5 100644
|
||||
--- a/net/sunrpc/svcsock.c
|
||||
+++ b/net/sunrpc/svcsock.c
|
||||
@@ -1113,14 +1113,15 @@ static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
|
||||
unsigned int offset, len, remaining;
|
||||
struct bio_vec *bvec;
|
||||
|
||||
- bvec = xdr->bvec;
|
||||
- offset = xdr->page_base;
|
||||
+ bvec = xdr->bvec + (xdr->page_base >> PAGE_SHIFT);
|
||||
+ offset = offset_in_page(xdr->page_base);
|
||||
remaining = xdr->page_len;
|
||||
flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
|
||||
while (remaining > 0) {
|
||||
if (remaining <= PAGE_SIZE && tail->iov_len == 0)
|
||||
flags = 0;
|
||||
- len = min(remaining, bvec->bv_len);
|
||||
+
|
||||
+ len = min(remaining, bvec->bv_len - offset);
|
||||
ret = kernel_sendpage(sock, bvec->bv_page,
|
||||
bvec->bv_offset + offset,
|
||||
len, flags);
|
||||
--
|
||||
2.30.0
|
||||
|
|
@ -7,7 +7,7 @@ pkgbase=linux-espressobin
|
|||
_srcname=linux-5.10
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Globalscale ESPRESSOBin"
|
||||
pkgver=5.10.14
|
||||
pkgver=5.10.16
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -16,15 +16,13 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
|||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
|
||||
'0001-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'60-linux.hook'
|
||||
'90-linux.hook'
|
||||
'91-linux.hook')
|
||||
md5sums=('753adc474bf799d569dec4f165ed92c3'
|
||||
'd928049c6149ed507afbb72c90cb2dc2'
|
||||
'ed5be3aaf3c6e2af2a74807ee73bd7b5'
|
||||
'6eb3cfa9872f7c0cbc59e5c17eca854c'
|
||||
'91db2c2612382a535c851169c5873612'
|
||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||
'ce6c81ad1ad1f8b333fd6077d47abdaf'
|
||||
|
@ -37,9 +35,6 @@ prepare() {
|
|||
# add upstream patch
|
||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
|
|
Loading…
Reference in a new issue