added extra/gnome-builder

This commit is contained in:
Kevin Mihelich 2015-04-14 19:24:18 +00:00
parent 4c0c407931
commit 1da2593a03
3 changed files with 69 additions and 0 deletions

View file

@ -0,0 +1,42 @@
# $Id$
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix build on ARM
pkgname=gnome-builder
pkgver=3.16.1
pkgrel=1
pkgdesc="An IDE for writing GNOME-based software"
url="https://wiki.gnome.org/Apps/Builder"
arch=(i686 x86_64)
license=(GPL3)
depends=(gtksourceview3 devhelp libgit2-glib gjs python-gobject clang)
makedepends=(intltool llvm gobject-introspection)
groups=(gnome-extra)
install=gnome-builder.install
source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
arm.patch)
sha256sums=('1cb9b66f3b0a6b99a2360bab155d9fa1748e5a80590481b4bce900a378064947'
'e56bb096be7b6fae0725efa5846e2376177e12b6b0495e04c21c13d771c38b34')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../arm.patch
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
check() {
cd $pkgname-$pkgver
make -k check || :
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}

View file

@ -0,0 +1,15 @@
diff -urN a/libide/ide-highlight-index.c b/libide/ide-highlight-index.c
--- a/libide/ide-highlight-index.c 2015-04-08 00:43:25.000000000 -0600
+++ b/libide/ide-highlight-index.c 2015-04-14 13:18:59.080511371 -0600
@@ -28,6 +28,11 @@
G_DEFINE_BOXED_TYPE (IdeHighlightIndex, ide_highlight_index,
ide_highlight_index_ref, ide_highlight_index_unref)
+#ifndef PAGE_SIZE
+#include <unistd.h>
+#define PAGE_SIZE sysconf(_SC_PAGESIZE)
+#endif
+
struct _IdeHighlightIndex
{
volatile gint ref_count;

View file

@ -0,0 +1,12 @@
post_install() {
glib-compile-schemas /usr/share/glib-2.0/schemas
gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}