mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/kdelibs to 4.13.2-2
This commit is contained in:
parent
e6dcbb53ff
commit
1e101c58d8
2 changed files with 6 additions and 57 deletions
|
@ -6,8 +6,8 @@
|
|||
# - patch to fix unclickable plasmoid buttons on ARM
|
||||
|
||||
pkgname=kdelibs
|
||||
pkgver=4.13.1
|
||||
pkgrel=3
|
||||
pkgver=4.13.2
|
||||
pkgrel=2
|
||||
pkgdesc="KDE Core Libraries"
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://projects.kde.org/projects/kde/kdelibs'
|
||||
|
@ -20,14 +20,12 @@ makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'hspell' 'mesa')
|
|||
install=${pkgname}.install
|
||||
source=("http://download.kde.org/stable/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
|
||||
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch'
|
||||
'arm-coronaoffscreen-input-fixes.diff'
|
||||
'fix-cifs-mount.patch')
|
||||
'arm-coronaoffscreen-input-fixes.diff')
|
||||
sha1sums=('1008effc37f316bf6e3a4d527c4257937fc572ec'
|
||||
'86ee8c8660f19de8141ac99cd6943964d97a1ed7'
|
||||
'63a850ab4196b9d06934f2b4a13acd9f7739bc67'
|
||||
'ed1f57ee661e5c7440efcaba7e51d2554709701c'
|
||||
'855150096763600c970aa307c8241b96da33b9ed'
|
||||
'26bbebeaf3f882d84030fd9b39b7b4c9debbbeec')
|
||||
'855150096763600c970aa307c8241b96da33b9ed')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
@ -37,10 +35,10 @@ prepare() {
|
|||
patch -p1 -i "${srcdir}"/archlinux-menu.patch
|
||||
# qmake refers to Qt5
|
||||
patch -p1 -i "${srcdir}"/qt4.patch
|
||||
# fix build with giflib 5.1.0
|
||||
sed -i "/DGifCloseFile/s:file:&, NULL:g" khtml/imload/decoders/gifloader.cpp
|
||||
# fix unclickable plasmoid buttons on ARM
|
||||
patch -p1 -i "${srcdir}"/arm-coronaoffscreen-input-fixes.diff
|
||||
|
||||
patch -p1 -i "${srcdir}"/fix-cifs-mount.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
commit 9a8426ae2ed35ac900b89a623618fc158d24ee6a
|
||||
Author: Tomáš Trnka <tomastrnka@gmx.com>
|
||||
Date: Sun May 25 16:12:36 2014 +0200
|
||||
|
||||
Revert "Avoid unnecessary automounting in KDiskFreeSpaceInfo::freeSpaceInfo"
|
||||
|
||||
This reverts commit 6246e99b43f3d1a9e15d563fbb5e173ed50ba5e5.
|
||||
|
||||
It breaks KIO on CIFS mounts as the check for automounts copied over
|
||||
from frameworks/kfileitem.cpp isDirectoryMounted() apparently matches
|
||||
CIFS as well (and for some weird reason KIO checks for available space
|
||||
before trying to copy files).
|
||||
|
||||
We'll probably have to return to v1 of the abovementioned commit, i.e.
|
||||
checking for "autofs" explicitly. However, more testing is apparently
|
||||
necessary to avoid further nasty surprises.
|
||||
|
||||
REVIEW: 117044
|
||||
BUG: 334776
|
||||
FIXED-IN: 4.13.2
|
||||
|
||||
diff --git a/kio/kfile/kdiskfreespaceinfo.cpp b/kio/kfile/kdiskfreespaceinfo.cpp
|
||||
index 5c1fa72..f11eb09 100644
|
||||
--- a/kio/kfile/kdiskfreespaceinfo.cpp
|
||||
+++ b/kio/kfile/kdiskfreespaceinfo.cpp
|
||||
@@ -33,7 +33,6 @@
|
||||
#include <QtCore/QDir>
|
||||
#include <windows.h>
|
||||
#else
|
||||
-#include <QtCore/QFileInfo>
|
||||
#include <sys/statvfs.h>
|
||||
#endif
|
||||
|
||||
@@ -131,15 +130,6 @@ KDiskFreeSpaceInfo KDiskFreeSpaceInfo::freeSpaceInfo( const QString& path )
|
||||
#else
|
||||
struct statvfs statvfs_buf;
|
||||
|
||||
- // Ignore autofs mountpoints as statvfs would trigger (expensive) automounting
|
||||
- // This also matches "special" filesystems like /proc where free space has no meaning
|
||||
- if (mp) {
|
||||
- QFileInfo fi(info.d->mountPoint);
|
||||
- if (fi.isDir() && fi.size() == 0) {
|
||||
- return info;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
// Prefer mountPoint if available, so that it even works with non-existing files.
|
||||
const QString pathArg = info.d->mountPoint.isEmpty() ? path : info.d->mountPoint;
|
||||
if (!statvfs(QFile::encodeName(pathArg).constData(), &statvfs_buf)) {
|
Loading…
Reference in a new issue