mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/opensubdiv to 3.4.4-2
This commit is contained in:
parent
6cf007781f
commit
1ecaa1d434
2 changed files with 14 additions and 19 deletions
|
@ -5,7 +5,7 @@
|
|||
|
||||
pkgname=opensubdiv
|
||||
pkgver=3.4.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="An Open-Source subdivision surface library"
|
||||
arch=(x86_64)
|
||||
url="http://graphics.pixar.com/opensubdiv"
|
||||
|
@ -14,22 +14,25 @@ depends=('ptex' 'intel-tbb' 'libxcursor' 'xorg-xrandr' 'libxinerama')
|
|||
makedepends=('cmake' 'doxygen' 'glfw' 'glew' 'python' 'python-pygments' 'python-docutils' 'opencl-headers')
|
||||
source=("https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${pkgver//./_}.tar.gz"
|
||||
python3.patch
|
||||
cuda9.patch)
|
||||
cuda11.patch)
|
||||
sha512sums=('fc8f28b79347015c8991150535c1339e695d96947c72fadd4fa27b546a0813c1125cd175ee03bed5aacdb3609f74c4e526ef70103d1195ba9f7df041e73ea9fb'
|
||||
'10f1f63e07d59deb4d91ba04448bb360efff0e41202bb6737caffbce09ba244efb349fe25b24880420b80fdadb268aed84923464af0d66ee1a36e4ba8f96cfd5'
|
||||
'fe51160959f71f33e3c8008158f9f98c3c7a065b22360e7719ec1d262105b35d02c2c2f64f05acee58281c938a007a88054dcc07f1aef89908e6dbf4e3e3ab6f')
|
||||
'e67d270496b56f6337698ee7bd9f1a0c945e75cd963e5f9dd451414c92c12382525190d691de269d783cffebed0b0dae5bd8fd94e555d7bb94ae06034edc375f')
|
||||
|
||||
prepare() {
|
||||
cd "OpenSubdiv-${pkgver//./_}"
|
||||
|
||||
patch -Np1 -i "${srcdir}"/python3.patch
|
||||
patch -Np1 -i "${srcdir}"/cuda9.patch
|
||||
patch -Np1 -i "${srcdir}"/cuda11.patch
|
||||
mkdir build
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "OpenSubdiv-${pkgver//./_}"/build
|
||||
|
||||
# wtf
|
||||
mkdir -p CMakeFiles/osd_static_gpu.dir/osd
|
||||
|
||||
cmake .. \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr
|
||||
|
|
|
@ -1,25 +1,17 @@
|
|||
From 7b9157bca7138480c387ef3d5b69b6cf1eb498e5 Mon Sep 17 00:00:00 2001
|
||||
From: "Daniel M. Weeks" <dan@danweeks.net>
|
||||
Date: Fri, 15 Dec 2017 22:45:55 -0500
|
||||
Subject: [PATCH] CUDA 9 compatible gpu-architecture default
|
||||
|
||||
---
|
||||
CMakeLists.txt | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 4f3cd9d40..fa438b461 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -513,8 +513,10 @@ if(CUDA_FOUND)
|
||||
diff --color -aur OpenSubdiv-3_4_4-old/CMakeLists.txt OpenSubdiv-3_4_4-new/CMakeLists.txt
|
||||
--- OpenSubdiv-3_4_4-old/CMakeLists.txt 2021-06-14 16:59:54.699746298 +0300
|
||||
+++ OpenSubdiv-3_4_4-new/CMakeLists.txt 2021-06-14 17:01:32.976412136 +0300
|
||||
@@ -586,8 +586,12 @@
|
||||
if (NOT DEFINED OSD_CUDA_NVCC_FLAGS)
|
||||
if (CUDA_VERSION_MAJOR LESS 6)
|
||||
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_11 )
|
||||
- else()
|
||||
+ elseif (CUDA_VERSION_MAJOR LESS 9)
|
||||
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_20 )
|
||||
+ else()
|
||||
+ elseif (CUDA_VERSION_MAJOR LESS 11)
|
||||
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_35 )
|
||||
+ else()
|
||||
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_37 )
|
||||
endif()
|
||||
endif()
|
||||
endif()
|
Loading…
Reference in a new issue