add imx-bootlets-olinuxino-ntsc

This commit is contained in:
Kiril Zyapkov 2012-09-21 16:51:45 +03:00
parent 918fb79df1
commit 1ed6536895
4 changed files with 107 additions and 0 deletions

View file

@ -0,0 +1,39 @@
# Contributor: Kiril Zyapkov <kiril.zyapkov@gmail.com>
buildarch=2
pkgname=imx-bootlets-olinuxino-ntsc
pkgver=10.12.01
pkgrel=4
pkgdesc="Bootlets for the i.MX233 Freescale processor"
arch=(arm)
url="http://freescale.com"
license=('MIT')
makedepends=()
source=("http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${pkgver}.tar.gz"
"linux_prep-fix-cmdlines.patch"
"linux-fix-paths.patch"
"imx233-olinuxino-maxi.patch")
md5sums=('cf0ab3822dca694b930a051501c1d0e4'
'd764749e7d5461c19924861ad7194395'
'513eee238f4ae169afa855563f5aefbc'
'a3ecd391021d32723c34c955a3e2a0f5')
build() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
patch -Np1 -i ../linux_prep-fix-cmdlines.patch
patch -Np1 -i ../linux-fix-paths.patch
patch -Np1 -i ../imx233-olinuxino-maxi.patch
BOARD=stmp378x_dev make linux_prep boot_prep power_prep
}
package() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
mkdir -p ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 linux.bd ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 power_prep/power_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 boot_prep/boot_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 linux_prep/output-target/linux_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
}
# vim:set ts=2 sw=2 et:

View file

@ -0,0 +1,19 @@
mx23/platform: set machine ID
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/include/mx23/platform.h b/linux_prep/include/mx23/platform.h
index ed58d79..3cbe2eb 100644
--- a/linux_prep/include/mx23/platform.h
+++ b/linux_prep/include/mx23/platform.h
@@ -18,7 +18,7 @@
#define __37XX_PLATFORM_H
#if defined (BOARD_STMP378X_DEV)
-#define MACHINE_ID 0xa45
+#define MACHINE_ID 0x1009
#else
#error "Allocate a machine ID for your board"
#endif

View file

@ -0,0 +1,19 @@
diff --git a/linux.bd b/linux.bd
index c4956d0..036a609 100644
--- a/linux.bd
+++ b/linux.bd
@@ -4,10 +4,10 @@ options {
flags = 0x01;
}
sources {
- power_prep="./power_prep/power_prep";
- sdram_prep="./boot_prep/boot_prep";
- linux_prep="./linux_prep/output-target/linux_prep";
- zImage = "./zImage";
+ power_prep="imx-bootlets-olinuxino-ntsc/power_prep";
+ sdram_prep="imx-bootlets-olinuxino-ntsc/boot_prep";
+ linux_prep="imx-bootlets-olinuxino-ntsc/linux_prep";
+ zImage = "arch/arm/boot/zImage";
}
section (0) {

View file

@ -0,0 +1,30 @@
imx-bootlets: Fix cmdlines for Linux boot
This adapt the cmdlines for the partitioning layout used on the
generated SD cards.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/cmdlines/iMX28_EVK.txt b/linux_prep/cmdlines/iMX28_EVK.txt
index 6bc36b9..6cf89a0 100644
--- a/linux_prep/cmdlines/iMX28_EVK.txt
+++ b/linux_prep/cmdlines/iMX28_EVK.txt
@@ -1 +1 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
diff --git a/linux_prep/cmdlines/stmp378x_dev.txt b/linux_prep/cmdlines/stmp378x_dev.txt
index 9a717eb..fdb7390 100644
--- a/linux_prep/cmdlines/stmp378x_dev.txt
+++ b/linux_prep/cmdlines/stmp378x_dev.txt
@@ -1,6 +1,3 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms430 no_console_suspend
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms350
-console=ttyAM0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
-
-
-
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=tvenc_ntsc no_console_suspend
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms350
+console=ttyAMA0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430