community/python-jsonpatch to 1.14-2

This commit is contained in:
Kevin Mihelich 2017-01-06 13:37:28 +00:00
parent 271d16a044
commit 1ee48f4859
2 changed files with 36 additions and 3 deletions

View file

@ -10,7 +10,7 @@ pkgbase=python-jsonpatch
_pkgname=jsonpatch
pkgname=(python-jsonpatch python2-jsonpatch)
pkgver=1.14
pkgrel=1
pkgrel=2
pkgdesc="An implementation of the JSON Patch format"
arch=("any")
url="https://github.com/stefankoegl/python-json-patch"
@ -18,10 +18,14 @@ license=("BSD")
makedepends=("python-setuptools" "python2-setuptools" "python-jsonpointer" "python2-jsonpointer"
"git")
checkdepends=('python-coverage' 'python2-coverage')
source=("git+https://github.com/stefankoegl/python-json-patch.git#tag=v$pkgver")
sha512sums=('SKIP')
source=("git+https://github.com/stefankoegl/python-json-patch.git#tag=v$pkgver"
python3.6.patch)
sha512sums=('SKIP'
'e6f536bf89002cbdce63828fbc9f37690cf23fddad3b300258766b18bd735fc9ac22f6cd3f8ecf59e79206721ca31b2867ab1518efb578d86f485a2d63b07fcc')
prepare(){
(cd python-json-patch; patch -p1 -i ../python3.6.patch)
cp -a python-json-patch{,-py2}
find python-json-patch-py2 -name \*.py -exec sed -i '1s/python$/&2/' {} +
}

View file

@ -0,0 +1,29 @@
From d6e9a0047bad780b53151f572ea257f1cb6ebe41 Mon Sep 17 00:00:00 2001
From: Victor Stinner <vstinner@redhat.com>
Date: Wed, 29 Jun 2016 11:13:00 +0200
Subject: [PATCH] Use inspect.signature() on Python 3
The inspect.getargspec() function has been deprecated in Python 3:
https://docs.python.org/3/library/inspect.html#inspect.getargspec
---
jsonpatch.py | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/jsonpatch.py b/jsonpatch.py
index 32508e2..3c83f61 100644
--- a/jsonpatch.py
+++ b/jsonpatch.py
@@ -105,8 +105,11 @@ def get_loadjson():
function with object_pairs_hook set to multidict for Python versions that
support the parameter. """
- argspec = inspect.getargspec(json.load)
- if 'object_pairs_hook' not in argspec.args:
+ if sys.version_info >= (3, 3):
+ args = inspect.signature(json.load).parameters
+ else:
+ args = inspect.getargspec(json.load).args
+ if 'object_pairs_hook' not in args:
return json.load
return functools.partial(json.load, object_pairs_hook=multidict)