mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/kodi to 16.1-4
This commit is contained in:
parent
280b5e4e3f
commit
1eeed5705e
2 changed files with 3 additions and 58 deletions
|
@ -1,58 +1,3 @@
|
|||
From efa1179a7d55be713940cf82eaadb3d7379a7942 Mon Sep 17 00:00:00 2001
|
||||
From: fritsch <peter.fruehberger@gmail.com>
|
||||
Date: Sat, 23 Jul 2016 21:34:05 +0200
|
||||
Subject: [PATCH 1/2] Curl: Support libcurl version 7.5.0
|
||||
|
||||
---
|
||||
xbmc/filesystem/CurlFile.h | 6 ++++++
|
||||
xbmc/filesystem/DllLibCurl.h | 2 +-
|
||||
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xbmc/filesystem/CurlFile.h b/xbmc/filesystem/CurlFile.h
|
||||
index b4f5046..81a5ae5 100644
|
||||
--- a/xbmc/filesystem/CurlFile.h
|
||||
+++ b/xbmc/filesystem/CurlFile.h
|
||||
@@ -24,11 +24,17 @@
|
||||
#include <map>
|
||||
#include <string>
|
||||
#include "utils/HttpHeader.h"
|
||||
+#include <curl/curlver.h>
|
||||
|
||||
namespace XCURL
|
||||
{
|
||||
+#if LIBCURL_VERSION_NUM >= 0x073200
|
||||
+ typedef struct Curl_easy CURL_HANDLE;
|
||||
+ typedef struct Curl_multi CURLM;
|
||||
+#else
|
||||
typedef void CURL_HANDLE;
|
||||
typedef void CURLM;
|
||||
+#endif
|
||||
struct curl_slist;
|
||||
}
|
||||
|
||||
diff --git a/xbmc/filesystem/DllLibCurl.h b/xbmc/filesystem/DllLibCurl.h
|
||||
index db97f92..1bdaae1 100644
|
||||
--- a/xbmc/filesystem/DllLibCurl.h
|
||||
+++ b/xbmc/filesystem/DllLibCurl.h
|
||||
@@ -52,7 +52,7 @@ namespace XCURL
|
||||
virtual CURLMcode multi_fdset(CURLM *multi_handle, fd_set *read_fd_set, fd_set *write_fd_set, fd_set *exc_fd_set, int *max_fd)=0;
|
||||
virtual CURLMcode multi_timeout(CURLM *multi_handle, long *timeout)=0;
|
||||
virtual CURLMsg* multi_info_read(CURLM *multi_handle, int *msgs_in_queue)=0;
|
||||
- virtual void multi_cleanup(CURL_HANDLE * handle )=0;
|
||||
+ virtual void multi_cleanup(CURLM * handle )=0;
|
||||
virtual struct curl_slist* slist_append(struct curl_slist *, const char *)=0;
|
||||
virtual void slist_free_all(struct curl_slist *)=0;
|
||||
};
|
||||
|
||||
From 9c6dd05394c7f55c046f285b124b0caa46e66ee4 Mon Sep 17 00:00:00 2001
|
||||
From: fritsch <peter.fruehberger@gmail.com>
|
||||
Date: Sun, 24 Jul 2016 20:24:07 +0200
|
||||
Subject: [PATCH 2/2] Curl: Adjust multi_cleanup method which returns CURLMcode
|
||||
|
||||
---
|
||||
xbmc/filesystem/DllLibCurl.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/xbmc/filesystem/DllLibCurl.h b/xbmc/filesystem/DllLibCurl.h
|
||||
index 1bdaae1..9e78a91 100644
|
||||
--- a/xbmc/filesystem/DllLibCurl.h
|
||||
|
@ -61,7 +6,7 @@ index 1bdaae1..9e78a91 100644
|
|||
virtual CURLMcode multi_fdset(CURLM *multi_handle, fd_set *read_fd_set, fd_set *write_fd_set, fd_set *exc_fd_set, int *max_fd)=0;
|
||||
virtual CURLMcode multi_timeout(CURLM *multi_handle, long *timeout)=0;
|
||||
virtual CURLMsg* multi_info_read(CURLM *multi_handle, int *msgs_in_queue)=0;
|
||||
- virtual void multi_cleanup(CURLM * handle )=0;
|
||||
- virtual void multi_cleanup(CURL_HANDLE * handle )=0;
|
||||
+ virtual CURLMcode multi_cleanup(CURLM * handle )=0;
|
||||
virtual struct curl_slist* slist_append(struct curl_slist *, const char *)=0;
|
||||
virtual void slist_free_all(struct curl_slist *)=0;
|
||||
|
|
|
@ -19,7 +19,7 @@ pkgbase=kodi
|
|||
pkgname=('kodi' 'kodi-eventclients')
|
||||
pkgver=16.1
|
||||
_codename=Jarvis
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://kodi.tv"
|
||||
license=('GPL2')
|
||||
|
@ -41,7 +41,7 @@ source=(
|
|||
sha256sums=(
|
||||
'7d82c8aff2715c83deecdf10c566e26105bec0473af530a1356d4c747ebdfd10'
|
||||
'b0fe75d10b2678894d1dec48f3258c0bec2a4a170f33d76a9a8334bb1969b18f'
|
||||
'947119637577abb77fdac6173fea05b0a4524928d344e3b3f0ed328e51b3e596'
|
||||
'870037ddedc09f161db16df8550e1b0eaaa67a8bdfe47e7151bc9ee25c9bfead'
|
||||
)
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue