extra/cantor to 18.08.0-3

This commit is contained in:
Kevin Mihelich 2018-08-19 23:36:48 +00:00
parent e4e47a8b0a
commit 1f05247eeb
2 changed files with 41 additions and 3 deletions

View file

@ -8,7 +8,7 @@
pkgname=cantor
pkgver=18.08.0
pkgrel=2
pkgrel=3
pkgdesc="KDE Frontend to Mathematical Software"
url="https://kde.org/applications/education/cantor/"
arch=(x86_64)
@ -24,10 +24,11 @@ optdepends=('maxima: Maxima backend'
'python2: Python 2 backend'
'sagemath: SageMath backend')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
cantor-julia.patch::"https://cgit.kde.org/cantor.git/patch/?id=90b001d1")
cantor-julia.patch::"https://cgit.kde.org/cantor.git/patch/?id=90b001d1" cantor-julia-0.7.patch)
sha256sums=('be6167ec88504091e9fa9914e0bd1fbb13637fb2b2b228c9274225db6dc85823'
'SKIP'
'366e1a734a968c4a933e91342308e4d18108c1bc023572848747ca6a2ec656f7')
'366e1a734a968c4a933e91342308e4d18108c1bc023572848747ca6a2ec656f7'
'cf031eb1891a97f964c9147a4ff4d7e69f3821eee8fb5dab0693c6483dacd4ee')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
@ -36,6 +37,7 @@ prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../cantor-julia.patch # Fix julia backend build
patch -p1 -i ../cantor-julia-0.7.patch # support julia>=0.7
}
build() {

View file

@ -0,0 +1,36 @@
diff --git a/cmake/FindJulia.cmake b/cmake/FindJulia.cmake
index 77c9f7f8..2d4e1f6a 100644
--- a/cmake/FindJulia.cmake
+++ b/cmake/FindJulia.cmake
@@ -1,7 +1,7 @@
if(JULIA_FOUND)
return()
endif()
-
+
# Find julia executable
find_program(JULIA_EXECUTABLE julia DOC "Julia executable")
@@ -31,8 +31,14 @@ endif()
#
# Julia includes
#
+if(${JULIA_VERSION_STRING} VERSION_LESS 0.7.0)
+ set(JULIA_BINDIR "JULIA_HOME")
+else()
+ set(JULIA_BINDIR "Sys.BINDIR")
+endif()
+
execute_process(
- COMMAND ${JULIA_EXECUTABLE} -E "joinpath(match(r\"(.*)(bin)\",JULIA_HOME).captures[1],\"include\",\"julia\")"
+ COMMAND ${JULIA_EXECUTABLE} -E "joinpath(match(r\"(.*)(bin)\",${JULIA_BINDIR}).captures[1],\"include\",\"julia\")"
OUTPUT_VARIABLE JULIA_INCLUDE_DIRS
# COMMAND ${JULIA_EXECUTABLE} -E "abspath(joinpath(JULIA_HOME, \"../..\", \"src\"))"
# OUTPUT_VARIABLE JULIA_INCLUDE_DIRS
@@ -80,4 +86,4 @@ find_package_handle_standard_args(
REQUIRED_VARS JULIA_LIBRARY JULIA_LIBRARY_DIR JULIA_INCLUDE_DIRS
VERSION_VAR JULIA_VERSION_STRING
FAIL_MESSAGE "Julia not found"
-)
\ No newline at end of file
+)