mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/pipewire to 0.3.8-2
This commit is contained in:
parent
6921cbd165
commit
1f0a32b1ed
2 changed files with 14 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
From 0d037e8f639471f388581926877556fd6d882d28 Mon Sep 17 00:00:00 2001
|
||||
From ff849ed1b0d254afa4dd591ca01d8d74c03344ec Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 11 Mar 2020 07:28:28 -0600
|
||||
Subject: [PATCH] atomic
|
||||
|
@ -8,11 +8,11 @@ Subject: [PATCH] atomic
|
|||
1 file changed, 22 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pipewire-jack/src/meson.build b/pipewire-jack/src/meson.build
|
||||
index e52349ed..c42a792d 100644
|
||||
index a052eaa8..1f08f0a5 100644
|
||||
--- a/pipewire-jack/src/meson.build
|
||||
+++ b/pipewire-jack/src/meson.build
|
||||
@@ -31,13 +31,34 @@ configure_file(input : 'pw-jack.in',
|
||||
install: true,
|
||||
@@ -33,13 +33,34 @@ configure_file(input : 'pw-jack.in',
|
||||
configuration : tools_config,
|
||||
install_dir : pipewire_bindir)
|
||||
|
||||
+# Check for GCC style atomics
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend on valgrind
|
||||
|
@ -7,8 +7,8 @@
|
|||
|
||||
pkgbase=pipewire
|
||||
pkgname=(pipewire pipewire-docs pipewire-jack pipewire-pulse pipewire-alsa)
|
||||
pkgver=0.3.7
|
||||
pkgrel=1
|
||||
pkgver=0.3.8
|
||||
pkgrel=2
|
||||
pkgdesc="Server and user space API to deal with multimedia pipelines"
|
||||
url="https://pipewire.org"
|
||||
license=(LGPL2.1)
|
||||
|
@ -16,11 +16,11 @@ arch=(x86_64)
|
|||
makedepends=(git meson doxygen graphviz xmltoman jack2 libpulse
|
||||
alsa-lib gstreamer gst-plugins-base sbc rtkit vulkan-icd-loader
|
||||
dbus libsndfile bluez-libs vulkan-headers)
|
||||
_commit=0b3e9edaa2a155b6f1d1189a2dadbdb568c05ab1 # tags/0.3.7
|
||||
_commit=229fad46914a32b621e88e53abd1270c62b0e158 # tags/0.3.8^0
|
||||
source=("git+https://github.com/PipeWire/pipewire#commit=$_commit"
|
||||
0001-atomic.patch)
|
||||
sha256sums=('SKIP'
|
||||
'5ff6323570a6a4956a073861015ee90793617affb52892dbfacb8c2424605813')
|
||||
'4453fecf0fc9dbb3399018e43f032d2f178f521f4d44482be87ff207b8d9e789')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgbase
|
||||
|
@ -29,13 +29,17 @@ pkgver() {
|
|||
|
||||
prepare() {
|
||||
cd $pkgbase
|
||||
|
||||
# Fix infinite loop when disconnecting ALSA device
|
||||
git cherry-pick -n d2452e1340038539bfbe3948fe61fe8a7b214f85
|
||||
|
||||
patch -p1 -i ../0001-atomic.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
arch-meson $pkgbase build \
|
||||
-D docs=true \
|
||||
-D man=true
|
||||
-D udevrulesdir=/usr/lib/udev/rules.d
|
||||
|
||||
meson compile -C build
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue