community/gdc fix

This commit is contained in:
Kevin Mihelich 2015-12-24 18:49:10 +00:00
parent 5bfae636b7
commit 1f1a02be1d
2 changed files with 9 additions and 11 deletions

View file

@ -17,18 +17,16 @@ makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'automake')
options=('!emptydirs' '!buildflags') options=('!emptydirs' '!buildflags')
source=( source=(
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2" "ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
"gdc::git://github.com/D-Programming-GDC/GDC.git#tag=v2.066.1_gcc5" "gdc::git://github.com/D-Programming-GDC/GDC.git#commit=42c4f6c"
"git+https://github.com/D-Programming-GDC/GDMD.git" "git+https://github.com/D-Programming-GDC/GDMD.git"
"folders.diff" "folders.diff"
"system_zlib.diff" "system_zlib.diff"
) )
sha256sums=( sha256sums=('b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db'
'b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db' 'SKIP'
'SKIP' 'SKIP'
'SKIP' 'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20' '4c679ac426a841182215654f5555c0294449e4fde107da0e0f6c2dbb6476f0b2')
'1bf81cde6a7bad096f76db2f20ad8ab2801cd0ab2dd2fa0219503073e8dae480'
)
groups=('dlang' 'dlang-gdc') groups=('dlang' 'dlang-gdc')
conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git') conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git')

View file

@ -1,7 +1,7 @@
diff --git a/gcc/d/d-spec.cc b/gcc/d/d-spec.cc diff --git a/gcc/d/d-spec.c b/gcc/d/d-spec.c
index a43cb34..e4bb527 100644 index a43cb34..e4bb527 100644
--- a/gcc/d/d-spec.cc --- a/gcc/d/d-spec.c
+++ b/gcc/d/d-spec.cc +++ b/gcc/d/d-spec.c
@@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options, @@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
/* The number of arguments being added to what's in argv, other than /* The number of arguments being added to what's in argv, other than
libraries. We use this to track the number of times we've inserted libraries. We use this to track the number of times we've inserted