mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed extra/subversion, local changes no longer needed
This commit is contained in:
parent
f0c3b76555
commit
1f3689d080
7 changed files with 0 additions and 2554 deletions
|
@ -1,92 +0,0 @@
|
|||
# $Id: PKGBUILD 103462 2010-12-19 17:12:50Z paul $
|
||||
# Maintainer: Paul Mattal <paul@archlinux.org>
|
||||
# Contributor: Jason Chu <jason@archlinux.org>
|
||||
|
||||
# PlugApps: - removed Gnome, KDE components, and javahl.
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=subversion
|
||||
pkgver=1.6.15
|
||||
pkgrel=1
|
||||
pkgdesc="Replacement for CVS, another versioning system (SVN)"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('apache' 'bsd')
|
||||
depends=('neon' 'apr-util')
|
||||
makedepends=('heimdal' 'apache' 'python2' 'perl' 'swig' 'ruby'
|
||||
'autoconf' 'sqlite3' 'db' 'e2fsprogs')
|
||||
source=(http://subversion.tigris.org/downloads/$pkgname-$pkgver.tar.bz2
|
||||
svnserve svn svnserve.conf svnmerge.py
|
||||
subversion.rpath.fix.patch
|
||||
subversion.suppress.deprecation.warnings.patch)
|
||||
|
||||
backup=('etc/xinetd.d/svn' 'etc/conf.d/svnserve')
|
||||
url="http://subversion.apache.org/"
|
||||
provides=('svn')
|
||||
options=('!makeflags' '!libtool')
|
||||
optdepends=('bash-completion: for svn bash completion')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
export PYTHON=/usr/bin/python2
|
||||
|
||||
# apply patches
|
||||
patch -p0 < $srcdir/subversion.rpath.fix.patch
|
||||
patch -p1 -i $srcdir/subversion.suppress.deprecation.warnings.patch
|
||||
|
||||
# configure
|
||||
autoreconf
|
||||
./configure --prefix=/usr --with-apr=/usr --with-apr-util=/usr \
|
||||
--with-zlib=/usr --with-neon=/usr --with-apxs \
|
||||
--with-sqlite=/usr --with-berkeley-db=:/usr/include/:/usr/lib:db-5.1
|
||||
|
||||
# build
|
||||
(make external-all && make LT_LDFLAGS="-L$Fdestdir/usr/lib" local-all )
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
# install
|
||||
export LD_LIBRARY_PATH=${pkgdir}/usr/lib:$LD_LIBRARY_PATH
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
make DESTDIR=${pkgdir} swig-py
|
||||
make install-swig-py DESTDIR=${pkgdir}
|
||||
|
||||
install -d ${pkgdir}/usr/lib/python2.7
|
||||
mv ${pkgdir}/usr/lib/svn-python/ ${pkgdir}/usr/lib/python2.7/site-packages
|
||||
|
||||
install -d ${pkgdir}/usr/share/subversion
|
||||
install -d -m 755 tools/hook-scripts ${pkgdir}/usr/share/subversion/
|
||||
rm -f ${pkgdir}/usr/share/subversion/hook-scripts/*.in
|
||||
|
||||
make DESTDIR=${pkgdir} swig-pl
|
||||
make install-swig-pl DESTDIR=${pkgdir} INSTALLDIRS=vendor
|
||||
rm -f ${pkgdir}/usr/lib/perl5/vendor_perl/auto/SVN/_Core/.packlist
|
||||
rm -rf ${pkgdir}/usr/lib/perl5/core_perl
|
||||
|
||||
make DESTDIR=${pkgdir} swig-rb
|
||||
make install-swig-rb DESTDIR=${pkgdir}
|
||||
|
||||
install -d ${pkgdir}/etc/{rc.d,xinetd.d,conf.d}
|
||||
|
||||
install -m 755 ${srcdir}/svnserve ${pkgdir}/etc/rc.d
|
||||
install -m 644 ${srcdir}/svn ${pkgdir}/etc/xinetd.d
|
||||
install -m 644 ${srcdir}/svnserve.conf ${pkgdir}/etc/conf.d/svnserve
|
||||
install -m 755 ${srcdir}/svnmerge.py ${pkgdir}/usr/bin/svnmerge
|
||||
install -D -m 644 ${srcdir}/subversion-$pkgver/COPYING \
|
||||
${pkgdir}/usr/share/licenses/$pkgname/LICENSE
|
||||
|
||||
# bash completion
|
||||
install -Dm 644 ${srcdir}/${pkgname}-${pkgver}/tools/client-side/bash_completion \
|
||||
${pkgdir}/etc/bash_completion.d/subversion
|
||||
}
|
||||
md5sums=('113fca1d9e4aa389d7dc2b210010fa69'
|
||||
'a2b029e8385007ffb99b437b30521c90'
|
||||
'a0db6dd43af33952739b6ec089852630'
|
||||
'c459e299192552f61578f3438abf0664'
|
||||
'a6371baeda7e224504629ecdda2749b4'
|
||||
'6b4340ba9d8845cd8497e013ae01be3f'
|
||||
'1166f3b7413d7e7450299b3525680bbe')
|
|
@ -1,10 +0,0 @@
|
|||
--- Makefile.in.orig 2009-02-16 14:10:48.000000000 -0200
|
||||
+++ Makefile.in 2009-06-04 00:56:29.000000000 -0300
|
||||
@@ -678,6 +678,7 @@
|
||||
|
||||
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
|
||||
cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
|
||||
+ cd $(SWIG_PL_DIR)/native; sed -i 's|LD_RUN_PATH|DIE_RPATH_DIE|g' Makefile{,.{client,delta,fs,ra,repos,wc}}
|
||||
|
||||
swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
|
||||
$(SWIG_PL_DIR)/native/Makefile
|
|
@ -1,22 +0,0 @@
|
|||
diff -urN subversion-1.6.9/subversion/bindings/swig/python/svn/core.py subversion-1.6.9-fixed/subversion/bindings/swig/python/svn/core.py
|
||||
--- subversion-1.6.9/subversion/bindings/swig/python/svn/core.py 2009-02-13 11:22:26.000000000 -0500
|
||||
+++ subversion-1.6.9-fixed/subversion/bindings/swig/python/svn/core.py 2010-02-08 07:46:29.000000000 -0500
|
||||
@@ -19,6 +19,7 @@
|
||||
from libsvn.core import *
|
||||
import libsvn.core as _libsvncore
|
||||
import atexit as _atexit
|
||||
+import warnings
|
||||
|
||||
class SubversionException(Exception):
|
||||
def __init__(self, message=None, apr_err=None, child=None,
|
||||
@@ -44,7 +45,9 @@
|
||||
Exception.__init__(self, *args)
|
||||
|
||||
self.apr_err = apr_err
|
||||
- self.message = message
|
||||
+ with warnings.catch_warnings():
|
||||
+ warnings.simplefilter("ignore", DeprecationWarning)
|
||||
+ self.message = message
|
||||
self.child = child
|
||||
self.file = file
|
||||
self.line = line
|
|
@ -1,11 +0,0 @@
|
|||
service svn
|
||||
{
|
||||
flags = REUSE
|
||||
socket_type = stream
|
||||
wait = no
|
||||
user = root
|
||||
server = /usr/bin/svnserve
|
||||
server_args = -i
|
||||
log_on_failure += USERID
|
||||
disable = yes
|
||||
}
|
File diff suppressed because it is too large
Load diff
|
@ -1,42 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
. /etc/rc.conf
|
||||
. /etc/rc.d/functions
|
||||
. /etc/conf.d/svnserve
|
||||
|
||||
PID=`pidof -o %PPID /usr/bin/svnserve`
|
||||
case "$1" in
|
||||
start)
|
||||
stat_busy "Starting svnserve"
|
||||
if [ -z "$PID" ]; then
|
||||
if [ -n "$SVNSERVE_USER" ]; then
|
||||
su -s '/bin/sh' $SVNSERVE_USER -c "/usr/bin/svnserve -d $SVNSERVE_ARGS" &
|
||||
else
|
||||
/usr/bin/svnserve -d $SVNSERVE_ARGS &
|
||||
fi
|
||||
fi
|
||||
if [ ! -z "$PID" -o $? -gt 0 ]; then
|
||||
stat_fail
|
||||
else
|
||||
add_daemon svnserve
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
stop)
|
||||
stat_busy "Stopping svnserve"
|
||||
[ ! -z "$PID" ] && kill $PID &> /dev/null
|
||||
if [ $? -gt 0 ]; then
|
||||
stat_fail
|
||||
else
|
||||
rm_daemon svnserve
|
||||
stat_done
|
||||
fi
|
||||
;;
|
||||
restart)
|
||||
$0 stop
|
||||
sleep 1
|
||||
$0 start
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 {start|stop|restart}"
|
||||
esac
|
|
@ -1,7 +0,0 @@
|
|||
#
|
||||
# Parameters to be passed to svnserve
|
||||
#
|
||||
#SVNSERVE_ARGS="-r /path/to/some/repos"
|
||||
SVNSERVE_ARGS=""
|
||||
|
||||
#SVNSERVE_USER="svn"
|
Loading…
Reference in a new issue