extra/mesa to 23.0.3-1

This commit is contained in:
Kevin Mihelich 2023-04-24 12:46:32 +00:00
parent bf967486f7
commit 1f36a3b073
2 changed files with 36 additions and 5 deletions

View file

@ -0,0 +1,23 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Sat, 22 Apr 2023 01:21:20 +0000
Subject: [PATCH] rusticl: Fix bindgen invocation
The deprecated `--size_t-is-usize` was removed in bindgen 0.65.1, being
enabled by default.
---
src/gallium/frontends/rusticl/meson.build | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/gallium/frontends/rusticl/meson.build b/src/gallium/frontends/rusticl/meson.build
index e53b50a9b8b8..9fa024cb8db4 100644
--- a/src/gallium/frontends/rusticl/meson.build
+++ b/src/gallium/frontends/rusticl/meson.build
@@ -92,7 +92,6 @@ rusticl_gen_args = [
rusticl_bindgen_args = [
'--no-convert-floats',
'--use-array-pointers-in-arguments',
- '--size_t-is-usize',
'--default-enum-style', 'rust',
'--with-derive-partialeq',
'--with-derive-eq',

View file

@ -14,32 +14,36 @@ highmem=1
pkgbase=mesa
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-virtio' 'vulkan-broadcom' 'vulkan-panfrost' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
pkgdesc="An open-source implementation of the OpenGL specification"
pkgver=23.0.2
pkgrel=2
pkgver=23.0.3
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
'libomxil-bellagio' 'libclc' 'clang' 'libglvnd' 'libunwind' 'lm_sensors' 'libxrandr'
'systemd' 'valgrind' 'glslang' 'vulkan-icd-loader' 'directx-headers' 'cmake' 'meson')
makedepends+=('rust' 'rust-bindgen' 'spirv-tools' 'spirv-llvm-translator') # rusticl dependencies
makedepends+=('python-ply' 'spirv-llvm-translator') # intel-clc dependencies
makedepends+=('rust' 'rust-bindgen' 'spirv-tools') # rusticl dependencies
url="https://www.mesa3d.org/"
license=('custom')
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
0001-intel-fs-fix-scheduling-of-HALT-instructions.patch
0002-egl-wayland-Fix-destruction-of-event-queue-with-prox.patch
0003-vulkan-wsi-wayland-Fix-destruction-of-event-queue-wi.patch
0004-rusticl-Fix-bindgen-invocation.patch
LICENSE)
sha256sums=('1b7d3399fc6f16f030361f925d33ebc7600cbf98094582f54775b6a1180529e7'
sha256sums=('386362a5d80df3b096636b67f340e1ce67b705b44767d5bdd11d2ed1037192d5'
'SKIP'
'dc6790b5be0e80c23e74ae18ca1a2b40f57f4211cc7b645bf22b63af3b790e40'
'c25493de3e5930702acf833d182aeca0895d6a9d9e830dca15c42d130e25c41c'
'db2be7ae0540d65e77449eda1af66200e27af382183fdcd0c87f99db3520b80a'
'b3aaccd6ce5c6d417801baafa056d4dfb2a13bf9b480fb980e9af6d0d071cedb'
'7052ba73bb07ea78873a2431ee4e828f4e72bda7d176d07f770fa48373dec537')
b2sums=('5a90fcd8b7096dde1e6c82b9bb5b00622cc1cf35e4308419441d3489d66ed322843db89f2f1162c8c30f6bcddbce867447f83425a29145bd42a742b773ec1258'
b2sums=('e716d9ddce3da649239c1bc37ec208b9669f316f6b547ca0c69937043f371f0d59ead34fec427297171916045061ddb8783d126f6dec5ece90a0719003fe2c40'
'SKIP'
'37d1d070c45c85bce8abe3524a3f8d9ac9ed6326a3eec653cd89fffce3630b08eb9b96b11aeb495488230449c99f9b508f73a15e53265d2b159286b0e2dda7cc'
'ae891637318fdbb8dd58285098af7bea709fb032969a5671eb225a4a471bf9422fac2a6cb0fd188aad96ea5a03eb043f646f5d371dd655a100046adb1c91bd7d'
'a7312e0931904e659b3d33fcb37b13bcadab943c6040dd2b58ea191db350b50c1ba588e334b7e59b513bd6155797e29dc1bd1a6a35a278b3824d06534f2c9d17'
'58c374ae45f84996a7bf248d0f2dd97fb003f30b2ecda5654561679b90c53830efdff10f990295390cdf8d9d676deeb756b3037c070966a6441670bf8dcb2223'
'1ecf007b82260710a7bf5048f47dd5d600c168824c02c595af654632326536a6527fbe0738670ee7b921dd85a70425108e0f471ba85a8e1ca47d294ad74b4adb')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
@ -63,6 +67,9 @@ prepare() {
# https://bugs.archlinux.org/task/78142
# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21647
patch -Np1 -i ../0003-vulkan-wsi-wayland-Fix-destruction-of-event-queue-wi.patch
# Fix build failure with rust-bindgen 0.65.1
patch -Np1 -i ../0004-rusticl-Fix-bindgen-invocation.patch
}
build() {
@ -103,6 +110,7 @@ build() {
-D lmsensors=enabled \
-D osmesa=true \
-D shared-glapi=enabled \
-D intel-clc=disabled \
-D microsoft-clc=disabled \
-D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc \
-D valgrind=enabled