mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
Fixed glibc conflict with tzdata, more ABS-vanilla-like
This commit is contained in:
parent
716bd39086
commit
1fa6ef5da1
2 changed files with 29 additions and 7 deletions
|
@ -1,11 +1,11 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
|
||||
# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
|
||||
|
||||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
|
||||
# NOTE: valgrind requires rebuilt with each new glibc version
|
||||
|
||||
pkgname=glibc
|
||||
pkgver=2.11
|
||||
pkgrel=7
|
||||
pkgrel=8
|
||||
pkgdesc="GNU C Library"
|
||||
arch=('arm')
|
||||
url="http://www.gnu.org/software/libc"
|
||||
|
@ -19,12 +19,14 @@ backup=(etc/locale.gen
|
|||
install=glibc.install
|
||||
source=(http://ftp.gnu.org/gnu/glibc/$pkgname-$pkgver.tar.gz
|
||||
http://ftp.gnu.org/gnu/glibc/$pkgname-ports-$pkgver.tar.gz
|
||||
glibc-2.10-dont-build-timezone.patch
|
||||
nscd
|
||||
locale.gen.txt
|
||||
locale-gen)
|
||||
locale-gen)
|
||||
|
||||
md5sums=('55d50abb2d7c366bde6fb5e35e681f9b'
|
||||
'7100d8ba81c52e90e7fb4795d2f736c9'
|
||||
'4dadb9203b69a3210d53514bb46f41c3'
|
||||
'b587ee3a70c9b3713099295609afde49'
|
||||
'1dfde0f12c99c7ec4d4054caf8ee5373'
|
||||
'476e9113489f93b348b21e144b6a8fcf')
|
||||
|
@ -34,6 +36,12 @@ build() {
|
|||
cd ${srcdir}/glibc
|
||||
ln -s $srcdir/glibc-ports-2.11 $srcdir/glibc
|
||||
|
||||
# From here on out, it's the same PKGBUILD as vanilla
|
||||
# With the ./configure armv5te exception
|
||||
|
||||
# timezone data is in separate package (tzdata)
|
||||
patch -Np1 -i ${srcdir}/glibc-2.10-dont-build-timezone.patch || return 1
|
||||
|
||||
install -dm755 ${pkgdir}/etc
|
||||
touch ${pkgdir}/etc/ld.so.conf
|
||||
|
||||
|
@ -62,15 +70,16 @@ build() {
|
|||
--without-selinux
|
||||
|
||||
make || return 1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/glibc/glibc-build
|
||||
make install_root=${pkgdir} install || return 1
|
||||
|
||||
# provided by linux-api-headers
|
||||
rm ${pkgdir}/usr/include/scsi/scsi.h
|
||||
|
||||
# provided by tzdata
|
||||
rm ${pkgdir}/usr/share/zoneinfo
|
||||
|
||||
rm ${pkgdir}/etc/ld.so.cache ${pkgdir}/etc/ld.so.conf ${pkgdir}/etc/localtime
|
||||
rm ${pkgdir}/etc/ld.so.cache ${pkgdir}/etc/ld.so.conf
|
||||
|
||||
install -dm755 ${pkgdir}/etc/rc.d
|
||||
install -dm755 ${pkgdir}/usr/sbin
|
||||
|
|
13
core/glibc/glibc-2.10-dont-build-timezone.patch
Executable file
13
core/glibc/glibc-2.10-dont-build-timezone.patch
Executable file
|
@ -0,0 +1,13 @@
|
|||
timezone data has been split into the package sys-libs/timezone-data
|
||||
|
||||
--- glibc-2.4/Makeconfig
|
||||
+++ glibc-2.4/Makeconfig
|
||||
@@ -931,7 +931,7 @@
|
||||
stdlib stdio-common libio malloc string wcsmbs time dirent \
|
||||
grp pwd posix io termios resource misc socket sysvipc gmon \
|
||||
gnulib iconv iconvdata wctype manual shadow gshadow po argp \
|
||||
- crypt nss localedata timezone rt conform debug \
|
||||
+ crypt nss localedata rt conform debug \
|
||||
$(add-on-subdirs) $(dlfcn) $(binfmt-subdir)
|
||||
|
||||
ifndef avoid-generated
|
Loading…
Reference in a new issue