extra/valgrind to 3.14.0-1

This commit is contained in:
Kevin Mihelich 2018-10-24 23:31:02 +00:00
parent 5660dd9c84
commit 1fdc2eec74
2 changed files with 4 additions and 38 deletions

View file

@ -11,7 +11,8 @@ buildarch=12
#noautobuild=1
pkgname=valgrind
pkgver=3.13.0+290+2b0aa0a5
_commit=3a3000290b4af0e8ef9880293c54659a6819ba78
pkgver=3.14.0
pkgrel=1
pkgdesc='Tool to help find memory-management problems in programs'
arch=('x86_64')
@ -25,8 +26,7 @@ optdepends=('openmpi: MPI support')
provides=('valgrind-multilib')
replaces=('valgrind-multilib')
options=('!emptydirs' '!strip')
_commit=2b0aa0a5b88f900e986a3360952fcb3d2513419d
source=(git+http://repo.or.cz/valgrind.git#commit=$_commit
source=("git+http://repo.or.cz/valgrind.git#commit=$_commit"
valgrind-3.7.0-respect-flags.patch
valgrind-3.13.0-arm64-hwcap.patch)
md5sums=('SKIP'
@ -38,10 +38,7 @@ sha512sums=('SKIP'
pkgver() {
cd valgrind
local _basever=${pkgver%%+*}
local _count="$(git rev-list --count svn/VALGRIND_${_basever//./_}..master)"
printf "%s+%s+%s" $_basever $_count ${_commit:0:8}
git describe --tags --always|sed -e 's|-|+|g' -e 's|VALGRIND_||g' -e 's|_|.|g'
}
prepare() {

View file

@ -1,31 +0,0 @@
diff --git a/coregrind/m_syswrap/syswrap-amd64-linux.c b/coregrind/m_syswrap/syswrap-amd64-linux.c
index 0f2ad8c51..407af7f76 100644
--- a/coregrind/m_syswrap/syswrap-amd64-linux.c
+++ b/coregrind/m_syswrap/syswrap-amd64-linux.c
@@ -249,6 +249,7 @@ PRE(sys_rt_sigreturn)
PRE(sys_arch_prctl)
{
ThreadState* tst;
+ Bool known_option = True;
PRINT( "arch_prctl ( %ld, %lx )", SARG1, ARG2 );
vg_assert(VG_(is_valid_tid)(tid));
@@ -283,13 +284,16 @@ PRE(sys_arch_prctl)
POST_MEM_WRITE(ARG2, sizeof(unsigned long));
}
else {
- VG_(core_panic)("Unsupported arch_prctl option");
+ known_option = False;
}
/* Note; the Status writeback to guest state that happens after
this wrapper returns does not change guest_FS_CONST or guest_GS_CONST;
hence that direct assignment to the guest state is safe here. */
- SET_STATUS_Success( 0 );
+ if (known_option)
+ SET_STATUS_Success( 0 );
+ else
+ SET_STATUS_Failure( VKI_EINVAL );
}
// Parts of this are amd64-specific, but the *PEEK* cases are generic.