mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/chromium to 46.0.2490.71-1
This commit is contained in:
parent
2fe806b923
commit
1ff74c4b2a
2 changed files with 7 additions and 43 deletions
|
@ -1,36 +0,0 @@
|
|||
From 241364c6f4d44165ce2dc707b9ad141dcc880d1b Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Sat, 27 Jun 2015 13:29:52 -0700
|
||||
Subject: [PATCH] Demand for newer POSIX macro
|
||||
|
||||
Reason for change: Define _POSIX_C_SOURCE such that it demands correct
|
||||
posix interfaces, netdb.h declares interfaces such as
|
||||
getaddrinfo if __USE_POSIX, i.e. POSIX.1:1990 or later.
|
||||
However, these interfaces were new in the 2001 edition of POSIX
|
||||
therefore ask for Extension from POSIX.1:2001 since we use addrinfo
|
||||
structure here.
|
||||
|
||||
Change-Id: Icb1c92745d1a0ca958108ae80c270c630628729e
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
Reviewed-on: https://boringssl-review.googlesource.com/5253
|
||||
Reviewed-by: Adam Langley <agl@google.com>
|
||||
---
|
||||
crypto/bio/socket_helper.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/crypto/bio/socket_helper.c b/crypto/bio/socket_helper.c
|
||||
index b1cdd1a..481278f 100644
|
||||
--- a/crypto/bio/socket_helper.c
|
||||
+++ b/crypto/bio/socket_helper.c
|
||||
@@ -12,7 +12,7 @@
|
||||
* OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
|
||||
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
|
||||
|
||||
-#define _POSIX_SOURCE
|
||||
+#define _POSIX_C_SOURCE 200112L
|
||||
|
||||
#include <openssl/bio.h>
|
||||
#include <openssl/err.h>
|
||||
--
|
||||
2.5.0
|
||||
|
|
@ -18,8 +18,8 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=45.0.2454.101
|
||||
pkgrel=2
|
||||
pkgver=46.0.2490.71
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('armv6h' 'armv7h')
|
||||
|
@ -41,14 +41,12 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium.desktop
|
||||
arm-webrtc-fix.patch
|
||||
chromium-arm-r0.patch
|
||||
0001-Demand-for-newer-POSIX-macro.patch
|
||||
chromium-widevine.patch)
|
||||
sha256sums=('1b682dcaae9c89b2ebfdb192bb2f73c78c5b30a55103e7198fa3c1e21fed85fb'
|
||||
sha256sums=('cd4b18249e64ee267236c9d4578effe810bf8f47567e2d43a5a8a7613787dcb6'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'9db0f01517c52e3236ff52e8a664840542a19144a54923ae6aabea3dcfa92c52'
|
||||
'df4be49770d508b772f98eda9fc5f37fa71d4c0459437e12f7f3db5892aa1611'
|
||||
'd908939b10161efe658f0f82d2c132bf28dff54e08f02c6fed93815c3656f328'
|
||||
'379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -63,8 +61,8 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
|
|||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Fix BoringSSL build with glibc 2.22 (FS#45965)
|
||||
patch -Np1 -d third_party/boringssl/src < ../0001-Demand-for-newer-POSIX-macro.patch
|
||||
# https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/9JX1N2nf4PU/discussion
|
||||
touch chrome/test/data/webui/i18n_process_css_test.html
|
||||
|
||||
# Enable support for the Widevine CDM plugin
|
||||
# The actual libraries are not included, but can be copied over from Chrome:
|
||||
|
@ -156,6 +154,8 @@ build() {
|
|||
-Dtarget_arch=arm
|
||||
-Darm_neon=1
|
||||
-Dlogging_like_official_build=1
|
||||
-Dtracing_like_official_build=1
|
||||
-Dfieldtrial_testing_like_official_build=1
|
||||
-Ddisable_nacl=1
|
||||
-Ddisable_pnacl=1
|
||||
-Dv8_use_arm_eabi_hardfloat=true
|
||||
|
|
Loading…
Reference in a new issue