diff --git a/core/linux-raspberrypi4/PKGBUILD b/core/linux-raspberrypi4/PKGBUILD
index f6073a82f..0a2f13d58 100644
--- a/core/linux-raspberrypi4/PKGBUILD
+++ b/core/linux-raspberrypi4/PKGBUILD
@@ -6,12 +6,12 @@
 buildarch=12
 
 pkgbase=linux-raspberrypi4
-_commit=16991af20bd821ecba1eae2fe11ddbcafa18f164
+_commit=13c43880f2ee6db7d26949cb6a3e8db1a4b76736
 _srcname=linux-${_commit}
 _kernelname=${pkgbase#linux}
 _desc="Raspberry Pi 4"
 pkgver=5.10.23
-pkgrel=1
+pkgrel=2
 arch=('armv7h' 'aarch64')
 url="http://www.kernel.org/"
 license=('GPL2')
@@ -23,17 +23,17 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
         '60-linux.hook'
         '90-linux.hook'
         0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
-        0002-vc4_place-dont-reject-fractional-source-coords.patch::https://github.com/popcornmix/linux/commit/ab3ef7a300c5e3e8a15a51e9de0bafeecf863be3.patch
+        0002-vc4-drm-vc4_plane-remove-subpixel-positioning-check.patch::https://patch-diff.githubusercontent.com/raw/raspberrypi/linux/pull/4215.patch
         )
 source_armv7h=('config' 'config.txt')
 source_aarch64=('config8' 'config8.txt')
-md5sums=('ea03d792c54c81671b7d7a9980108872'
+md5sums=('d7be2334df48ecbe08841cf43d76f7dc'
          '31c02f4518d46deb5f0c2ad1f8b083cd'
          '86d4a35722b5410e3b29fc92dae15d4b'
          'ce6c81ad1ad1f8b333fd6077d47abdaf'
          '441ec084c47cddc53e592fb0cbce4edf'
          'f66a7ea3feb708d398ef57e4da4815e9'
-         '78ad3b6ff01ebb09ce35214e23ff9ada')
+         'ce0949a5704dfcddc25382118600e813')
 md5sums_armv7h=('564213efed2fedecef1ea219c102cf2b'
                 '9669d916a5929a2eedbd64477f83d99e')
 md5sums_aarch64=('4e701f76ed19fb6072b3857d2ac6210c'
@@ -55,7 +55,7 @@ prepare() {
   sed -i '2iexit 0' scripts/depmod.sh
 
   patch -Np1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
-  patch -Np1 -i ../0002-vc4_place-dont-reject-fractional-source-coords.patch
+  patch -Np1 -i ../0002-vc4-drm-vc4_plane-remove-subpixel-positioning-check.patch
 }
 
 build() {